LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk
User Name
Password
Zenwalk This forum is for the discussion of Zenwalk Linux.

Notices

Reply
 
Search this Thread
Old 10-11-2006, 07:54 AM   #1
missmoondog
Member
 
Registered: Oct 2005
Distribution: Zenwalk 3.0
Posts: 34

Rep: Reputation: 15
shut down/power off


have 2 hp pavilions (6736 & 6835) that don't fully shutdown. they shut down to the point off turning off the power and then just sets. i have to push the button on the tower to turn it off. feels like i back in windows 95 days!

i know i've seen a thread somewhere around, not sure if it's here on on the zenwalk community forums, but i can't find it again.


also, both of these computers get a video mode error on startup saying something along the lines of i have entered a bad paramater(?) i then get the option of seeing available video modes, which i don't have a clue as to what to enter, or wait 30 seconds. if i just hit the spacebar, they boot fine.

both machines are intel celeron i810's.

any help is appreciated. thanks
 
Old 10-11-2006, 09:04 AM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,433

Rep: Reputation: 83
Hi,

I had similar problem a while ago. It was some kernel paramter setting, which I do not remember now.

Happy Penguins
 
Old 10-11-2006, 09:42 AM   #3
slackperson
LQ Newbie
 
Registered: Feb 2006
Posts: 12

Rep: Reputation: 0
Smile error

The error you are seeing in based on a lilo parameter that defines a console resolution at startup. Don't worry, it is nothing to worry about. I'm not sure how to stop it,though.
 
Old 10-11-2006, 09:50 AM   #4
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,433

Rep: Reputation: 83
Hya,

:0

Similar problem I had was "not shutdown"

It was somewehre power management and shutdown/suspend or somethin like that.

Have a happy penguin!
 
Old 10-11-2006, 10:49 AM   #5
missmoondog
Member
 
Registered: Oct 2005
Distribution: Zenwalk 3.0
Posts: 34

Original Poster
Rep: Reputation: 15
good tips for helping to identify the cause, but i've already known as much from searching around.

now, on to the solution?
how do i determine the video mode and how/where do i add what to make the video mode error not come up?

thanks

Last edited by missmoondog; 10-11-2006 at 03:09 PM.
 
Old 10-11-2006, 04:24 PM   #6
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,433

Rep: Reputation: 83


I am lost.

You posted two problems when this thread was made.

we have to straighten out which reply goes which problem
 
Old 10-11-2006, 08:17 PM   #7
missmoondog
Member
 
Registered: Oct 2005
Distribution: Zenwalk 3.0
Posts: 34

Original Poster
Rep: Reputation: 15
what's so tough about replying to whichever one you think you know how to fix? you simply type in something like "this is what you do to fix shutdown issue............ or, this is what video mode you need and this is how to edit whatever, etc..........

the video problem will probably be the harder to fix over these forums as i have the issue on 3 machines actually, and all 3 have different model monitors, which i'm sure probably has something to do with it and i at least need to know their specs most likely.

the shutdown issue is the on i'd really like to fix.

Last edited by missmoondog; 10-11-2006 at 08:18 PM.
 
Old 10-13-2006, 06:27 AM   #8
darkscot
Member
 
Registered: Jul 2006
Location: West Yorkshire, UK
Distribution: Mandriva, Leeenux, Saluki
Posts: 103

Rep: Reputation: 20
Quote:
Originally Posted by missmoondog
...also, both of these computers get a video mode error on startup saying something along the lines of i have entered a bad paramater(?) i then get the option of seeing available video modes, which i don't have a clue as to what to enter, or wait 30 seconds. if i just hit the spacebar, they boot fine.
"You passed an undefined mode number" No, I don't know what it means either! As root you need to edit /etc/lilo.conf. Look for the section shown below. In my case the default setting was vga=normal but I had to comment that out and uncomment vga=791. But I had to try a few options before I got one that worked.

Make sure you run lilo -v after you make any changes to lilo.conf.


Code:
# VESA framebuffer console @ 1024x768x64k
vga = 791
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section

Last edited by darkscot; 10-13-2006 at 06:32 AM.
 
Old 10-13-2006, 06:34 AM   #9
darkscot
Member
 
Registered: Jul 2006
Location: West Yorkshire, UK
Distribution: Mandriva, Leeenux, Saluki
Posts: 103

Rep: Reputation: 20
[QUOTE=missmoondog]have 2 hp pavilions (6736 & 6835) that don't fully shutdown. they shut down to the point off turning off the power and then just sets. i have to push the button on the tower to turn it off.

Look here:
http://support.zenwalk.org/index.php/topic,2313.0.html

Quote:
feels like i back in windows 95 days!
Hp Pavilions don't switch off with Windows ME either.
 
Old 10-13-2006, 07:02 AM   #10
missmoondog
Member
 
Registered: Oct 2005
Distribution: Zenwalk 3.0
Posts: 34

Original Poster
Rep: Reputation: 15
ok. looking at that link you posted. had already added that line to the file but just noticed there was a space after last letter and " at the end.

both of these machines had windows me on them. don't remember if they shut down all the way or not. day i got them, is the day w2k went on them!

here's hoping it works. brb!

Last edited by missmoondog; 10-13-2006 at 07:08 AM.
 
Old 10-13-2006, 11:03 AM   #11
missmoondog
Member
 
Registered: Oct 2005
Distribution: Zenwalk 3.0
Posts: 34

Original Poster
Rep: Reputation: 15
ok, so not quite "right" back. it (shutdown) didn't work on the hp6835.

as far as what my /etc/lilo.conf looks like, it is and was exactly the same yours.
 
Old 10-13-2006, 08:29 PM   #12
DamianS
LQ Newbie
 
Registered: Sep 2006
Posts: 5

Rep: Reputation: 0
If your computers will not power down, that means either the acpi daemon is not running, or your motherboards are not ACPI-compliant.
Hsve you already checked you haven't disabled the daemon from running?

I have an Asus P2B-DS mobo, the early versions of which had a bug preventing proper ACPI compliance. Because of this, they are on a 'black list' of mainboards which the kernel will not normally allow ACPI for.
The problem is that I have one of the last versions, which were fixed.
So everytime I install any version of Linux, I have to add the parameter 'acpi=force' as described in the thread.

If they shut down in Windows, then maybe you need to investigate the APM options.

Last edited by DamianS; 10-13-2006 at 08:34 PM.
 
Old 10-14-2006, 06:03 AM   #13
missmoondog
Member
 
Registered: Oct 2005
Distribution: Zenwalk 3.0
Posts: 34

Original Poster
Rep: Reputation: 15
what is the correct way to type this out?

addappend = acpi=force

where EXACTLY do the punctuation marks go and what type are they. i'm finding some posts have it like this: addappend = "acpi=force" and this addappend = "acpi=force " and this addappend = 'acpi=force' and this addappend = acpi=force' and this addappend = 'acpi=force'

would somebody make up my mind and type the crap the CORRECT way, please?!!

thanks

edit:
nevermind. got the answer on another forum. no marks go around the acpi=force

yay! it worked, wit the correct punctuation!

Last edited by missmoondog; 10-20-2006 at 04:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
power shut down in core 3 Lar Fedora 7 12-03-2004 05:02 PM
Video shut off by power manager, but how? asentell Linux - Newbie 5 12-27-2003 07:05 PM
how to get mandrake 9.0 shut down the computer without pushing the power button? sirpelidor Mandriva 8 11-25-2003 12:11 PM
power off the computer after shut down gary.chan Linux - Software 1 01-05-2003 10:35 AM
APM Power MGMT wont shut off!!! NyteMask Linux - General 5 05-25-2002 03:21 AM


All times are GMT -5. The time now is 03:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration