LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Zenwalk
User Name
Password
Zenwalk This forum is for the discussion of Zenwalk Linux.

Notices

Reply
 
Search this Thread
Old 03-11-2012, 01:38 PM   #1
slipstream5
LQ Newbie
 
Registered: Mar 2012
Location: Canada
Distribution: Ubuntu, Korora, SalixOs,
Posts: 14

Rep: Reputation: Disabled
Unhappy Installation of 96.43 Nvidia driver in Zenwalk fails: fatal error- no screens found


I have 2 identical 15 inch monitors which I like to use with Nvidia's "Twinview", rather then as clones of each other. So I need the Nvidia driver. I first installed the recommended LTS kernel version and followed the instructions from Zenwalk wiki: tutorial by Christian Schmidt

''To install the NVidia driver to Zenwalk Linux please complete the following steps:
Edit the file /etc/netpkg.conf with a text editor, in the section "Black_list" remove everything except aaa_base. No one should ever update aaa_base. This will ensure you use the new kernel and sources.
First update your system: netpkg upgrade
Restart your computer, to be running with the new kernel.
Without needing to login, shutdown the X-Server. Change to a textmode console with "CTRL+ALT+F2", login as root and stop the X-Server by running "init 3".
We need the kernelsource to build the NVidia driver kernel module: netpkg kernelsource
The driver should be fetched at the official NVIDIA homepage.
Execute the downloaded file: # sh NVIDIA-Linux-x86-1.0-*VERSION*-pkg1.run -s .
The driver will be build now and installs the kernel module to the Zenwalk system. Then you have to modify the etc/X11/xorg.conf for your needs. (The easiest way is to change Driver "nameOfTheDriver" to Driver "nvidia" in the Device section).
Now restart the X-Server by typing init 4 ."

But... I got "fatal server error: no screens found".

So I deleted xorg.conf in order to start x again and then used the
generated backup xorg.conf file to make new xorg file, and removed the
monitor and screen section, as I have sucessfully done for Ubuntu and other OS.
But then, when I try to use gksudo nvidia-settings I get error:

NV-CONTROL extension not found on this Display.
ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.
ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.
ERROR: Unable to determine number of NVIDIA VCSCs on ':0.0'.

So then, I modified xorg.conf again, and added monitor information
according to xorg.conf from Ubuntu which I know is correct. but then
it said nvidia not installed. When i re-installed nvidia from TTY
screen, now I get:

" your driver installation has been altered since it was initially
installed; this may happen for example if you have since installed the
NVIDIA driver through a mechanism other then nvidia-installer...."

What a mess!

Anyone knows how I can start over and use a xorg.conf file that Zenwalk will accept? short of re-installing...

(Note: its my first time using a Slackware based OS)

If I have to re-install, I am considering Salix-OS, because I can't even register to the Zenwalk forum- there is an error with the webpage there, and no one from the email list has replied to me including the webmaster, it leaves me with the impression that they don't care about new (Zenwalk) users, I really hope I'm mistaken!
 
Old 03-11-2012, 02:36 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,502

Rep: Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570
Hmmm. I wonder what all that was about.

I have an old MX-440 card and that used the 96.43 driver (x86-96.43.14 to be precise) and you needed no messing, no special kernel, no blacklist, none of that <expletive deleted>.

I don't know about netpkg.conf, and will give no instructions for it.
Try this: Get your install cd &
1. Uninstall the driver Nvidia-whatsit-86.43.blah.run --uninstall
If that doesn't run try /uninstall or -uninstall. As an absolute last resort, ask it: Nvidia-whatsit-86.43.blah.run --help (or /help or /? I'm going senile

2. Check that Mesa has been sorted with
ls -l /usr/lib/libGL*
This should spew up files and symlinks. Check that the files with 96.43.* are not referenced by the symlinks (e.g. libGL.so should point to libGL.so.1.2 or something like that).

3. I would run make in the kernel top source. Your required .config is probably in boot, as /boot/config.kernel-version. Copy that to /usr/src/linux-version/.config (note DOTconfig). Run make clean && make

4. Install the driver again. (your symlinks now should be to /usr/lib/libGL.so.96.43.stuff

5. Hide xorg.conf, and take the video stuff out of xorg.conf.d. Leave a Section for each monitor, that's all.

6. Reboot. & startx > somefile 2&>1

7. Post back with your results. We could use a laugh

I slapped on a 1440x900 monitor, gave it 1440x900 in the xorg.conf. It said
Found this mode - 1440x900: That's Clearly Ridiculous - Deleting it.
and down the file . .
let's ask the Monitor what it _can_ do . .
it says it will do 1440x900 - so I'll try rolling up one of those. . .
and I had picture.
 
1 members found this post helpful.
Old 03-13-2012, 08:40 AM   #3
slipstream5
LQ Newbie
 
Registered: Mar 2012
Location: Canada
Distribution: Ubuntu, Korora, SalixOs,
Posts: 14

Original Poster
Rep: Reputation: Disabled
Hi business_kid,

Have some time today to try to fix Nvidia. I am not sure of step #3:


Quote:
3. I would run make in the kernel top source. Your required .config is probably in boot, as /boot/config.kernel-version. Copy that to /usr/src/linux-version/.config (note DOTconfig). Run make clean && make
so I copy the file config.2.6.37.4 from /boot exactly as is to /usr/src/linux-version/.config?

And what do I add to the command ''make clean && make"?

Thanks for bearing with me; I'm new to Slackware & related, I'm used to Ubuntu...so its a little confusing for me...
 
Old 03-13-2012, 10:23 AM   #4
slipstream5
LQ Newbie
 
Registered: Mar 2012
Location: Canada
Distribution: Ubuntu, Korora, SalixOs,
Posts: 14

Original Poster
Rep: Reputation: Disabled
I managed to re-install nvidia driver and

added busid in xorg.conf using nano, the rest seemed ok so I left it as is but when I rebooted and tried to use:

sudo nvidia-settings

I still got:


ERROR: NV-CONTROL extension not found on this Display.


ERROR: Unable to determine number of NVIDIA GPUs on ':0.0'.


ERROR: Unable to determine number of NVIDIA Frame Lock Devices on ':0.0'.

I installed Nvidia from same place as previously so this may be the problem?
ERROR: Unable to determine number of NVIDIA VCSCs on ':0.0'

so I have nothing that is configurable in the nvidia-settings gui, and still have my cloned screens. don't know what to do next....

Last edited by slipstream5; 03-13-2012 at 10:29 AM. Reason: added info
 
Old 03-13-2012, 12:15 PM   #5
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,502

Rep: Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570
Quote:
Originally Posted by slipstream5 View Post
Hi business_kid,

Have some time today to try to fix Nvidia. I am not sure of step #3:

so I copy the file config.2.6.37.4 from /boot exactly as is to /usr/src/linux-version/.config?

And what do I add to the command ''make clean && make"?

Thanks for bearing with me; I'm new to Slackware & related, I'm used to Ubuntu...so its a little confusing for me...
Your kernel source is in /usr/src/linux-2.6.37.4. Copy the config file exactly as you said. Add nothing to the 'make clean && make' ; once the .config file is in /usr/src/linux-2.6.37.4/ and you cd into that directory (may have left that out). You need root for this
make clean cleans up after any previous compile
&& joins 2 commands
make compiles the kernel, and modules and stuff as described by make help. It should start doing stuff, and stay doing it for a while.
 
1 members found this post helpful.
Old 03-15-2012, 02:04 PM   #6
slipstream5
LQ Newbie
 
Registered: Mar 2012
Location: Canada
Distribution: Ubuntu, Korora, SalixOs,
Posts: 14

Original Poster
Rep: Reputation: Disabled
Smile

Hi!
Thanks for the help, business_kid, it actually worked!

The strange thing with "make" command was that it compiled the whole kernel, I guess, for a looong time and at some point the terminal just closed itself, so I wasen't certain if the compiling had completed properly. I took a chance and tried the next step. This time I copied the nvidia driver to that same folder (usr/scr/linux 2.6.XX) and then when I logged out and ran it (sh xxxxNVIDIAxxx.run ) Nvidia did its thing! (Compiled the kernel asked if I wanted to update the config file). I then modified the xorg.conf correctly, albeit after a couple of tries.

If this helps anyone with same driver vrs;

-installing NVIDIA driver with other OS sometimes had to have Busid "PCI:X:X:X" line added to Device section but do NOT add it for Zenwalk. I did add
Section "Module"
Load "glx"

and had to delete the "Monitor" and the "Screen" sections in order to get X11 working!

-I then did the usual sudo nvidia-settings to get my 2 screens set up with Twinview, and saved xorg.conf but deleted 2 "Modes" settings that were higher then my screens could handle.

Note: testing many new OS including Zenwalk- happy with Zenwalk now!
 
Old 03-16-2012, 03:14 AM   #7
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,502

Rep: Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570Reputation: 570
Glad to hear it.

Yes, it made the whole kernel, and all the files around the place, so when the nvidia compile came looking for them, they were there. You can now go back into the kernel, run 'make clean' and save 200 megs of disk space.
 
  


Reply

Tags
dual monitor, installation, nvidia drivers, xorg.conf, zenwalk


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fatal Server error: No screens found tadaa Linux - Laptop and Netbook 11 01-23-2010 08:20 PM
fatal error no screens found alf_frommars Suse/Novell 1 07-30-2006 01:19 PM
Driver "nvidia" causes Fatal Error: no screens found Gamezace Linux - Newbie 3 04-19-2004 05:06 PM
Fatal server error: no screens found walsht3108 Linux - Newbie 1 08-26-2003 04:46 PM
Fatal server error: no screens found walsht3108 Linux - Newbie 1 08-26-2003 04:42 PM


All times are GMT -5. The time now is 01:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration