LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Zenwalk (http://www.linuxquestions.org/questions/zenwalk-75/)
-   -   df does not show my home partition (http://www.linuxquestions.org/questions/zenwalk-75/df-does-not-show-my-home-partition-586452/)

xri 09-21-2007 09:21 PM

df does not show my home partition
 
When I type in df -h, I get the free space in all my partitions, except for /home (it does not show on the list). No error messages.

My fstab looks fine.

This is the first time I see myself unable to run a quick check of my home space. The "devices" tool on the panel, which has the same purpose, is also blind to my ;home partition.

All the partitions were formatted as ext3, while my home partition is jfs. Is that maybe the reason why I can't get to see the free space on my partition?

How can I check my free space in this case?

ArcLinux 09-21-2007 10:03 PM

what does you fstab look like?

michaelk 09-22-2007 01:55 PM

I've only briefly played with Zenwalk but I do not believe it supports jfs. AFAIK ext2/3, xfs and reiserfs are supported. Was this an existing parititon or was it created when you installed Zenwalk?

In addition to posting your fstab include how your drive(s) are partitioned via the fdisk command.
fdisk -l (that is a small L)

xri 09-22-2007 09:38 PM

Thanks for the answers.
My fstab:
Quote:

/dev/sda5 swap swap defaults 0 0
/dev/sda6 / ext3 defaults,noatime 1 1
/dev/sda10 /home jfs defaults,noatime 1 2
/dev/sda7 /extra ext3 defaults,noatime 1 2
/dev/sda8 /usr ext3 defaults,noatime 1 2
/dev/sda9 /boot ext3 defaults,noatime 1 2
/dev/sda1 /windows ntfs-3g defaults,noatime 1 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
/dev/sr0 /mnt/dvd iso9660 noauto,user,ro 0 0
I created the partitions with GParted before installing Zenwalk. After the installation, the mount type for my /home partition was empty, and I added jfs for home and replaced ntfs with ntfs-3g for /windows. Either way, df keeps neglecting /home.
How can I know if I have to compile the kernel with jfs support?

guth 09-23-2007 06:06 AM

Quote:

$ grep -i jfs /proc/filesystems
$
$ grep -i jfs /boot/config
# CONFIG_JFS_FS is not set
$
Either recompile kernel with jfs support or use xfs/ext3/...

xri 09-23-2007 12:09 PM

Now I see my mistake. Since Slack supports jfs, I assumed that the current Zenwalk does it too. I should have been more careful.
Two more questions:
  1. If my current kernel does not support jfs, what driver is letting me use my /home partition as I am currently doing? How come the system is up and runnning nonetheless?
  2. When I recompile the kernel, I don't want to lose all the nice features Zenwalk already has. How can I make sure all the rest stays the same, after adding the jfs patch?

guth 09-23-2007 01:25 PM

Quote:

Originally Posted by xri (Post 2901108)
Now I see my mistake. Since Slack supports jfs, I assumed that the current Zenwalk does it too. I should have been more careful.
Two more questions:
  1. If my current kernel does not support jfs, what driver is letting me use my /home partition as I am currently doing? How come the system is up and runnning nonetheless?

you have to add jfs support either as module or built-in your "home made" kernel
Quote:

  1. When I recompile the kernel, I don't want to lose all the nice features Zenwalk already has. How can I make sure all the rest stays the same, after adding the jfs patch?

just install the package kernelsources (eithere by un-blacklisting it in netpkg.conf or downloading and installing it with installpkg or thunar right-click) from zenwalk mirrors and you'll have the default .config ;)

syg00 09-23-2007 05:13 PM

Quote:

Originally Posted by xri (Post 2901108)
what driver is letting me use my /home partition as I am currently doing? How come the system is up and runnning nonetheless?

It is just a directory under the root. If you compile jfs support in and reboot with that fstab your user will not have access to the old /home.
Might pay to come up in single user and copy the /home before logging the user on.

xri 09-23-2007 06:39 PM

Now I'm getting the picture. Thank you all for your help.
I'll recompile and post about it, for the records.

xri 09-28-2007 06:36 AM

I still can't mount it with the new kernel!!
 
I recompiled the 2.6.22.9 kernel and chose Y (not as module) on jfs on "Filesystems".
I also installed jfsutils.

However, after mount -t jfs /dev/sda10 /mnt/hello

Quote:

mount: unknown filesystem type 'jfs'
After jfs_fsck /dev/sda10

Quote:

jfs_fsck version 1.1.11, 05-Jun-2006
processing started: 9/28/2007 6.32.15
Using default parameter: -p
The current device is: /dev/sda10
Block size in bytes: 4096
Filesystem size in blocks: 7456160
**Phase 0 - Replay Journal Log
Filesystem is clean.

What am I missing here?

xri 09-29-2007 10:09 PM

I recompiled several times, either setting the jfs support as a module or as part of the kernel. Every time, it gave me the error messages shown above. Maybe I made a mistake at some point. I'll eventually figure it out. In the meantime, I installed a regular kernel from Slack, with support for jfs already. It's working fine.


All times are GMT -5. The time now is 10:32 PM.