LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Yoper
User Name
Password
Yoper This forum is for the discussion of Yoper Linux.

Notices



Reply
 
Search this Thread
Old 11-24-2004, 11:24 PM   #1
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Rep: Reputation: 30
kernel rebuild


i'm trying to get wireless working on a Sony VGN-S150 with intel 2200 wireless.

according to the drivers i need CONFIG_NET_RADIO configured in my kernel. when i grep see if it is on, i get an error.

i also need firmware loading capabilities of hotplug.

can i turn both these on without recompiling?
what is the proper directory for firmware loading?

if not, should i just download the most recent source and recompile?

hmm, guess that's enough q's to get me started, lol.

thx,
pres
 
Old 11-25-2004, 05:20 AM   #2
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Quote:
when i grep see if it is on, i get an error.
What error ? Something like "CONFIG_NET_RADIO is not set" ?

Then you need to compile the kernel with the above option set.

Quote:
i also need firmware loading capabilities of hotplug.
what is the proper directory for firmware loading?
Sorry, don't know anything about that.

Quote:
if not, should i just download the most recent source and recompile?
I think it's easier to recompile the current kernel (instead of the newest), so you don't run into possible configuration problems. Simply clone the kernel config (copy .config and make oldconfig) and change the parameters you need.
 
Old 11-25-2004, 12:47 PM   #3
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Original Poster
Rep: Reputation: 30
no the error i get is that the directory i am grepping does not exist (the wireless driver developers said to grep that directory).

here is the output:
grep CONFIG_NET_RADIO \
> /lib/modules/'uname -r'/build/include/linux/autoconf.h
grep: /lib/modules/uname -r/build/include/linux/autoconf.h: No such file or directory

also, the locate db has not been created when i installed yoper. making difficult to find things. how do i tell it to generate one?

hate to ask such simple questions :S
pres
 
Old 11-25-2004, 01:08 PM   #4
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I don't know if the Yoper kernel has this feature, but you could try the following:

zcat /proc/config.gz | grep NET_RADIO

I guess what the developers mean ist that you should fill in the output of uname -r rather than uname -r itself. This command returns the kernel version.

Code:
user@linux:~> uname -r
2.6.7
user@linux:~> cat /lib/modules/2.6.7/build/include/linux/autoconf.h | grep NET_RADIO
#undef CONFIG_NET_RADIO
To get your locate db updated, you may need to run the command updatedb (as root).
 
Old 11-25-2004, 04:10 PM   #5
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Original Poster
Rep: Reputation: 30
thanks,

actually after my last post i decided to try to follow the directory tree listed, and saw that 2.6.8.1-3 was the "uname -r" directory, but then the entire naming scheme breaks down.... there is no .../build directory after that, let alone the other ones listed.

hmm, let me do some more sleuthing... wish i knew how to get "locate" working... lemme do a search on that first, lol... i need to write the db files for it.
 
Old 11-25-2004, 04:19 PM   #6
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Original Poster
Rep: Reputation: 30
cool, the command to write the locate and find db is: updatedb
now the locate command works

now back to the problem @ hand...
locate does not find an autoconf.h anywhere. i cannot grep for the NET_RADIO status unless i can locate it?

hmm...

edited:
so if i were to recompile the kernel, i would need to place the drivers in the above mentioned directory?
i'm not sure why the directory structure is different. either the kernel i'm using, or yoper has made it different?

hmm again... lol, i'm lost

Last edited by Present; 11-25-2004 at 04:23 PM.
 
Old 11-25-2004, 05:22 PM   #7
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Original Poster
Rep: Reputation: 30
i just tried this to get the kernel source (i don't think i have it):

apt-get install kernel-source

and it reads package lists and dep tree fine, but then i get this message:

E: Couldn't find package kernel-source

do i need to refer to the package differently?

edited
i just checked kernel.org for a version of the kernel i'm using to manually install it so i can get on with configuring this computer, and they only have 2.6.8.1 while yoper is using 2.6.8.1-3. is this the same? can i manually install sources from ..1 and have them work with ..1-3?

-maybe i should ask this last part at the general forum... not sure if this is the right place...
thx

Last edited by Present; 11-25-2004 at 07:22 PM.
 
Old 11-26-2004, 12:19 AM   #8
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Original Poster
Rep: Reputation: 30
i found the source on yoper website and just installed it from rpm (couldn't get the apt-get to work..)

also got the radio transmitting and receiving, just need to get the networking setup on it now (a quick search of the forums or web should get me through this easily).

thanks all, i'm all set,
pres

edited:
the solution for the radio actually didn't need the source (vmware did, lol).

to get the radio working on this notebook, get the ipw2200-0.15(+) drivers and firmware (two separate tars).

1. untar the firmware to the /usr/lib/hotplug/firmware/ directory.
2. untar the drivers to a directory and make, make install (as su)
3. modprobe ipw2200 (as su also)

you should be set. yoper takes care of the rest of the settings in the kernel.
a little prog like KWiFiManager should let you see if you're transmitting and receiving.
gl

Last edited by Present; 11-26-2004 at 12:28 AM.
 
Old 11-26-2004, 04:15 AM   #9
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
Quote:
Originally posted by Present
cool, the command to write the locate and find db is: updatedb
now the locate command works
WOW, who told you that?

Quote:
Originally posted by abisko00
To get your locate db updated, you may need to run the command updatedb (as root).
Quote:
Originally posted by Present
now back to the problem @ hand...
locate does not find an autoconf.h anywhere. i cannot grep for the NET_RADIO status unless i can locate it?
I actually get the impression that you didn't read my post at all:

Quote:
Originally posted by abisko00
zcat /proc/config.gz | grep NET_RADIO
But I am happy that you resolved the problem yourself, finally!
 
Old 11-26-2004, 07:08 PM   #10
Present
Member
 
Registered: Jan 2004
Distribution: suse/slack/gentoo/lfs (not-in-that-order)
Posts: 281

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by abisko00
I don't know if the Yoper kernel has this feature, but you could try the following:

zcat /proc/config.gz | grep NET_RADIO
"No such file or directory"

Quote:
Originally posted by abisko00
I guess what the developers mean ist that you should fill in the output of uname -r rather than uname -r itself. This command returns the kernel version.

Code:
user@linux:~> uname -r
2.6.7
user@linux:~> cat /lib/modules/2.6.7/build/include/linux/autoconf.h | grep NET_RADIO
#undef CONFIG_NET_RADIO
for me that would be: ~> cat /lib/modules/2.6.8.1-3/build/include/linux/autoconf.h | grep NET_RADIO
...drum roll..."No such file or directory"

Quote:
Originally posted by abisko00
To get your locate db updated, you may need to run the command updatedb (as root).
OOPPPS!!! i goofed, lol. dyslexia strikes back... here's how i read that:

To get your locate db updated, you may need to run the command updated (as root).

...And i thought to myself, "he misspelled and never told me the command."

Sorry about that. ignorance does have a price. in my case the price was an hour trying to figure out how to update the db because i didn't read carefully and reread.

Thanks again for your help,
pres

Last edited by Present; 11-26-2004 at 07:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to rebuild kernel bhanu12 Linux - Newbie 2 10-26-2005 05:42 PM
How do you rebuild a kernel? Thaidog Linux - General 4 07-26-2005 01:15 PM
Help (!?) with rebuild kernel 2.4.26 WoofDeF Debian 1 06-22-2005 10:11 AM
Kernel Rebuild Nightmare squirellplaying Linux - General 2 01-20-2005 05:31 PM
Rebuild kernel And then !!! left-hand Linux - Software 4 02-06-2004 10:59 AM


All times are GMT -5. The time now is 05:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration