LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > VectorLinux
User Name
Password
VectorLinux This forum is for the discussion of VectorLinux.

Notices

Reply
 
Search this Thread
Old 01-11-2007, 12:57 PM   #1
Berto
Member
 
Registered: Sep 2003
Location: Stevenson, WA, USA
Distribution: Slackware
Posts: 232

Rep: Reputation: 30
Making Wifi Connection Default


I just installed VectorLinux on my sister's computer and she uses wifi for the internet. The card was automatically detected and configured (AWESOME) and it connects to the router, but once the computer is rebooted it doesn't automatically reconnect and she has to use the wifi radar app every time.

How do I set this Wifi connection as the default one and make it automatically connect?
 
Old 01-11-2007, 02:27 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,292

Rep: Reputation: 138Reputation: 138
I had the same problem and solved it by adding this to the end of /etc/rc.d/rc.local:

Code:
wifi-radar -d &
It works beautifully. Be sure to include the "&" at the end or it will hang on boot. rc.local is the last init script to run at boot. My edit starts the WifiRadar daemon at the end of the boot process. WifiRadar then looks at all the wifi essids you have previously setup and scans to see if any are available. When it finds one it automatically connects to the strongest available. If it finds none available it doesn't try to bring up the wireless network which makes it nice if you take the laptop out of the range of your wireless access point.
 
Old 01-11-2007, 03:28 PM   #3
Berto
Member
 
Registered: Sep 2003
Location: Stevenson, WA, USA
Distribution: Slackware
Posts: 232

Original Poster
Rep: Reputation: 30
Thanks I'll try that.
 
Old 02-08-2007, 06:22 PM   #4
Berto
Member
 
Registered: Sep 2003
Location: Stevenson, WA, USA
Distribution: Slackware
Posts: 232

Original Poster
Rep: Reputation: 30
wifi-radar doesn't work. The only thing that does let it connect is vwifi but with that I haven't found a way to connect except to run the program and enter the SSID manually.

Is there any single command (like wifi-radar -d) for vwifi? (like vwifi SSIDNAME)
 
Old 02-09-2007, 02:23 PM   #5
M0E-lnx
LQ Newbie
 
Registered: Feb 2007
Distribution: Vector Linux
Posts: 8

Rep: Reputation: 0
You can use iwconfig to connect
Code:
iwconfig eth0 essid ACCESPOINTNAME && dhcpcd &
see man iwconfig for information.
replace eth0 with your interface name if needed

Try that in a terminal as root... if it works, add it at the end of your /etc/rc.d/rc.local file

Last edited by M0E-lnx; 02-09-2007 at 02:25 PM.
 
  


Reply

Tags
wifi, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Making firefox the default Richie55 Mandriva 2 01-30-2006 12:59 PM
making WiFi settings in /etc/network/interfaces permanent Lleb_KCir Linux - General 3 05-10-2005 11:22 PM
Suse 9.2 default route wifi nanofa Suse/Novell 3 01-08-2005 08:45 PM
making zsh the default corbis_demon Linux - General 2 12-21-2004 03:15 PM
Making Alsa the Default haimeltjnfg Linux - Hardware 4 05-02-2004 02:04 PM


All times are GMT -5. The time now is 06:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration