LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 06-17-2010, 08:59 PM   #1
conman124
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Rep: Reputation: 0
Xubuntu hibernation restarts after saving state


Hi,

I have been running Xubuntu Lucid for a couple of days and so far the only problem I have been having is with hibernation. When I hibernate, it saves the state, shuts off the computer, but then the computer starts again.

I have looked around a bit in the hibernation scripts (/etc/acpi/hibernate.sh) and changed some of the pm configuration files (added "HIBERNATE_MODE = shutdown" to the end of /etc/pm/config.d/00sleep_module) to no avail.

My computer is an IBM ThinkCentre. I am not exactly sure on the specific model, but I believe it is m51.

Thank you in advance,
--Connor

EDIT: If it makes any difference, this was an Ubuntu install that I changed to a Xubuntu install by doing "apt-get remove liborbit2" (I found this instruction on a website) and then "apt-get install xubuntu-desktop".

Last edited by conman124; 06-17-2010 at 09:01 PM. Reason: Added more information
 
Old 06-18-2010, 10:38 AM   #2
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Can you discover the event that is bringing it back out of Hibernation?
Bios settings used to have a WOL Wake On Lan setting to allow Local Area Network r'equests to wake the PC.
Does your script specify the allowable wake up events?
 
Old 06-18-2010, 12:46 PM   #3
conman124
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Original Poster
Rep: Reputation: 0
How would I go about doing that? I believe there might be some sort of bug in the script that is telling the system to restart, not power off. I am not sure how to verify this however.

--Connor
 
Old 06-18-2010, 06:39 PM   #4
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Used to be able to go into the bios using F2 in the power up sequence and go into the Setup screens and enable/disable Wake on Lan WOL bu I just went into my Dell BIOS and all I see is Wake on USB.
What you might try is disconnecting USb and ethernet cable and downing your wireless connections, if any, and then try the Hibernation function to see if it is an external event that is waking you up.
 
Old 06-18-2010, 11:19 PM   #5
conman124
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Original Poster
Rep: Reputation: 0
Ah. The only problem is that the OS is running off of a external hard drive. (Sorry, I forgot to mention that in my first post). However, I doubt that it is that, because it restarts immediately afterwards and my Windows install hibernates fine as well as other Linux distributions I have tried.

I will check, but probably not till tomorrow morning.
--Connor
 
Old 06-19-2010, 06:55 AM   #6
bubuntu
LQ Newbie
 
Registered: Nov 2009
Location: Huntsville, Al
Distribution: Ubuntu
Posts: 26

Rep: Reputation: 1
I'm having the opposite problem only my system goes into hibernation just fine but when it restarts it sometimes is only up for a minute or so then goes back to hibernation. I was about to start a thread when I found this so I'll wait till this is resolved.
 
Old 06-19-2010, 05:04 PM   #7
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Quote:
Originally Posted by conman124 View Post
Ah. The only problem is that the OS is running off of a external hard drive. (Sorry, I forgot to mention that in my first post). However, I doubt that it is that, because it restarts immediately afterwards and my Windows install hibernates fine as well as other Linux distributions I have tried.

I will check, but probably not till tomorrow morning.
--Connor
Thats ok, the BIOS is in a ROM in the Computer you are trying to put in to hibernation. So if you shut down the computer and then turn it back on and hit F2 to get into setup (Look at the screen to discover what key your computer uses to go into setup). Then once you get into setup use the arrow keys to go back and forth until you see something like WOL or Wake on USB and turn that off. Then see if you are still coming back out of hibernation. If you are then you may have failing hardware.
If you boot up into Windows does Hibernate work properly? (I think the MSDOS CLi command is shutdown -h to go into hibernate mode.

Last edited by john test; 06-19-2010 at 05:08 PM.
 
Old 06-19-2010, 05:10 PM   #8
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Another thought You may have Wake On usb turned on and your external hard drive may be using Wake on USB to wake your machie back up. I am assuming that your external hard drive uses a USB connection.
 
Old 06-20-2010, 04:12 PM   #9
conman124
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Original Poster
Rep: Reputation: 0
I meant, it's an external hard drive, so I don't know how to check the wake on USB. However, I don't think my BIOS has that. After poking around a bit in the settings, I don't see anything like that. Yes, Windows hibernation works fine. The Windows drive is internal.

--Connor
 
Old 06-22-2010, 10:13 PM   #10
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Yea looks like th external drive on your usb port is waking you back up. Sort of anyway
Does the Drive have its own power source or does it draw power from the usb port?
 
Old 06-23-2010, 10:21 AM   #11
conman124
LQ Newbie
 
Registered: Jun 2010
Posts: 6

Original Poster
Rep: Reputation: 0
It has it's own power source, but like I said, I looked around in the BIOS and I saw a wake on LAN, but no wake on USB.

If it is the USB drive, wouldn't it also restart on a shutdown? Because I just tested and it shuts down fine.

--Connor
 
Old 06-24-2010, 01:56 PM   #12
john test
Member
 
Registered: Jul 2008
Distribution: ubuntu 9.10
Posts: 527
Blog Entries: 1

Rep: Reputation: 35
Did you turn off WOL while you were in the bios?

If the usb hard drive is truly shutting down then you wouldn't think it would be responsible for restarting the system.
That Leaves an Ethernet Connection or a Wireless connection to do the Wake up.

Could be a bad bleeder resistor on a Network Adapter keeping a voltage high enogh to wake you back up. I would disable WOL to see if it is a LAN function and then I would uninstall network adapters to see if a faulty one is causing the issuel
 
1 members found this post helpful.
  


Reply

Tags
hibernation, xubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables -I INPUT -p tcp --dport 22 -i eth0 -m state --state NEW -m recent --set deadeyes Linux - Server 14 07-29-2009 04:30 AM
Preparing for Linux Install Question: Saving current Hard Drive State daedalus1618 Linux - General 2 08-06-2008 01:41 PM
scrambled display after entering "power saving?" state rbees Linux - General 2 02-26-2008 05:32 AM
LXer: State by state, Microsoft responds to creeping threat LXer Syndicated Linux News 0 05-01-2007 07:16 AM
Computer restarts after syslogd restarts birdseye Linux - General 2 03-05-2006 04:27 AM


All times are GMT -5. The time now is 04:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration