LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-22-2011, 08:56 PM   #1
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Rep: Reputation: Disabled
Xubuntu, Dell laptop, Sigmatel audio: no Quickcam Pro 9000 mic and no speaker sound


Hi,

Noob here. I have no programming experience but I do love using linux. I have xubuntu on my dell laptop with a sigmatel audio. I installed on the weekend and cannot get skype or anything else for that matter to pick up the mic. on my quickcam pro 9000. I also have no sound through my speakers.

I'm really lost and do not know what to install and configure to get it working. Any help is much apreciated.

Thank you.

Last edited by unSpawn; 11-22-2011 at 09:16 PM. Reason: //Pruned from http://www.linuxquestions.org/questions/mandriva-30/logitech-quickcam-pro-9000-uvc-driver-596901/
 
Old 11-22-2011, 10:42 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Hi sacksyboy, Welcome to LQ. Which version of Xubuntu are you using? Please post the results of the following.

Code:
$ sudo lsmod | grep uvc
$ uname -a
$ cat /proc/asound/card0/codec#* | grep Codec
Have you tried any mixers, alsamixer to adjust and unmute your sound? Once you have sound working getting Skype configured should be a matter of choosing the correct option in Skype's settings.

Good luck. ;-)
 
Old 11-23-2011, 08:54 AM   #3
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Peacedog View Post
Hi sacksyboy, Welcome to LQ. Which version of Xubuntu are you using? Please post the results of the following.

Code:
$ sudo lsmod | grep uvc
$ uname -a
$ cat /proc/asound/card0/codec#* | grep Codec
Have you tried any mixers, alsamixer to adjust and unmute your sound? Once you have sound working getting Skype configured should be a matter of choosing the correct option in Skype's settings.

Good luck. ;-)
Okay...took me a while to figure out where the vertical bar was on my keyboard and that I should use terminal...here are the results:

sacksyboy@sacksyboy-laptop:~$ sudo lsmod | grep uvc
[sudo] password for sacksyboy:
uvcvideo 57406 0
videodev 34425 1 uvcvideo
v4l1_compat 13251 2 uvcvideo,videodev
sacksyboy@sacksyboy-laptop:~$ uname -a
Linux sacksyboy-laptop 2.6.32-35-generic #78-Ubuntu SMP Tue Oct 11 15:27:15 UTC 2011 i686 GNU/Linux
sacksyboy@sacksyboy-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
cat: /proc/asound/card0/codec#*: No such file or directory
sacksyboy@sacksyboy-laptop:~$ ^C
sacksyboy@sacksyboy-laptop:~$

I tried pulse audio, uvcvideo and alsa but no dice. It could be that it works and I just don't know how to test it properly but I could find not testing within those applications to see if the mic or speakers were working. I would then go back to skype and try it with no success...
 
Old 11-23-2011, 10:14 AM   #4
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,087

Rep: Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809Reputation: 809
As suggested above, have you run "alsamixer" in a terminal? (no quotes when your run it) Use the arrow keys on the keyboard to select item and the up/dn arrow keys to adjust volume. If you see MM at the bottom of anything it is muted so just hit the M key to unmute. You should have a number of options, click the F5 key to get all options.
 
Old 11-23-2011, 07:12 PM   #5
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Noob

Quote:
Originally Posted by yancek View Post
As suggested above, have you run "alsamixer" in a terminal? (no quotes when your run it) Use the arrow keys on the keyboard to select item and the up/dn arrow keys to adjust volume. If you see MM at the bottom of anything it is muted so just hit the M key to unmute. You should have a number of options, click the F5 key to get all options.
I'm a little green on the terminal process. could you provide a little more detail on how to do that.
I went so far as to copy the commands in terminal and get the results I posted above. Sorry, I am sure you are used to dealing with folks a little more skilled in these areas.
 
Old 11-23-2011, 07:20 PM   #6
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Re-Ran

Quote:
Originally Posted by sacksyboy View Post
I'm a little green on the terminal process. could you provide a little more detail on how to do that.
I went so far as to copy the commands in terminal and get the results I posted above. Sorry, I am sure you are used to dealing with folks a little more skilled in these areas.
I re-ran with the following results in case I changed something inadvertantly...
sacksyboy@sacksyboy-laptop:~$ sudo lsmod | grep uvc
[sudo] password for sacksyboy:
uvcvideo 57406 0
videodev 34425 1 uvcvideo
v4l1_compat 13251 2 uvcvideo,videodev
sacksyboy@sacksyboy-laptop:~$ uname -a
Linux sacksyboy-laptop 2.6.32-35-generic #78-Ubuntu SMP Tue Oct 11 15:27:15 UTC 2011 i686 GNU/Linux
sacksyboy@sacksyboy-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
cat: /proc/asound/card0/codec#*: No such file or directory
sacksyboy@sacksyboy-laptop:~$
 
Old 11-23-2011, 08:53 PM   #7
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Let's try a different way.

Code:
$ ls -la /proc/asound/card0
$ sudo lspci -v | grep -i audio
Good luck. ;-)
 
Old 11-24-2011, 10:38 AM   #8
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Output - fixed....Input - not fixed (mic)

Quote:
Originally Posted by Peacedog View Post
Let's try a different way.

Code:
$ ls -la /proc/asound/card0
$ sudo lspci -v | grep -i audio
Good luck. ;-)
UPDATE: The sound is working and so is the video in Skype. The mic is not working.
In the NGOME Alsa Mixer app, the mic option has mute unchecked and rec. is checked.

Last edited by sacksyboy; 11-24-2011 at 10:40 AM. Reason: update of information
 
Old 11-24-2011, 01:56 PM   #9
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
Does the capture work if you uncheck the rec option?

Good luck. ;-)
 
Old 11-24-2011, 08:18 PM   #10
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Peacedog View Post
Does the capture work if you uncheck the rec option?

Good luck. ;-)
i think I understand your question but correct me if I am wrong...I uncheck "rec." in the Gnome Mixer and can see test video in skype. However, when I open the mixer back up the rec. button for the mic is checked again. The microphone still does not work.
 
Old 11-24-2011, 08:40 PM   #11
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
You have to set two options in Skype, both are in Options > Sound Devices. The Sound In option is where you select the device to use. At the bottom of the Sound Devices option page there should be a check box "Allow Skype to automatically adjust my mixer levels". Choose the sound device you want to use at the top and uncheck the option at the bottom and see if that corrects the current problem.

Good luck. ;-)
 
Old 11-25-2011, 12:20 PM   #12
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Peacedog View Post
You have to set two options in Skype, both are in Options > Sound Devices. The Sound In option is where you select the device to use. At the bottom of the Sound Devices option page there should be a check box "Allow Skype to automatically adjust my mixer levels". Choose the sound device you want to use at the top and uncheck the option at the bottom and see if that corrects the current problem.

Good luck. ;-)
There is only one option for all the devices = PulseAudio
I did uncheck the mixer levels but the micropohone on the webcam is still not working.

Again, thank you for all the help.
 
Old 11-26-2011, 08:30 AM   #13
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
There is information here about using Skype with PulseAudio.

http://www.pulseaudio.org/wiki/PerfectSetup#Skype

Also there is Ubuntu specific PulseAudio help here.

https://wiki.ubuntu.com/PulseAudio

Good luck. ;-)
 
Old 11-26-2011, 11:33 AM   #14
sacksyboy
LQ Newbie
 
Registered: Nov 2011
Posts: 8

Original Poster
Rep: Reputation: Disabled
Wink

Quote:
Originally Posted by Peacedog View Post
There is information here about using Skype with PulseAudio.

http://www.pulseaudio.org/wiki/PerfectSetup#Skype

Also there is Ubuntu specific PulseAudio help here.

https://wiki.ubuntu.com/PulseAudio

Good luck. ;-)
It worked!
Thanks a million. I really appreciate the "teach a man to fish" help as I now have some additional tools at my disposal for future issues. The main problem appeared to be that I did not have pavucontrol installed which allowed me to select and input device. Once installed, the skype options menu had the greyed out "pulse audio options" available for configuration.
 
Old 11-26-2011, 01:04 PM   #15
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 168Reputation: 168
You're welcome. Glad you got it sorted.

Good luck. ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALsa and Logitech quickcam pro 9000 mwgrient Slackware 7 12-15-2008 06:27 AM
Logitech QuickCam Pro 9000 geoffames Linux - Newbie 2 11-30-2008 06:41 AM
Quickcam Pro 4000 mic leupi Linux - Hardware 0 11-10-2005 03:44 PM


All times are GMT -5. The time now is 03:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration