LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Xubuntu, Dell laptop, Sigmatel audio: no Quickcam Pro 9000 mic and no speaker sound (http://www.linuxquestions.org/questions/ubuntu-63/xubuntu-dell-laptop-sigmatel-audio-no-quickcam-pro-9000-mic-and-no-speaker-sound-914990/)

sacksyboy 11-22-2011 07:56 PM

Xubuntu, Dell laptop, Sigmatel audio: no Quickcam Pro 9000 mic and no speaker sound
 
Hi,

Noob here. I have no programming experience but I do love using linux. I have xubuntu on my dell laptop with a sigmatel audio. I installed on the weekend and cannot get skype or anything else for that matter to pick up the mic. on my quickcam pro 9000. I also have no sound through my speakers.

I'm really lost and do not know what to install and configure to get it working. Any help is much apreciated.

Thank you.

Peacedog 11-22-2011 09:42 PM

Hi sacksyboy, Welcome to LQ. Which version of Xubuntu are you using? Please post the results of the following.

Code:

$ sudo lsmod | grep uvc
$ uname -a
$ cat /proc/asound/card0/codec#* | grep Codec

Have you tried any mixers, alsamixer to adjust and unmute your sound? Once you have sound working getting Skype configured should be a matter of choosing the correct option in Skype's settings.

Good luck. ;-)

sacksyboy 11-23-2011 07:54 AM

Quote:

Originally Posted by Peacedog (Post 4531229)
Hi sacksyboy, Welcome to LQ. Which version of Xubuntu are you using? Please post the results of the following.

Code:

$ sudo lsmod | grep uvc
$ uname -a
$ cat /proc/asound/card0/codec#* | grep Codec

Have you tried any mixers, alsamixer to adjust and unmute your sound? Once you have sound working getting Skype configured should be a matter of choosing the correct option in Skype's settings.

Good luck. ;-)

Okay...took me a while to figure out where the vertical bar was on my keyboard and that I should use terminal...here are the results:

sacksyboy@sacksyboy-laptop:~$ sudo lsmod | grep uvc
[sudo] password for sacksyboy:
uvcvideo 57406 0
videodev 34425 1 uvcvideo
v4l1_compat 13251 2 uvcvideo,videodev
sacksyboy@sacksyboy-laptop:~$ uname -a
Linux sacksyboy-laptop 2.6.32-35-generic #78-Ubuntu SMP Tue Oct 11 15:27:15 UTC 2011 i686 GNU/Linux
sacksyboy@sacksyboy-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
cat: /proc/asound/card0/codec#*: No such file or directory
sacksyboy@sacksyboy-laptop:~$ ^C
sacksyboy@sacksyboy-laptop:~$

I tried pulse audio, uvcvideo and alsa but no dice. It could be that it works and I just don't know how to test it properly but I could find not testing within those applications to see if the mic or speakers were working. I would then go back to skype and try it with no success...

yancek 11-23-2011 09:14 AM

As suggested above, have you run "alsamixer" in a terminal? (no quotes when your run it) Use the arrow keys on the keyboard to select item and the up/dn arrow keys to adjust volume. If you see MM at the bottom of anything it is muted so just hit the M key to unmute. You should have a number of options, click the F5 key to get all options.

sacksyboy 11-23-2011 06:12 PM

Noob
 
Quote:

Originally Posted by yancek (Post 4531774)
As suggested above, have you run "alsamixer" in a terminal? (no quotes when your run it) Use the arrow keys on the keyboard to select item and the up/dn arrow keys to adjust volume. If you see MM at the bottom of anything it is muted so just hit the M key to unmute. You should have a number of options, click the F5 key to get all options.

I'm a little green on the terminal process. could you provide a little more detail on how to do that.
I went so far as to copy the commands in terminal and get the results I posted above. Sorry, I am sure you are used to dealing with folks a little more skilled in these areas.

sacksyboy 11-23-2011 06:20 PM

Re-Ran
 
Quote:

Originally Posted by sacksyboy (Post 4532219)
I'm a little green on the terminal process. could you provide a little more detail on how to do that.
I went so far as to copy the commands in terminal and get the results I posted above. Sorry, I am sure you are used to dealing with folks a little more skilled in these areas.

I re-ran with the following results in case I changed something inadvertantly...
sacksyboy@sacksyboy-laptop:~$ sudo lsmod | grep uvc
[sudo] password for sacksyboy:
uvcvideo 57406 0
videodev 34425 1 uvcvideo
v4l1_compat 13251 2 uvcvideo,videodev
sacksyboy@sacksyboy-laptop:~$ uname -a
Linux sacksyboy-laptop 2.6.32-35-generic #78-Ubuntu SMP Tue Oct 11 15:27:15 UTC 2011 i686 GNU/Linux
sacksyboy@sacksyboy-laptop:~$ cat /proc/asound/card0/codec#* | grep Codec
cat: /proc/asound/card0/codec#*: No such file or directory
sacksyboy@sacksyboy-laptop:~$

Peacedog 11-23-2011 07:53 PM

Let's try a different way.

Code:

$ ls -la /proc/asound/card0
$ sudo lspci -v | grep -i audio

Good luck. ;-)

sacksyboy 11-24-2011 09:38 AM

Output - fixed....Input - not fixed (mic)
 
Quote:

Originally Posted by Peacedog (Post 4532292)
Let's try a different way.

Code:

$ ls -la /proc/asound/card0
$ sudo lspci -v | grep -i audio

Good luck. ;-)

UPDATE: The sound is working and so is the video in Skype. The mic is not working.
In the NGOME Alsa Mixer app, the mic option has mute unchecked and rec. is checked.

Peacedog 11-24-2011 12:56 PM

Does the capture work if you uncheck the rec option?

Good luck. ;-)

sacksyboy 11-24-2011 07:18 PM

Quote:

Originally Posted by Peacedog (Post 4532981)
Does the capture work if you uncheck the rec option?

Good luck. ;-)

i think I understand your question but correct me if I am wrong...I uncheck "rec." in the Gnome Mixer and can see test video in skype. However, when I open the mixer back up the rec. button for the mic is checked again. The microphone still does not work.

Peacedog 11-24-2011 07:40 PM

You have to set two options in Skype, both are in Options > Sound Devices. The Sound In option is where you select the device to use. At the bottom of the Sound Devices option page there should be a check box "Allow Skype to automatically adjust my mixer levels". Choose the sound device you want to use at the top and uncheck the option at the bottom and see if that corrects the current problem.

Good luck. ;-)

sacksyboy 11-25-2011 11:20 AM

Quote:

Originally Posted by Peacedog (Post 4533200)
You have to set two options in Skype, both are in Options > Sound Devices. The Sound In option is where you select the device to use. At the bottom of the Sound Devices option page there should be a check box "Allow Skype to automatically adjust my mixer levels". Choose the sound device you want to use at the top and uncheck the option at the bottom and see if that corrects the current problem.

Good luck. ;-)

There is only one option for all the devices = PulseAudio
I did uncheck the mixer levels but the micropohone on the webcam is still not working.

Again, thank you for all the help.

Peacedog 11-26-2011 07:30 AM

There is information here about using Skype with PulseAudio.

http://www.pulseaudio.org/wiki/PerfectSetup#Skype

Also there is Ubuntu specific PulseAudio help here.

https://wiki.ubuntu.com/PulseAudio

Good luck. ;-)

sacksyboy 11-26-2011 10:33 AM

Quote:

Originally Posted by Peacedog (Post 4534374)
There is information here about using Skype with PulseAudio.

http://www.pulseaudio.org/wiki/PerfectSetup#Skype

Also there is Ubuntu specific PulseAudio help here.

https://wiki.ubuntu.com/PulseAudio

Good luck. ;-)

It worked!
Thanks a million. I really appreciate the "teach a man to fish" help as I now have some additional tools at my disposal for future issues. The main problem appeared to be that I did not have pavucontrol installed which allowed me to select and input device. Once installed, the skype options menu had the greyed out "pulse audio options" available for configuration.

Peacedog 11-26-2011 12:04 PM

You're welcome. Glad you got it sorted.

Good luck. ;-)


All times are GMT -5. The time now is 01:44 AM.