LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Xubuntu and Atheros AR9285 (http://www.linuxquestions.org/questions/ubuntu-63/xubuntu-and-atheros-ar9285-801549/)

Majusiak 04-12-2010 08:31 AM

Xubuntu and Atheros AR9285
 
well first, im not a complete noob with linux, just really close to one. lol. And any time i try to get wireless up, regardless of the hardware, i just cant seem to get it right.
Recently I bought a new laptop cuz im going to be starting school this summer term. obviously the first thing i wanted to do with it was throw linux on. So I did. The laptop is an HP G71. And im running Xubuntu 9.10 amd64. Everything works except for my sound and my wireless. the sound is another issue. i get to it eventually or ill ask for help on here again. lol. My problem is the wireless. i have no clue what to do right now.

my lspci output shows the device.
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

iwconfig shows a wlan.
wlan0 IEEE 802.11bgn ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


but the xubuntu network manager is saying that wireless is disabled. If you need more info just ask. any help would be greatly appreciated. :D

ryro22 04-12-2010 01:39 PM

Hmm. I'm not sure about the networking as I have had trouble with connecting to a wireless network with my Atheros wireless card as well. The Atheros drivers have really spotty support for WPA2 Enterprise, which means I can't use the wireless network at my university.

What you can try is upgrading Network Manager to the latest version from the devs. Although I can't guarantee that this will fix it, there is certainly a chance that it might.

Also, double check the wireless switch on your netbook. Those things are evil and make it ridiculously easy to accidentally switch off your wireless card.

------

About the sound. You can try upgrading the ALSA drivers to the latest versions to see if they have better support for your netbook's sound.

To upgrade both the ALSA and Network Manager drivers, you can add the driver repository for my distro to your sources. Although this repository is meant my distro, all the packages on it will work perfectly on Xubuntu 9.10.

You can check and see what packages my repository includes by going to https://launchpad.net/~infinityos/+a...esting-drivers

-----

To upgrade the drivers and add my repo to your sources, enter the following commands into your terminal:

Code:

$ sudo add-apt-repository ppa:infinityos/testing-drivers
$ sudo aptitude update
$ sudo aptitude dist-upgrade

You will need to restart your computer after those commands are completed.

Majusiak 04-12-2010 07:32 PM

awesome. i just upgraded everything and my network manager was a little screwwy i guess. my wireless works pretty damn good now.

But the audio still isnt working. Maybe someone can help. lol.
heres my lspci output:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

ryro22 04-12-2010 09:11 PM

Hmm. Check and see if your audio output is set to your sound card in Xfce Mixer. You may have to enable some extra controls and unmute some stuff.

If that fails, check and see if PulseAudio is installed (using Synaptic).

If it is, remove it using the following commands:

Code:

$ sudo aptitude install gnome-media
$ sudo aptitude purge pulseaudio gstreamer0.10-pulseaudio
$ sudo aptitude autoremove
$ sudo aptitude alsa-base alsa-tools alsa-tools-gui alsa-utils alsa-oss linux-sound-base alsamixergui
$ sudo aptitude purge pulseaudio gstreamer0.10-pulseaudio
$ sudo aptitude autoremove

Then run the following command:
Code:

$ gstreamer-properties
Set everything to ALSA

---------

PulseAudio is the devil. It breaks many sound cards, almost all games, and Adobe Flash.

Majusiak 04-13-2010 06:27 AM

removed pulseaudio. Made assigned my card on the mixer. set everything to alsa. No sound. :(

ryro22 04-13-2010 01:13 PM

Hmm. Try unmuting all your outputs/controls in the mixer. I had to unmute my headphone jack before it would work on my Macbook.

Majusiak 04-13-2010 07:41 PM

did that as well. I enabled all the options for alsa and even oss. unmuted everything. No luck tho.

ryro22 04-13-2010 11:15 PM

Try this:

Quote:

2. Add the options to /etc/modprobe.d/alsa-base.conf

Open a terminal and do....

Code:
$ sudo gedit /etc/modprobe.d/alsa-base.conf
Go to the bottom of the file and add the following line.

Code:
options snd-hda-intel model=dell-m4-3 enable_msi=1
You will need to reboot afterwards.

Copied from http://ubuntuforums.org/showthread.php?t=1292587

Majusiak 04-15-2010 12:23 AM

THANK YOU!!!! lol
it works!! and damn is it loud!!! lol, i had to lower all my volumes. :P
thank u so much for all ur help dude. :D


All times are GMT -5. The time now is 05:21 AM.