LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2006, 10:13 PM   #1
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Rep: Reputation: 30
xorg.conf updates not taking effect/Laptop Touchpad Issues


My Edgy install does NOT recognize my laptop's synaptics touchpad properly (I can't scroll down a window using the side of the touchpad). So, I saved a copy of my xorg.conf from my previous Dapper install. Under Dapper my touchpad worked GREAT! I replaced Edgy's xorg.conf file with the one I had from Dapper. After replacing the file I "ctrl+alt+backspace" and login......my touchpad works again. If I restart my computer I'm back to touchpad that doesn't work again. If I "ctrl+alt+backspace", it works again. What is going on? Is xorg.conf not being updated or is this different problem entirely? I never had this issue under Dapper.

Thanks for your help!
 
Old 12-03-2006, 10:24 PM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
https://launchpad.net/distros/ubuntu...org/+bug/46700
 
Old 12-03-2006, 11:20 PM   #3
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
Thank you for the link. I checked my xorg.conf file and made sure that it is configured as it should be. Once again, on bootup my touchpad is frozen. I must move my finger on the touchpad for a couple seconds for the touchpad to be activated. After I log in to Gnome and try using the scrolling functions...it doesn't work. If I do "ctrl+alt+backspace" and log back in, the touchpad is properly configured. How to I get my machine to properly recognize the touchpad on boot up??

Since I don't use an external mouse, I am going to try commenting out the section of the xorg.conf that makes reference for a generic mouse device. Perhaps that will help.


**EDIT**

commenting the generic mouse section didn't do anything.

Last edited by tubatodd; 12-03-2006 at 11:36 PM.
 
Old 12-04-2006, 02:27 AM   #4
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Did you follow the link to the fix?
I got mine set so, not only do I get the scroll option, I can also switch the touchpad off/on with ctrl+F9. I can rt-click with 2-finger taps... the works. I keep the configuration with qsynaptics -r and xbindkeys in the startup dialog.

Lets have a look at your xorg.conf then.
 
Old 12-04-2006, 06:26 AM   #5
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
My xorg.conf
------------

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection
.
.
.
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"

EndSection

Section "DRI"
Mode 0666
EndSection


NOTE
I removed all of the wacom lines. I have gsynaptics installed. The "gysnaptics-init --sm-disable" was loaded on Gnome startup by gsynaptics automatically. "gsynaptics -r" only brings up the configuration manager.

todd@todd-laptop:~$ cat /proc/bus/input/devices
.
.
.
I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="PS/2 Mouse"
P: Phys=isa0060/serio4/input1
S: Sysfs=/class/input/input3
H: Handlers=mouse0 event1 ts0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=7321
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio4/input0
S: Sysfs=/class/input/input4
H: Handlers=mouse1 event3 ts1
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003

ahhhhhhh

Why is it that if I do ctrl+alt+backspace....everything is fine? Edgy just won't detect the touchpad on initial startup. Under Dapper...I had no problems at all. I updated to Edgy before and got fed up so I went back to Dapper. I currently have Edgy installed and I don't want to redo my system AGAIN and put Dapper back on my machine in order to get this to work.
 
Old 12-04-2006, 12:13 PM   #6
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
Last night I checked the xorg log files to see if there are any errors. I'm not familiar with what the log file SHOULD have looked like but I did notice that on bootup it says something about Alps Touchpad being input2, but when I do the ctrl+alt+backspace and the touchpad now works the log file NOW says Alps Touchpad being input3.

I read something about modifying the xorg.conf to say "/dev/something/input3" instead of /dev/psaux


help help help
 
Old 12-05-2006, 05:37 AM   #7
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
Problem "solved"...........


I reinstalled Dapper


NONE of the information I read on the web or any of the information in the link above....worked. I still can NOT explain why Edgy would NOT recognize the touchpad on initial startup. Once again, I could get it to work if I restarted X using ctrl+alt+backspace, but the touchpad would not configure properly on the initial X bootup.
 
Old 12-06-2006, 08:33 PM   #8
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
Problem "solved"........... I reinstalled Dapper
Not exactly a "solution".

Edgy probably just didn't load the driver in the initial setup - or loaded the touchpad "disabled" - no nothing happened. I've got a script in startup programs to make sure the proper settings are loaded when I login.

Edgy comes with a thing called "synclient" which is supposed to help.
http://www.mail-archive.com/laptop-t.../msg00986.html
 
Old 12-07-2006, 01:10 PM   #9
tubatodd
Member
 
Registered: Jun 2003
Location: Birmingham, Alabama (USA)
Distribution: Slackware
Posts: 351

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Simon Bridge
Not exactly a "solution".

Edgy probably just didn't load the driver in the initial setup - or loaded the touchpad "disabled" - no nothing happened. I've got a script in startup programs to make sure the proper settings are loaded when I login.

Edgy comes with a thing called "synclient" which is supposed to help.
http://www.mail-archive.com/laptop-t.../msg00986.html

HOW? How do I get it to load on initial startup??
 
Old 12-08-2006, 02:52 AM   #10
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
System > preferences > sessions > startup programs
... allows you to add programs which you want to start when you login.

I have "qsynaptics -r" in there to get my syanptics settings remembered.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg.conf on an ubuntu laptop with second screen chr15t0 Ubuntu 1 05-22-2006 05:12 PM
Voodoo3 stuck in 640x480 and changing xorg.conf has no effect Zeppelin_ii Linux - Software 4 03-27-2006 06:55 PM
nvidia driver, twinview, xorg.conf issues on fedora 4-64 elpatan Fedora 2 01-24-2006 11:18 PM
xorg.conf for Laptop & external display. Riddick Linux - Software 11 12-03-2005 04:24 PM
xorg.conf - video && touchpad problem * (Dell C640) Pear-i Linux - Laptop and Netbook 2 07-27-2005 08:12 AM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration