LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   xorg.conf updates not taking effect/Laptop Touchpad Issues (http://www.linuxquestions.org/questions/ubuntu-63/xorg-conf-updates-not-taking-effect-laptop-touchpad-issues-507261/)

tubatodd 12-03-2006 10:13 PM

xorg.conf updates not taking effect/Laptop Touchpad Issues
 
My Edgy install does NOT recognize my laptop's synaptics touchpad properly (I can't scroll down a window using the side of the touchpad). So, I saved a copy of my xorg.conf from my previous Dapper install. Under Dapper my touchpad worked GREAT! I replaced Edgy's xorg.conf file with the one I had from Dapper. After replacing the file I "ctrl+alt+backspace" and login......my touchpad works again. If I restart my computer I'm back to touchpad that doesn't work again. If I "ctrl+alt+backspace", it works again. What is going on? Is xorg.conf not being updated or is this different problem entirely? I never had this issue under Dapper.

Thanks for your help! :)

Simon Bridge 12-03-2006 10:24 PM

https://launchpad.net/distros/ubuntu...org/+bug/46700

tubatodd 12-03-2006 11:20 PM

Thank you for the link. I checked my xorg.conf file and made sure that it is configured as it should be. Once again, on bootup my touchpad is frozen. I must move my finger on the touchpad for a couple seconds for the touchpad to be activated. After I log in to Gnome and try using the scrolling functions...it doesn't work. If I do "ctrl+alt+backspace" and log back in, the touchpad is properly configured. How to I get my machine to properly recognize the touchpad on boot up??

Since I don't use an external mouse, I am going to try commenting out the section of the xorg.conf that makes reference for a generic mouse device. Perhaps that will help.


**EDIT**

commenting the generic mouse section didn't do anything.

Simon Bridge 12-04-2006 02:27 AM

Did you follow the link to the fix?
I got mine set so, not only do I get the scroll option, I can also switch the touchpad off/on with ctrl+F9. I can rt-click with 2-finger taps... the works. I keep the configuration with qsynaptics -r and xbindkeys in the startup dialog.

Lets have a look at your xorg.conf then.

tubatodd 12-04-2006 06:26 AM

My xorg.conf
------------

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection
.
.
.
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"

EndSection

Section "DRI"
Mode 0666
EndSection


NOTE
I removed all of the wacom lines. I have gsynaptics installed. The "gysnaptics-init --sm-disable" was loaded on Gnome startup by gsynaptics automatically. "gsynaptics -r" only brings up the configuration manager.

todd@todd-laptop:~$ cat /proc/bus/input/devices
.
.
.
I: Bus=0011 Vendor=0002 Product=0008 Version=0000
N: Name="PS/2 Mouse"
P: Phys=isa0060/serio4/input1
S: Sysfs=/class/input/input3
H: Handlers=mouse0 event1 ts0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0011 Vendor=0002 Product=0008 Version=7321
N: Name="AlpsPS/2 ALPS GlidePoint"
P: Phys=isa0060/serio4/input0
S: Sysfs=/class/input/input4
H: Handlers=mouse1 event3 ts1
B: EV=f
B: KEY=420 0 70000 0 0 0 0 0 0 0 0
B: REL=3
B: ABS=1000003

ahhhhhhh

Why is it that if I do ctrl+alt+backspace....everything is fine? Edgy just won't detect the touchpad on initial startup. Under Dapper...I had no problems at all. I updated to Edgy before and got fed up so I went back to Dapper. I currently have Edgy installed and I don't want to redo my system AGAIN and put Dapper back on my machine in order to get this to work.

tubatodd 12-04-2006 12:13 PM

Last night I checked the xorg log files to see if there are any errors. I'm not familiar with what the log file SHOULD have looked like but I did notice that on bootup it says something about Alps Touchpad being input2, but when I do the ctrl+alt+backspace and the touchpad now works the log file NOW says Alps Touchpad being input3.

I read something about modifying the xorg.conf to say "/dev/something/input3" instead of /dev/psaux


help help help

tubatodd 12-05-2006 05:37 AM

Problem "solved"...........


I reinstalled Dapper


NONE of the information I read on the web or any of the information in the link above....worked. I still can NOT explain why Edgy would NOT recognize the touchpad on initial startup. Once again, I could get it to work if I restarted X using ctrl+alt+backspace, but the touchpad would not configure properly on the initial X bootup.

Simon Bridge 12-06-2006 08:33 PM

Quote:

Problem "solved"........... I reinstalled Dapper
Not exactly a "solution".

Edgy probably just didn't load the driver in the initial setup - or loaded the touchpad "disabled" - no nothing happened. I've got a script in startup programs to make sure the proper settings are loaded when I login.

Edgy comes with a thing called "synclient" which is supposed to help.
http://www.mail-archive.com/laptop-t.../msg00986.html

tubatodd 12-07-2006 01:10 PM

Quote:

Originally Posted by Simon Bridge
Not exactly a "solution".

Edgy probably just didn't load the driver in the initial setup - or loaded the touchpad "disabled" - no nothing happened. I've got a script in startup programs to make sure the proper settings are loaded when I login.

Edgy comes with a thing called "synclient" which is supposed to help.
http://www.mail-archive.com/laptop-t.../msg00986.html


HOW? How do I get it to load on initial startup??

Simon Bridge 12-08-2006 02:52 AM

System > preferences > sessions > startup programs
... allows you to add programs which you want to start when you login.

I have "qsynaptics -r" in there to get my syanptics settings remembered.


All times are GMT -5. The time now is 09:17 PM.