-   Ubuntu (
-   -   X applications ignore UMASK settings (

thejasondean 01-10-2007 05:46 AM

X applications ignore UMASK settings
hi all,
i've tried setting the UMASK throught ~/.bash_profile and /etc/login.defs and even /etc/gdm/Xsession
but X applications completely ignore my modifications and make all files unreadable by all users in my group.

The problem is that all files i create under /var/www are not readable by apache and so i have to manualy chmod from a terminal every time i create a file.

Which file must i edit in order to have X applications use my UMASK setting ?

All times are GMT -5. The time now is 04:53 AM.