LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 01-24-2011, 09:30 AM   #1
fjd
Member
 
Registered: Apr 2006
Distribution: Ubuntu 10.10
Posts: 39

Rep: Reputation: 15
Wireless became disabled - how do I enable?


I have been using ubuntu 10.10 (running on a Dell Inspiron N4010) for a couple months and love it but the wireless just recently stopped working and I can't figure out how to re-enable it. I've searched endlessly the FAQ's, forums, etc but nothing seems to work.

uname -r
2.6.35-24-generic-pae

The output from lshw -C network
Code:
 *-network DISABLED
       description: Wireless interface
       product: BCM4313 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth1
       version: 01
       serial: 1c:65:9d:99:3d:d1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=5.60.48.36 latency=0 multicast=yes wireless=IEEE 802.11
Output from # iwconfig
Code:
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:8 Mb/s   Tx-Power:24 dBm   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=5/5  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
The directory listing from /etc/modprobe.d
# ls -aFC
./ blacklist-firewire.conf
../ blacklist-framebuffer.conf
alsa-base.conf blacklist-modem.conf
blacklist-ath_pci.conf blacklist-oss.conf@
blacklist-bcm43.conf blacklist-watchdog.conf
blacklist.conf intel-5300-iwlagn-disable11n.conf
root@fjd-Inspiron-N4010:/etc/modprobe.d


Output from lsmod |grep wl
wl 1959565 0
lib80211 5058 2 lib80211_crypt_tkip,wl

Any help would be greatly appreciated.
 
Old 01-24-2011, 09:50 AM   #2
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
Try posting the output of this:

Code:
sudo iwlist wlan0 scanning
If it returns networks, you're connected.
 
Old 01-24-2011, 10:45 AM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,863

Rep: Reputation: 739Reputation: 739Reputation: 739Reputation: 739Reputation: 739Reputation: 739Reputation: 739
Quote:
Originally Posted by Kenny_Strawn View Post

If it returns networks, you're connected.
Not necessarily. However, it will show if the OPs Access Point is visible/active and its current signal strength. Without knowing any details all the OP might have to accomplish is click on the wireless icon and select the correct essid.
 
Old 01-24-2011, 12:49 PM   #4
fjd
Member
 
Registered: Apr 2006
Distribution: Ubuntu 10.10
Posts: 39

Original Poster
Rep: Reputation: 15
Here is the output of: sudo iwlist wlan0 scanning
wlan0 Interface doesn't support scanning.

I can edit the wireless connection but I can't select it since it doesn't show up on the dropdown menu. It just says "Wireless Networks ...then wireless is disabled".
 
Old 01-24-2011, 05:05 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,863

Rep: Reputation: 739Reputation: 739Reputation: 739Reputation: 739Reputation: 739Reputation: 739Reputation: 739
Fn F2 turns on/off wireless adapter. Try toggling the function switch. Does the laptop have a wireless ON LED?

Last edited by michaelk; 01-24-2011 at 07:18 PM.
 
Old 01-24-2011, 07:12 PM   #6
fjd
Member
 
Registered: Apr 2006
Distribution: Ubuntu 10.10
Posts: 39

Original Poster
Rep: Reputation: 15
SOLVED! Michael - I don't believe it but yes that was the problem (I hang my head in shame). There is no LED for wireless on my laptop and it wasn't a function+F2. I actually tried that and it didn't work prior. After reading your post I just realized it's a CTRL+F2 to switch on and off. For the archive record for anyone else with this problem: After CTRL+F2 I needed to right click (not left) on the network icon on the panel. Then check off Enable Wireless. After that I needed to choose my network from the list.
Thank you very much Michael - that one tripped me up.
 
Old 05-22-2011, 10:10 PM   #7
glsen_az
Member
 
Registered: Oct 2003
Location: Tucson, AZ
Distribution: XUbuntu 12.10, Smoothwall 3
Posts: 32

Rep: Reputation: 15
SOLVED - quick write-up.

Here's what I did to get my HP Pavilion DV2000 laptop (works like a charm with Ubuntu 10.10) to re-enable the wireless interface:
Wireless had been working just fine. I was going to be using only wired connection for a while, so I decided to just flip the wireless switch to OFF. Seems that the physical hardware switch to turn wireless networking (and Bluetooth) off actually sets a software setting in Ubuntu to DISABLE the wireless interface(s). Hardware switch on my HP Pavilion DV2000 is ON when pushed towards the RIGHT and OFF when towards the LEFT. Here's what I did to get things working.

Entered the command string:
$ sudo ifconfig wlan0 up

(got the following response - pay attention to the "RF-kill" bits.)
SIOCSIFFLAGS: Operation not possible due to RF-kill

(OK - at this point, I entered the following search term in Google:
ubuntu 10.10 + SIOCSIFFLAGS: Operation not possible due to RF-kill
Came up with web sites that had info about the RF-Kill command and its options.)

(this checks what the NetworkManager thinks is happening - I had already used sudo to edit the following file with VI and set the "WirelessEnabled=false" to "true")
$ cat /var/lib/NetworkManager/NetworkManager.state
OUTPUT:
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

(now, remember the rfkill command? Use the following while moving the switch back and forth to see how the OS is really seeing)
$ sudo rfkill event
(OUTPUT)
type 1 op 0 soft 1 hard 1
type 1 op 0 soft 1 hard 0
type 2 op 0 soft 0 hard 0
...
(1st line shows that both the software & hardware are ON (1s) while line #3 shows both software & hardware are OFF (0s) - this is real time so moving switch produces more output, just watch the differences carefully.)
(now, do the following command to see that the OS says the wireless interface is indeed disabled, as far as it's concerned.)

$ sudo lshw -C network
(OUTPUT)
*-network DISABLED
description: Wireless interface
logical name: wlan0
(do that RFKILL again with different parameter and see the data listed in a bit more human-friendly format)

$ sudo rfkill list all
(OUTPUT)
0: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes
1: hp-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: yes
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: yes
(shows both software & hardware "switches" for wireless are currently "blocked" Note the Bluetooth hardware switch is turned off - wireless & Bluetooth share the same switch.)

(use the rfkill with Super User rights to unblock all the interfaces)
$ sudo rfkill unblock all
(then do the lshw to show what if anything is disabled)
$ sudo lshw -C network
(OUTPUT)
*-network
description: Wireless interface

(OK, looks good! Check the NetworkManager's state)
$ cat /var/lib/NetworkManager/NetworkManager.state
(OUTPUT)
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

(Joy! The WiFi starts to do a DHCP lease request after issuing the network restart command with the following)
$ sudo /etc/init.d/network-manager restart
(should be good to go!)

Hope this helps!

-*-Bill

Last edited by glsen_az; 05-22-2011 at 10:17 PM.
 
Old 10-17-2011, 12:34 PM   #8
anajuliaqm
LQ Newbie
 
Registered: Oct 2011
Posts: 1

Rep: Reputation: Disabled
Thanks!

glsen_az you saved my netbook. I have a HP Mini 210-1020BR and it wouldn't connect nor find wireless networks. I've already done almost everything 'till I found your post here and it worked. Thanks a lot!
 
Old 11-16-2011, 06:17 AM   #9
beadrifle
LQ Newbie
 
Registered: Aug 2010
Posts: 2

Rep: Reputation: 0
glsen_az's solution for an HP dv2000 series laptop works perfectly. Thanks a ton, kudos; you just saved someone a lot of trouble!
 
Old 02-06-2012, 04:09 PM   #10
jamalparit
LQ Newbie
 
Registered: Feb 2012
Posts: 1

Rep: Reputation: Disabled
Thank You ... i got my wireless back
 
Old 05-27-2012, 10:40 AM   #11
alteredboot
LQ Newbie
 
Registered: May 2012
Posts: 1

Rep: Reputation: Disabled
Another thanks to glsen_az. As a linux noob, I appreciate that the solution was easy to follow and understand. It worked perfectly.
 
Old 06-02-2012, 12:01 AM   #12
clanmills
LQ Newbie
 
Registered: Sep 2009
Location: San Jose, CA
Distribution: Ubuntu
Posts: 2
Blog Entries: 1

Rep: Reputation: Disabled
Thanks glsen_az - you've got my wifi back.
 
Old 07-18-2012, 12:52 AM   #13
ashishgrover
LQ Newbie
 
Registered: Jul 2012
Posts: 1

Rep: Reputation: Disabled
Wink Thanks

Thanks I am using Linux Mint 13 on Sony Vaio SVS13112EN
Faced similar problem, wifi was working fine until I disabled "Networking" from Network Manager once.
And there was no way to enable it. (Network manager showed it greyed out)
Following command:-

sudo rfkill list all

enabled the menu option. Then I selected and Enabled the check Box.
Wifi working fine again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I Disabled gnome-screensaver, and I Need to Enable It Again Teasdale Ubuntu 7 01-26-2009 02:13 PM
HD access disabled, can I enable it? JoeFisher57 Linux - Hardware 10 12-31-2007 08:37 PM
How do I Enable Samba & NFS File Sharing Scriptsd for wired, but Disabled 4 wireless Old_Fogie Slackware 7 06-03-2006 09:00 PM
repeat key disabled. how to enable it again? neon Linux - Newbie 0 11-20-2003 07:47 PM
Session is disabled. How to enable it again? concoran Linux - General 6 11-19-2001 10:06 PM


All times are GMT -5. The time now is 04:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration