LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Wireless became disabled - how do I enable? (http://www.linuxquestions.org/questions/ubuntu-63/wireless-became-disabled-how-do-i-enable-858357/)

fjd 01-24-2011 10:30 AM

Wireless became disabled - how do I enable?
 
I have been using ubuntu 10.10 (running on a Dell Inspiron N4010) for a couple months and love it but the wireless just recently stopped working and I can't figure out how to re-enable it. I've searched endlessly the FAQ's, forums, etc but nothing seems to work.

uname -r
2.6.35-24-generic-pae

The output from lshw -C network
Code:

*-network DISABLED
      description: Wireless interface
      product: BCM4313 802.11b/g LP-PHY
      vendor: Broadcom Corporation
      physical id: 0
      bus info: pci@0000:03:00.0
      logical name: eth1
      version: 01
      serial: 1c:65:9d:99:3d:d1
      width: 64 bits
      clock: 33MHz
      capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
      configuration: broadcast=yes driver=wl0 driverversion=5.60.48.36 latency=0 multicast=yes wireless=IEEE 802.11

Output from # iwconfig
Code:

lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated 
          Bit Rate:8 Mb/s  Tx-Power:24 dBm 
          Retry min limit:7  RTS thr:off  Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=5/5  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

The directory listing from /etc/modprobe.d
# ls -aFC
./ blacklist-firewire.conf
../ blacklist-framebuffer.conf
alsa-base.conf blacklist-modem.conf
blacklist-ath_pci.conf blacklist-oss.conf@
blacklist-bcm43.conf blacklist-watchdog.conf
blacklist.conf intel-5300-iwlagn-disable11n.conf
root@fjd-Inspiron-N4010:/etc/modprobe.d


Output from lsmod |grep wl
wl 1959565 0
lib80211 5058 2 lib80211_crypt_tkip,wl

Any help would be greatly appreciated.

Kenny_Strawn 01-24-2011 10:50 AM

Try posting the output of this:

Code:

sudo iwlist wlan0 scanning
If it returns networks, you're connected.

michaelk 01-24-2011 11:45 AM

Quote:

Originally Posted by Kenny_Strawn (Post 4236127)

If it returns networks, you're connected.

Not necessarily. However, it will show if the OPs Access Point is visible/active and its current signal strength. Without knowing any details all the OP might have to accomplish is click on the wireless icon and select the correct essid.

fjd 01-24-2011 01:49 PM

Here is the output of: sudo iwlist wlan0 scanning
wlan0 Interface doesn't support scanning.

I can edit the wireless connection but I can't select it since it doesn't show up on the dropdown menu. It just says "Wireless Networks ...then wireless is disabled".

michaelk 01-24-2011 06:05 PM

Fn F2 turns on/off wireless adapter. Try toggling the function switch. Does the laptop have a wireless ON LED?

fjd 01-24-2011 08:12 PM

SOLVED! Michael - I don't believe it but yes that was the problem (I hang my head in shame). There is no LED for wireless on my laptop and it wasn't a function+F2. I actually tried that and it didn't work prior. After reading your post I just realized it's a CTRL+F2 to switch on and off. For the archive record for anyone else with this problem: After CTRL+F2 I needed to right click (not left) on the network icon on the panel. Then check off Enable Wireless. After that I needed to choose my network from the list.
Thank you very much Michael - that one tripped me up.

glsen_az 05-22-2011 11:10 PM

SOLVED - quick write-up.
 
Here's what I did to get my HP Pavilion DV2000 laptop (works like a charm with Ubuntu 10.10) to re-enable the wireless interface:
Wireless had been working just fine. I was going to be using only wired connection for a while, so I decided to just flip the wireless switch to OFF. Seems that the physical hardware switch to turn wireless networking (and Bluetooth) off actually sets a software setting in Ubuntu to DISABLE the wireless interface(s). Hardware switch on my HP Pavilion DV2000 is ON when pushed towards the RIGHT and OFF when towards the LEFT. Here's what I did to get things working.

Entered the command string:
$ sudo ifconfig wlan0 up

(got the following response - pay attention to the "RF-kill" bits.)
SIOCSIFFLAGS: Operation not possible due to RF-kill

(OK - at this point, I entered the following search term in Google:
ubuntu 10.10 + SIOCSIFFLAGS: Operation not possible due to RF-kill
Came up with web sites that had info about the RF-Kill command and its options.)

(this checks what the NetworkManager thinks is happening - I had already used sudo to edit the following file with VI and set the "WirelessEnabled=false" to "true")
$ cat /var/lib/NetworkManager/NetworkManager.state
OUTPUT:
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

(now, remember the rfkill command? Use the following while moving the switch back and forth to see how the OS is really seeing)
$ sudo rfkill event
(OUTPUT)
type 1 op 0 soft 1 hard 1
type 1 op 0 soft 1 hard 0
type 2 op 0 soft 0 hard 0
...
(1st line shows that both the software & hardware are ON (1s) while line #3 shows both software & hardware are OFF (0s) - this is real time so moving switch produces more output, just watch the differences carefully.)
(now, do the following command to see that the OS says the wireless interface is indeed disabled, as far as it's concerned.)

$ sudo lshw -C network
(OUTPUT)
*-network DISABLED
description: Wireless interface
logical name: wlan0
(do that RFKILL again with different parameter and see the data listed in a bit more human-friendly format)

$ sudo rfkill list all
(OUTPUT)
0: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes
1: hp-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: yes
2: hp-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: yes
(shows both software & hardware "switches" for wireless are currently "blocked" Note the Bluetooth hardware switch is turned off - wireless & Bluetooth share the same switch.)

(use the rfkill with Super User rights to unblock all the interfaces)
$ sudo rfkill unblock all
(then do the lshw to show what if anything is disabled)
$ sudo lshw -C network
(OUTPUT)
*-network
description: Wireless interface

(OK, looks good! Check the NetworkManager's state)
$ cat /var/lib/NetworkManager/NetworkManager.state
(OUTPUT)
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

(Joy! The WiFi starts to do a DHCP lease request after issuing the network restart command with the following)
$ sudo /etc/init.d/network-manager restart
(should be good to go!)

Hope this helps!

-*-Bill

anajuliaqm 10-17-2011 01:34 PM

Thanks!
 
glsen_az you saved my netbook. I have a HP Mini 210-1020BR and it wouldn't connect nor find wireless networks. I've already done almost everything 'till I found your post here and it worked. Thanks a lot!

beadrifle 11-16-2011 07:17 AM

glsen_az's solution for an HP dv2000 series laptop works perfectly. Thanks a ton, kudos; you just saved someone a lot of trouble!

jamalparit 02-06-2012 05:09 PM

Thank You ... i got my wireless back

alteredboot 05-27-2012 11:40 AM

Another thanks to glsen_az. As a linux noob, I appreciate that the solution was easy to follow and understand. It worked perfectly.

clanmills 06-02-2012 01:01 AM

Thanks glsen_az - you've got my wifi back.

ashishgrover 07-18-2012 01:52 AM

Thanks
 
Thanks I am using Linux Mint 13 on Sony Vaio SVS13112EN
Faced similar problem, wifi was working fine until I disabled "Networking" from Network Manager once.
And there was no way to enable it. (Network manager showed it greyed out)
Following command:-

sudo rfkill list all

enabled the menu option. Then I selected and Enabled the check Box.
Wifi working fine again.

Struggling 10-28-2014 04:55 PM

Quote:

Originally Posted by ashishgrover (Post 4731314)
Thanks I am using Linux Mint 13 on Sony Vaio SVS13112EN
Faced similar problem, wifi was working fine until I disabled "Networking" from Network Manager once.
And there was no way to enable it. (Network manager showed it greyed out)
Following command:-

sudo rfkill list all

enabled the menu option. Then I selected and Enabled the check Box.
Wifi working fine again.



I tired to enter the command, but after entering the command, it wouldn't let me type anything even though it asked for a password. I've tried everything, but I can get my Internet to reconnect!


All times are GMT -5. The time now is 03:54 PM.