LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 05-13-2012, 07:30 PM   #1
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Linux Mint
Posts: 263

Rep: Reputation: Disabled
Wifi blocked.


So I was using my Linux box just fine with no issues. Up until I upgraded. I am running 11.10. I tried removing various modules and rfkill unblock all. As well as various other commands and tricks I could think of. Nothing worked. So, I reinstalled and the probelm went away until I Updated my system. Then the problem came back. When I reinstalled my system, I piped the contents of lsmod to a txt file and have compared the new results with the old.

Here are the old.
The asterisk means unchanged. The greater than sign means the amount of user(used by) has changed.
Code:
root@annonymous:/etc/init.d# lsmod
Module                  Size  Used by

*nls_utf8               12493  1 
*isofs                  39549  1 
>nls_iso8859_1          12617  2 
>nls_cp437              12751  2 
>vfat                   17308  2 
*fat                    55577  1 vfat
*rfcomm                 38408  8 
NP - bnep                   17923  2 
NP - parport_pc             32114  0 
NP - ppdev                  12849  0 
*snd_hda_codec_realtek   254163  1 
*snd_hda_intel          28358  2 
*radeon                966249  3 
*snd_hda_codec          91888  2 snd_hda_codec_realtek,snd_hda_intel
*snd_hwdep              13276  1 snd_hda_codec
*snd_pcm                80435  2 snd_hda_intel,snd_hda_codec
*snd_seq_midi           13132  0 
*snd_rawmidi            25241  1 snd_seq_midi
*snd_seq_midi_event     14475  1 snd_seq_midi
*snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
*binfmt_misc            17292  1 
*arc4                   12473  2 
*snd_timer              28932  2 snd_pcm,snd_seq
*snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
*uvcvideo               67271  0 
>btusb                  18160  2 
*ath9k                 112612  0 
*ttm                    65224  1 radeon
*joydev                 17393  0 
*mac80211              393421  1 ath9k
*ath9k_common           13599  1 ath9k
*ath9k_hw              293933  2 ath9k,ath9k_common
*ath                    19387  2 ath9k,ath9k_hw
*videodev               85626  1 uvcvideo
>bluetooth             148869  23 rfcomm,bnep,btusb
*snd                    55902  13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
*soundcore              12600  1 snd
*drm_kms_helper         32889  1 radeon
*cfg80211              172427  3 ath9k,mac80211,ath
*snd_page_alloc         14108  2 snd_hda_intel,snd_pcm
*sp5100_tco             13495  0 
*drm                   196290  5 radeon,ttm,drm_kms_helper
*k10temp                12990  0 
*rts_pstor             353227  1 
*psmouse                63474  0 
*hp_wmi                 13652  0 
*sparse_keymap          13658  1 hp_wmi
*serio_raw              12990  0 
*i2c_algo_bit           13199  1 radeon
*i2c_piix4              13093  0 
*wmi                    18744  1 hp_wmi
*video                  19069  0 
*lp                     17455  0 
>parport                40930  3 parport_pc,ppdev,lp
>usb_storage            44172  3 
*uas                    17699  0 
*ahci                   21634  1 
*libahci                25761  1 ahci
*r8169                  47200  0

New
Code:
root@amboxer21# lsmod
Module                  Size  Used by
ath9k                 112612  0 
mac80211              393421  1 ath9k
ath9k_common           13599  1 ath9k
ath9k_hw              293933  2 ath9k,ath9k_common
ath                    19387  2 ath9k,ath9k_hw
cfg80211              172427  3 ath9k,mac80211,ath
hp_wmi                 13652  0 
wmi                    18744  1 hp_wmi
sparse_keymap          13658  1 hp_wmi
nls_utf8               12493  1 
nls_iso8859_1          12617  1 
nls_cp437              12751  1 
vfat                   17308  1 
fat                    55577  1 vfat
isofs                  39549  1 
snd_hda_codec_realtek   254163  1 
sp5100_tco             13495  0 
xt_tcpudp              12531  26 
nf_conntrack_ipv4      19084  1 
nf_defrag_ipv4         12649  1 nf_conntrack_ipv4
xt_state               12514  1 
nf_conntrack           70103  2 nf_conntrack_ipv4,xt_state
iptable_filter         12706  1 
ip_tables              18106  1 iptable_filter
x_tables               21975  4 xt_tcpudp,xt_state,iptable_filter,ip_tables
joydev                 17393  0 
snd_hda_intel          28358  2 
snd_hda_codec          91888  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13276  1 snd_hda_codec
snd_pcm                80435  2 snd_hda_intel,snd_hda_codec
snd_seq_midi           13132  0 
snd_rawmidi            25241  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
arc4                   12473  2 
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
uvcvideo               67271  0 
videodev               85626  1 uvcvideo
snd_timer              28932  2 snd_pcm,snd_seq
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
psmouse                63474  0 
ath3k                  13011  0 
btusb                  18160  0 
bluetooth             148869  1 btusb
k10temp                12990  0 
serio_raw              12990  0 
snd                    55902  13 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
rts_pstor             353227  1 
soundcore              12600  1 snd
snd_page_alloc         14108  2 snd_hda_intel,snd_pcm
i2c_piix4              13093  0 
binfmt_misc            17292  1 
radeon                966249  3 
video                  19069  0 
ttm                    65224  1 radeon
drm_kms_helper         32889  1 radeon
drm                   196290  5 radeon,ttm,drm_kms_helper
i2c_algo_bit           13199  1 radeon
lp                     17455  0 
parport                40930  1 lp
usb_storage            44172  2 
uas                    17699  0 
r8169                  47200  0 
ahci                   21634  1 
libahci                25761  1 ahci

ADDED/NEW

Code:
xt_tcpudp              12531  26
nf_conntrack           70103  2 nf_conntrack_ipv4,xt_state
ip_tables              18106  1 iptable_filter
x_tables               21975  4 xt_tcpudp,xt_state,iptable_filter,ip_tables
ath3k                  13011  0
The above is the new modules that were not in the old list.

I do not want to have to reinstall my system to be able to use wifi. Can some one please help me out? Thanks!

I am running Ubuntu 11.10 on a Compaq Presario. 32bit, AMD CPU.
 
Old 05-13-2012, 09:30 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,277

Rep: Reputation: 166Reputation: 166
Hi amboxer21, Welcome to LQ. What exactly is the problem with your wifi? Is the card not configurable, is it up and not connecting to the AP, or is it not coming up at all, not recognized? Does the wifi led come on? Have you tried the wifi switch or keystroke combination on the machine to activate or turn on the wifi?

Please post the results of the following:

Code:
$ sudo ifconfig -a
$ sudo lspci -v | grep -i net
Good luck. ;-)
 
Old 05-13-2012, 10:15 PM   #3
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Linux Mint
Posts: 263

Original Poster
Rep: Reputation: Disabled
hey @ , Sorry I figured the name of my post said it all... Wifi blocked. So, Eth0 works no matter what, but after the upgrade from 11.10 to 12.04 my wifi stopped working. I toggled the switch. tried removing various modules. The only thing that seems to work is a re-installation of 11.04. Something in the new updates is doing it. Thanks Also please reread my first post.



here is the output of rfkill
Code:
root@blah# rfkill list all
3: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
10: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
11: hp-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
12: hp-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
the wlan0 interface is available just soft blocked. I have

output of lspci -v | grep -i net
Code:
root@blah# lspci -v | grep -i net
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
07:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
#

Last edited by amboxer21; 05-13-2012 at 11:06 PM.
 
Old 05-15-2012, 10:05 PM   #4
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,277

Rep: Reputation: 166Reputation: 166
What does the following return?

Code:
$ cat /var/lib/NetworkManager/NetworkManager.state
Good luck. ;-)
 
Old 05-21-2012, 06:21 PM   #5
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Linux Mint
Posts: 263

Original Poster
Rep: Reputation: Disabled
The requested output of

cat /var/lib/NetworkManager/NetworkManager.state
Code:
/NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true
Ive tried:
Code:
cd /tmp && wget -O linux-headers-3.3.0-030300_3.3.0_all.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/linux-headers-3.3.0-030300_3.3.0-030300.201203182135_all.deb

sudo dpkg -i linux-headers-3.3.0-030300_3.3.0_all.deb

cd /tmp && wget -O  linux-headers-3.3.0-generic_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/linux-headers-3.3.0-030300-generic_3.3.0-030300.201203182135_i386.deb

sudo dpkg -i linux-headers-3.3.0-generic_i386.deb

cd /tmp && wget -O linux-image-3.3.0-generic_i386.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-precise/linux-image-3.3.0-030300-generic_3.3.0-030300.201203182135_i386.deb

sudo dpkg -i linux-image-3.3.0-generic_i386.deb

reboot
__________________________________________________________________

AND:
Code:
cd /lib/firmware/rtl_nic/
sudo cp rtl8168e-1.fw rtl8168f-1.fw
sudo cp rtl8168e-2.fw rtl8168f-2.fw
sudo update-initramfs -u -k `uname -r`
reboot
__________________________________________________________________

I downloaded the relevant package here -> http://linuxwireless.org/en/users/Download/stable/
Code:
cd Documents/
tar -xf compat-wireless-2.6.30.tar.bz2
cd compat-wireless-2.6.30
make
sudo make install
__________________________________________________________________

AS WELL AS:
Code:
Ive downloaded all relevant packages in synaptic -> 
linux-backports-modules-
__________________________________________________________________

I opened up the bottom of my computer and removed my wireless adapter wires then checked

rfkill list all and received:
Code:
root@amboxer21:~$ rfkill list all
0: hp-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: hp-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
root@amboxer21:~$
THEN, removed the adapter from my PCI-x slot all together and still received
Code:
annonymous@annonymous:~$ rfkill list all
0: hp-wifi: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: hp-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
Here is a photo of my wireless icon menu
wireless.png

If I click on the enable wireless option, It closes the menu. I reopen it and the option has no check next to it.

So, it doesnt matter if the adapter is in or not. Which I "assume" means that I am missing the wireless driver!?

I have 3 hard drives. I am reinstalling a fresh copy of Ubuntu 11.10 with a wired connection so the installation will download/install the proper wireless drivers, firmware, etc. Ill comb through the necessary files and see if I can find the difference and what is missing, blocked, wrong, etc.

I've even ran through the modprobe blacklist.conf

This is such a pain!!

Last edited by amboxer21; 05-21-2012 at 08:39 PM.
 
Old 05-21-2012, 08:24 PM   #6
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Linux Mint
Posts: 263

Original Poster
Rep: Reputation: Disabled
Even after the new installation, 3rd party sources enabled, with a wired connection... Still no wireless. WTF?
 
Old 05-21-2012, 09:23 PM   #7
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,277

Rep: Reputation: 166Reputation: 166
I went back and read the thread again.
1) At any point after the upgrades did you try toggling the wifi switch or keystoke combination to enable/disable the wifi?

2) Did you have a look at your bios options for wifi? I ask because one of the new drivers added is the ath3k module which is a bluetooth driver and some laptop models (my Dell Studio) have only one switch for both cards.

3) Do you have any wifi cards you can try other than this card, a usb card possibly?

Good luck. ;-)
 
Old 05-21-2012, 11:07 PM   #8
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Linux Mint
Posts: 263

Original Poster
Rep: Reputation: Disabled
I am so ****ing pissed right now!! I have tried everything. This has even carried over to the internal 250GIB Sata HDD with Windows 7. This happened before and I had to disconnect my linux hdd and factory reset my windows 7 hdd. Then re-install Ubuntu. I am beyond ****ing furious!! I'm moving to another distro! **** Ubuntu!

On top of it, my dumb *** ****ing android keeps auto correcting me and I'm going to smash it with a brick!!!!!!!!!!!

[sarcasm]What check the wifi toggle button? You mean the thing with the wifi icon on it? No, I never thought to check that. [/sarcasm] Sorry to be a jerk but I'm pretty mad and your asking a question that makes me feel dumb!! I of course checked the wifi toggle button bro. I'm not 12 or new to computers.

No other wifi cards or usb dongle.

I just updated my kernel to 3.3 from 3.2 after dist upgrade and it made my computer hang before the login screen. Just a purple screen. No password login UI.

I'm going to proceed with the steps I have specified then download arch Linux, or some debian variant. Screw this bro!

Last edited by amboxer21; 05-21-2012 at 11:28 PM.
 
Old 05-22-2012, 01:09 AM   #9
amboxer21
Member
 
Registered: Mar 2012
Location: New Jersey
Distribution: Linux Mint
Posts: 263

Original Poster
Rep: Reputation: Disabled
enabling the combo(wifi/bluetooth) did it. I did a factory reset, then enabled. I am sure you could just enable without a factory reset. I didn't think of that until after though. There has to be an easier more straight forward way! A Linux approach.

So, I assume the enabling of the combo toggle thingy installed or inserted the proper firmware/modules. It then carried over to Linux.

Last edited by amboxer21; 05-22-2012 at 01:10 AM.
 
Old 05-23-2012, 08:25 PM   #10
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,277

Rep: Reputation: 166Reputation: 166
Glad you got it sorted.

Good luck. ;-)
 
  


Reply

Tags
blocked, hard, module, soft, wifi


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Access secured WiFi with Debian Live (WiFi Interface not set up right?) Abscissa256 Linux - Networking 4 11-19-2011 12:39 PM
[SOLVED] WiFi Connection Failure on Intel Corporation WiFi Link 5100 physicsguru Linux - Wireless Networking 1 04-08-2011 06:41 PM
wifi works:how to connect to hotspot,with console?alternative to wifi-wiz assistant? frenchn00b Debian 7 10-30-2009 12:31 PM
HP Mini 110 (Linux) - Linux explicitly blocked from university wifi !!! eellis Linux - Wireless Networking 12 09-10-2009 01:46 PM
Mod recent blocked related question (netfilter). WHO IS BLOCKED CarLost Linux - Security 6 07-29-2008 03:53 PM


All times are GMT -5. The time now is 03:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration