LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-23-2005, 10:47 PM   #1
aquaboot
Member
 
Registered: May 2005
Location: Berkeley, CA.
Distribution: debain freebsd
Posts: 465

Rep: Reputation: 31
Why Run Level 2 by Default?


Hi All,

I've just installed Ubuntu 5.04. The default runlevel in /etc/inittab is runlevel 2. What is the difference between this and runlevel 5? I'm used to RL 5 being the x11 multiuser mode (like in Redhat FC 3). I ask this because after being logged into an X session, I come home and find out that the X server has stopped and I'm at a standard non-gui (RL 3 type) login prompt. What's this all about?

Thanks Much,

aquaboot
 
Old 08-23-2005, 11:14 PM   #2
linux=future
Member
 
Registered: Apr 2005
Distribution: Debian
Posts: 154

Rep: Reputation: 30
Ubuntu boots in runlevel 2, and on the first reboot it also installs additional packages then. Ubuntu will then go to runlevel 5 by default, and if it can't go to 5 for some reason it goes to 3.
 
Old 08-24-2005, 01:19 PM   #3
aquaboot
Member
 
Registered: May 2005
Location: Berkeley, CA.
Distribution: debain freebsd
Posts: 465

Original Poster
Rep: Reputation: 31
Thanks for the reply.

I have a very basic, default install and have not modified boot parameters. I've done probably 8 reboots since the initial install. /etc/inittab was set default at run level 2 and remained that way despite reboots until I manually changed it to 5 last night. Hmm...

-aquaboot
 
Old 08-24-2005, 01:57 PM   #4
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Debian and most of its derivatives use runlevel two for everything. To get back into the equivalent of runlevel 5, you would have to do as root
Code:
#/etc/init.d/gdm start (replace gdm with kdm if you use kdm)
To stop the xserver like runlevel 3, you would do something like
Code:
#/etc/init.d/gdm stop
There is a way to make sure that you always login to a gui. I think it involves using dpkg to reconfigure the xserver.
 
Old 08-24-2005, 07:50 PM   #5
aquaboot
Member
 
Registered: May 2005
Location: Berkeley, CA.
Distribution: debain freebsd
Posts: 465

Original Poster
Rep: Reputation: 31
thanks for the advise. I'll give it a try. :-)

-aquaboot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Run Level 3 webwolf70 Mandriva 5 01-17-2005 10:41 PM
Can I set the default printer on a user level? robinBones Linux - Software 3 12-02-2004 07:40 PM
Setting default run level blacktempest07 Linux - Newbie 2 03-03-2004 12:47 AM
Run level Joey.Dale Linux - General 4 06-18-2003 04:59 PM
run level isajera Linux - Software 2 06-22-2001 07:20 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration