LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-07-2010, 04:01 PM   #1
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Rep: Reputation: 0
Why is my desktop and icons huge?


I installed some security updates on my computer yesterday , and when it said to restart now or later. I choose to do this later. I was watching a movie and then half way through the computer shut down and then when it restarted the desktop, toolbar at the bottom and icons where all huge, and when you open applications and internet screens etc they are all way to big to fit within the screen. Please help. I need to know how to get the size of it all back to normal.
 
Old 10-07-2010, 04:13 PM   #2
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Kubuntu
Posts: 1,189

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
Maybe your resolution has been changed. Somewhere in screen menu, you should find proper option.
 
Old 10-07-2010, 04:45 PM   #3
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Monitor resolution settings don't work

ive tried changing resolution through preferences and the monitor setting. But it hasn't seemed to change anything. It can only be applied to auto. any other suggestions
 
Old 10-13-2010, 05:34 PM   #4
eSelix
Senior Member
 
Registered: Oct 2009
Location: Wroclaw, Poland
Distribution: Kubuntu
Posts: 1,189

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
Do you have installed current drivers for your video card? Can you output result of command "xrandr"?
 
Old 10-14-2010, 12:50 AM   #5
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Wink

im not entirley sure what that means. Im not sure about the video drivers. Im computer literate but not programmer literate.
 
Old 10-14-2010, 12:51 AM   #6
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Original Poster
Rep: Reputation: 0
I forgot to tell you that im running ubuntu/ gnome
 
Old 10-14-2010, 02:29 AM   #7
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,221

Rep: Reputation: 285Reputation: 285Reputation: 285
Quote:
Originally Posted by pixi View Post
im not entirley sure what that means. Im not sure about the video drivers. Im computer literate but not programmer literate.
Open a terminal (applications > accessories > terminal) and simply type xrandr and hit enter. Then post the output here in CODE tags so they will be easier to read. Or just post them if you can't figure out code tags here on the forums.
Here is a tutorial on using xrandr on Ubuntu:
https://wiki.ubuntu.com/X/Config/Resolution

Last edited by tommcd; 10-14-2010 at 02:30 AM.
 
Old 10-16-2010, 08:16 PM   #8
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Original Poster
Rep: Reputation: 0
No command 'xrander' found, did you mean:
Command 'xrandr' from package 'x11-xserver-utils' (main)
xrander: command not found
kingston@kingston-desktop:~$
 
Old 10-16-2010, 09:02 PM   #9
fbobraga
Member
 
Registered: Jul 2010
Location: São Paulo - Brasil
Distribution: Fedora 17 amd64 / Fedora 17 i686 LXDE (w e17)
Posts: 229

Rep: Reputation: 41
Quote:
Originally Posted by pixi View Post
No command 'xrander' found, did you mean:
Command 'xrandr' from package 'x11-xserver-utils' (main)
xrander: command not found
kingston@kingston-desktop:~$
without the "e" (it's only "xrandr").

Tip: on terminal, use the <TAB> key to complete commands, avoiding typo errors - try it: enter "xra" and hit <TAB>
 
Old 10-17-2010, 03:16 AM   #10
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Smile

how retarded am i lol. spelt correctly this time,

Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
640x480 50.0*
320x240 51.0
kingston@kingston-desktop:~$
 
Old 10-17-2010, 08:45 AM   #11
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,221

Rep: Reputation: 285Reputation: 285Reputation: 285
As eSelix, already asked in post #4 in this thread:
What video card do you have???
If you have nvidia or ati video card, have you installed the proper drivers???
What is the default resolution for your monitor??? And what resolution do you want to use???
Did you read that tutorial I linked to on using xrandr???

Write back with the requested info and hopefully we can find a solution here.
 
Old 10-17-2010, 04:01 PM   #12
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Original Poster
Rep: Reputation: 0
Smile

The video card is nvidia driver version 173.14.22

My brother installed ubuntu on my computer so im unsure if the proper drivers are installed.

The default resolution I think it is just on auto, i looked in the avidia x server settings and it is on auto the only other options are 640 x 480 and 320 x 240.

Im not sure what resolution i want or what it was before, just back the way it was before it did this. It was great before, now some windows when there open you try clicking on the x or some of the other things like file, etc and the window jumps round. Like when i use rhythembox i cannot select songs individually by clicking on them or selecting them to drag to my ipod as the window jumps around making really frustrating to try and use.

I did read the turtorial, some of it made sense.
 
Old 10-17-2010, 04:24 PM   #13
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
System -> Preferences -> Monitors. In the "Resolution" dropdown, select "1024x768". Click "Apply", and then click the option to "Save" if you get the 15s countdown. Now, you're all set!
 
Old 10-17-2010, 08:23 PM   #14
pixi
LQ Newbie
 
Registered: Oct 2010
Posts: 8

Original Poster
Rep: Reputation: 0
When i go to preferences> monitors it comes up with the follow message.

It appears that your graphics driver does not support the nessasary extensions to use this tool. Do you want to use your graphics driver vendors tool instead? YES/NO

Also if you choose yes or no the options only give me No option 640 x 480 (4:3) and 320x 240 (4:3) and YES option gives me Auto, 640x 480 and 320 x 240.
 
Old 10-18-2010, 12:23 AM   #15
vuelement
LQ Newbie
 
Registered: Oct 2010
Posts: 9

Rep: Reputation: 3
Hello Pixi! I need to ask you something. Are you using Ubuntu 10.10? Perhaps this may work for you. Try this:

Go to "Applications---Accessories--Terminal. Type in this:

sudo -s

Now enter your root password. this is your login password at startup: Hit "enter".

You are now on "root".

First back up a copy of your X-org Configuration file, like this:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

It seems you have a least recent generation NVidia Accelerated Graphics card GeForce FX series or above.

Now, if you are using a flat screen, try to get your monitor manual, read it carefully and look for where it's written the values of "HorizSync - (a figure is given e.g. 50-75)
"VertRefresh- (a figure is given e.g. 60-120).

Now, let us try this: Hit this command:

gksudo gedit /etc/X11/xorg.conf

This command opens up your X-org configuration file. You are now ready to edit your Screen configuration.

You'll see something like this:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg


So far so good. Now, in this section, you will find small details of what your monitor, screen and your graphics card are. Don't worry about that. You'll find something like this: The following is for the monitor section:

Section "Monitor"
Identifier "Configured Monitor"
Endsection

Now for the screen section:

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
Endsection

Here, we want to add some lines to the configuration. If your screen supports resolutions up to 1920x1200, the default depth is 24. If it doesn't appear, please add it as shown. Remember, when you add in your parameters, these are case sensitive! Write them as they are, like as shown above. Now, remember I asked you to get the values for your monitor, theHorizSync and the VertRefresh values. You'll add them using the guide I'll show you now. Also add the viewport as shown. Also, you depth and your desired screen resolution. Remember, do not remove what you find already configured for your screen. Faithfully add the extra values I've been referring to.

I'm sure you want to use 1280x1024. Good resolution choice, if you want. This one has a refresh rate of 60. But, follow the recommended screen resolution as suggested by your monitor manual(which can be downloaded from the internet).

Your monitor manual will suggest the recommended screen resolution and the refresh rate. Use the recommended screen resolution.

So, please put your desired screen resolution(or the recommended one from the manual) exactly as shown below(Oh, I also run an NVidia card with the same driver version "173"):

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30-83
VertRefresh 50-75
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

The above is my screen configuration. You may find something here similar to your configuration since you are an NVidia user as well. Now, add those extra values we talked about earlier, very carefully. Look at the spacing, Caps, Start and End Quotes. Follow exactly. Don't panic.

After doing that hit the "Save" button at the top of the Gedit window. Close it, and exit "root" by typing "exit".

Your login name will show. Type "exit" and you are out. Now , restart the computer.

Please tell me how it goes. I had this problem too and was solved this way. I'm more than happy to share this with you.

I use Ubuntu 9.04.

Thanks also to all of you guys who are helping out, "tommcd" and everyone. Much love.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] thunar toolbar buttons/icons are really huge ichundu Linux - Software 6 09-18-2011 09:34 PM
how to create and remove desktop icons or icons from shell scripts? kkpal Linux - Newbie 7 09-01-2008 10:04 AM
Huge icons in Konqueror stonehurstX11 Mandriva 1 05-28-2004 11:15 PM
Huge icons and no wireless slackware 9.0 jzneff Linux - Newbie 2 03-26-2004 08:01 PM
Huge icons, resolution messed up gralfus Linux - Newbie 1 02-29-2004 06:52 PM


All times are GMT -5. The time now is 02:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration