LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 10-13-2007, 06:16 AM   #1
JamboUK
Member
 
Registered: Apr 2003
Posts: 47

Rep: Reputation: 15
Question Weird Network Card(?) Problem


Hello.

Been happily using Ubuntu (and other dists previously) on a dual booting box with Win XP Pro for years.

Then a couple of weekends ago I try booting into my Ubuntu dist and found I had no internet connection initially and upon further investigation no no network connection at all (no light on my router).

So I restart machine and boot into Windows XP router light is on and machine is joined onto the network and internet is fine. Same hardware.... same network..............

I have tried a new install of Ubuntu..... problem still exists. I just can't understand what is stopping the network card from working all of sudden in my Ubuntu boot?!

I have not changed anything (and even if I had it is back to a clean install!!). Anyone have a similar problem?! Surely not IRQ conflicts? If so.... why now??

Your help much appreciated.
 
Old 10-13-2007, 07:34 AM   #2
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
I have a similar issue with my Sony Vaio. Been dual booting between XP and Linux for years without problems. Then one day a few months ago, was unable to get network connection in Linux. Did the usual troubleshooting, reconfiguring, reinstalling, but just could not get Linux to connect.
However, at some point, I did a cold boot into Linux and got network working. I still do not know why it only works when I cold boot into Linux. I suspect it's probably hardware related.
Sorry I can't be of more help.

Last edited by wildar; 10-13-2007 at 08:14 AM.
 
Old 10-13-2007, 07:36 AM   #3
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,805

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
One of the many ways Micro$oft displays their "corporate culture" to the world is to have a setting on some devices (I don't know specifically which) such that when windows shuts down, the device is locked. Boot another OS, and the device refuses to respond.

You should boot xp, go into the control panel, and search for internet hardware settings which may be locking the device until next windows boot.
 
Old 10-13-2007, 02:57 PM   #4
JamboUK
Member
 
Registered: Apr 2003
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bigrigdriver View Post
One of the many ways Micro$oft displays their "corporate culture" to the world is to have a setting on some devices (I don't know specifically which) such that when windows shuts down, the device is locked. Boot another OS, and the device refuses to respond.

You should boot xp, go into the control panel, and search for internet hardware settings which may be locking the device until next windows boot.

OK...yeah...it is something along these lines....although not pin pointed it yet. I have rolled back an automatic driver update for my network card from our friends at Microsoft in my Windows XP boot (yep that is right!!!).....

Rebooted back into Ubuntu.....the router light which is connected to this card then stays live (which it hasn't been doing once out of Windows) and boots into Linux no problems!!

The new driver appears to work OK in Windows XP but breaks the card for Ubuntu.... bizarre I know.... All I can think initially is that XP puts it into some kind of power save / shutdown state at XP shutdown....... and quite happily wakes it when rebooted back into XP.....

But it doesn't happen in Ubuntu... so rolling back this driver stops this happening at shutdown.... and bingo.... card works for both OS as before.

Last edited by JamboUK; 10-13-2007 at 03:01 PM.
 
Old 10-13-2007, 03:04 PM   #5
koen plessers
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Mint
Posts: 191

Rep: Reputation: 30
Hello everybody

Very strange indeed. What kind of networkcard do you use? Wireless? Wired?

Bye

Koen Plessers
 
Old 10-14-2007, 04:39 AM   #6
JamboUK
Member
 
Registered: Apr 2003
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by koen plessers View Post
Hello everybody

Very strange indeed. What kind of networkcard do you use? Wireless? Wired?

Bye

Koen Plessers
Wired.... Realtek RTL8139... although the Microsoft driver update mentioned earlier names it entirely differently (and different manufacturer).

Last edited by JamboUK; 10-14-2007 at 01:30 PM.
 
Old 10-14-2007, 11:21 AM   #7
wildar
Member
 
Registered: Jan 2007
Distribution: Mandriva 2008, Mandrake 2005, Ubuntu 8.04.1
Posts: 239

Rep: Reputation: 30
My laptop has a Realtek RTL8139/810x Family NIC. Confirmed the driver that was installed was dated 8/20/07. Rolled back the driver, date changed to 7/13/07. Did warm boot from XP to Linux, but eth0 would not start.
Switched back to XP and installed original driver that came with my laptop, driver dated 11/12/03.
Rebooted back to Linux and eth0 started up right away.
 
Old 10-14-2007, 01:31 PM   #8
JamboUK
Member
 
Registered: Apr 2003
Posts: 47

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by wildar View Post
My laptop has a Realtek RTL8139/810x Family NIC. Confirmed the driver that was installed was dated 8/20/07. Rolled back the driver, date changed to 7/13/07. Did warm boot from XP to Linux, but eth0 would not start.
Switched back to XP and installed original driver that came with my laptop, driver dated 11/12/03.
Rebooted back to Linux and eth0 started up right away.
Nice to know I am not alone..... and my sanity is intact.
 
Old 10-14-2007, 02:00 PM   #9
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
I have heard of these problems before. Windows can, and does do, strange things to some hardware. Sometimes it leaves it in an "unusual" configuration. Who knows why? (No, there's really no need to answer this, and it's probably not intentional (I hope), just laziness, and ms people making assumptions about how people use their hardware). When you do a "soft" reboot, the hardware remains in an unusual (soft) configuration (Eg. some registers or flags are set strangely), and it will not then work with linux.

For those of you that dual-boot: If you encounter problems with things that used to work with linux, and now suddenly do not (I've never had this happen with linux, but quite often when I used windows), you should boot to your boot loader (grub, lilo, whatever) from a completely dead computer. This means disconnecting it from its power supply (unplug from mains, or disconnect battery from laptop) for 30S or so. That way the hardware can reset itself to its defaults when the power is re-applied and all will be well.
 
Old 10-14-2007, 10:14 PM   #10
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
I've found that if you don't fully power down your system DHCP seems to use the last IP's rather than retrieving new ones. You may not have noticed unless you've inserted a router with NAT between you modem and the PC.
 
Old 10-14-2007, 10:44 PM   #11
wraithe
Member
 
Registered: Feb 2006
Location: australia
Distribution: Linux... :-)
Posts: 216
Blog Entries: 1

Rep: Reputation: 30
try unplugging and replugging card to start with, especially if its been assembled for some time...then i would use a clean boot each time to linux, common problems seem to be happening everywhere, but alas i have a friend who could only get online with linux, not with windoze, he was loving it but not his game mad son....rofl
 
Old 11-03-2007, 10:56 AM   #12
dresb
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Hello everybody,
I registered to this forum specifically to post the SOLUTION to this problem that also made me question my sanity. So other desperate Linux users that find this post through google (as I did) can save themselves some trouble.

Boot on windows.
Go to the device manager and get into "properties" for your network card.
In the "Advanced Options" tab select:

Wake-on-lan after shutdown | enable

Reboot into linux. Your network card should be working.

Last edited by dresb; 11-03-2007 at 11:14 AM.
 
Old 11-03-2007, 11:17 AM   #13
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
dresb,
Thanks for posting your solution, which is easier than mine!
Unfortunately, I do not have the hardware, or windows, to test it with, but I'm sure it'll help someone else.
And welcome to LQ!
 
Old 11-03-2007, 03:54 PM   #14
fragos
Senior Member
 
Registered: May 2004
Location: Fresno CA USA
Distribution: Ubuntu 10.10
Posts: 1,466

Rep: Reputation: 51
Quote:
Originally Posted by tredegar View Post
dresb,
Thanks for posting your solution, which is easier than mine!
Unfortunately, I do not have the hardware, or windows, to test it with, but I'm sure it'll help someone else.
And welcome to LQ!
Features like wake on LAN may also be configurable in your BIOS. It is on mine.
 
Old 11-12-2007, 05:16 AM   #15
v_golf
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Thumbs up Thank you dresb

Hi just registerd to drop this 'Thank you note' to dresb.

I was also about to question my sanity and could not figure out, what was causing this weird problem as it was intially working.

This was the first time I was looking into Linux but without internet connection it's pretty useless. Luckily found this post through google and this simple change in the windows device config solved the problem!

Thanks again for taking the time to post the SOLUTION.
Now I can really enjoy looking deeper into Linux capabilities :-)



Quote:
Originally Posted by dresb View Post
Hello everybody,
I registered to this forum specifically to post the SOLUTION to this problem that also made me question my sanity. So other desperate Linux users that find this post through google (as I did) can save themselves some trouble.

Boot on windows.
Go to the device manager and get into "properties" for your network card.
In the "Advanced Options" tab select:

Wake-on-lan after shutdown | enable

Reboot into linux. Your network card should be working.
 
  


Reply

Tags
solution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Card Weird Internet riskbling Ubuntu 3 10-13-2007 02:25 PM
Weird network card behavior on OpenBSD linuxpyro *BSD 9 08-04-2005 05:04 PM
Weird network problem rrwhite Ubuntu 2 07-07-2005 05:58 AM
Network card weird problem.... hkl8324 Linux - Networking 2 06-16-2005 05:08 AM
RH9 weird Network Card Problem ealex79 Linux - Networking 1 05-22-2003 08:39 PM


All times are GMT -5. The time now is 01:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration