LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 07-26-2008, 02:31 PM   #1
Toonses82
Member
 
Registered: Sep 2004
Location: Olympia, WA, USA
Distribution: Linux Mint 16 Cinnamon
Posts: 117

Rep: Reputation: 15
Cool Volume, Hotkeys, and Kubuntu 8.04


I installed Kubuntu 8.04 with KDE 4.0.3 on my Dell Inspiron E1505 laptop. A couple of the issues I'm facing are getting my hotkeys to work and to control volume.

My laptop has buttons on the front which are:
Mute
Volume -
Volume +
Play/Pause
Track -
Track +
Stop

None of them do anything right now. hotkey-setup is installed. This is supposed to auto-configure hotkeys, but obviously it hasn't worked. Is there a config file somewhere that I can edit to make them work?

Also, my volume is a bit screwy. KMix seems to work for controlling video and music playback volume, but system sounds (specifically startup) are always on full blast. The system "beep" is ridiculously loud and so is the intro tune when logging into my KDE desktop. How do I make these events obey the master volume setting in KMix?
 
Old 07-27-2008, 06:43 AM   #2
liaty
Member
 
Registered: Oct 2005
Distribution: openSuse 10.1
Posts: 129

Rep: Reputation: 15
On suse with kde 4 in system settings - keyboard & mouse is where to set the shortcuts.
Maybe the same in kubuntu.

same here with kmix.I think the trick is to select the correct master channel. right click on k mix in system tray select master channel I have chosen PCM which seems to work well but don't know what this is.
 
Old 07-27-2008, 01:15 PM   #3
Toonses82
Member
 
Registered: Sep 2004
Location: Olympia, WA, USA
Distribution: Linux Mint 16 Cinnamon
Posts: 117

Original Poster
Rep: Reputation: 15
Thumbs up

Thank you. Both suggestions worked.

I right-clicked KMix and clicked Select Master Channel. I then set it to Front. This seems to control all volume including event sounds.

I then mapped my volume buttons doing what you suggested. Everything works. The only problem I ran into was mapping play/stop/etc in Juk. It doesn't seem to remember my settings. I might just go with another music player.
 
Old 07-28-2008, 04:55 PM   #4
liaty
Member
 
Registered: Oct 2005
Distribution: openSuse 10.1
Posts: 129

Rep: Reputation: 15
Glad it worked, sorry no ideas on juk
 
Old 07-28-2008, 11:26 PM   #5
mpg187
LQ Newbie
 
Registered: Jul 2008
Distribution: (K)Ubuntu 8.04
Posts: 20
Blog Entries: 1

Rep: Reputation: 0
I am having problems in Kubuntu.

On my acer Aspire when I press the "Play/Pause" key (FN+home) in Gnome it works. In KDE when music is playng and I press it the music pauses, but when I press it again the music does not resume! In gnome is pauses and resumes...
 
Old 07-30-2008, 10:52 AM   #6
Toonses82
Member
 
Registered: Sep 2004
Location: Olympia, WA, USA
Distribution: Linux Mint 16 Cinnamon
Posts: 117

Original Poster
Rep: Reputation: 15
I'm not entirely sure how to solve it, but I will say I've had problems mapping keys in Juk. If you're using Juk, you might try another player.
 
Old 08-04-2008, 10:01 PM   #7
mpg187
LQ Newbie
 
Registered: Jul 2008
Distribution: (K)Ubuntu 8.04
Posts: 20
Blog Entries: 1

Rep: Reputation: 0
I use Rhythm box
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora LVM volume group & Physical Volume resize problem gabeyg Fedora 1 05-14-2008 12:26 PM
Volume Control: Intel 82801DB-ICH4 (Alsa mixer) won't save volume levels. cayspekko Linux - Newbie 2 01-31-2008 01:17 AM
Error message when launching volume control - no volume rm_-rf_windows Mandriva 9 06-26-2007 01:17 PM
Mac Volume Keys Don't Work in Kubuntu Edgy Eft bburgy Linux - Hardware 1 04-26-2007 08:30 AM
Gnome: make volume hotkeys alter PCM chanel instead of MASTER (ALSA) qwijibow Linux - General 1 11-13-2005 10:42 PM


All times are GMT -5. The time now is 05:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration