LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Volume, Hotkeys, and Kubuntu 8.04 (http://www.linuxquestions.org/questions/ubuntu-63/volume-hotkeys-and-kubuntu-8-04-a-658430/)

Toonses82 07-26-2008 02:31 PM

Volume, Hotkeys, and Kubuntu 8.04
 
I installed Kubuntu 8.04 with KDE 4.0.3 on my Dell Inspiron E1505 laptop. A couple of the issues I'm facing are getting my hotkeys to work and to control volume.

My laptop has buttons on the front which are:
Mute
Volume -
Volume +
Play/Pause
Track -
Track +
Stop

None of them do anything right now. hotkey-setup is installed. This is supposed to auto-configure hotkeys, but obviously it hasn't worked. Is there a config file somewhere that I can edit to make them work?

Also, my volume is a bit screwy. KMix seems to work for controlling video and music playback volume, but system sounds (specifically startup) are always on full blast. The system "beep" is ridiculously loud and so is the intro tune when logging into my KDE desktop. How do I make these events obey the master volume setting in KMix?

liaty 07-27-2008 06:43 AM

On suse with kde 4 in system settings - keyboard & mouse is where to set the shortcuts.
Maybe the same in kubuntu.

same here with kmix.I think the trick is to select the correct master channel. right click on k mix in system tray select master channel I have chosen PCM which seems to work well but don't know what this is.

Toonses82 07-27-2008 01:15 PM

Thank you. Both suggestions worked.

I right-clicked KMix and clicked Select Master Channel. I then set it to Front. This seems to control all volume including event sounds.

I then mapped my volume buttons doing what you suggested. Everything works. The only problem I ran into was mapping play/stop/etc in Juk. It doesn't seem to remember my settings. I might just go with another music player.

liaty 07-28-2008 04:55 PM

Glad it worked, sorry no ideas on juk

mpg187 07-28-2008 11:26 PM

I am having problems in Kubuntu.

On my acer Aspire when I press the "Play/Pause" key (FN+home) in Gnome it works. In KDE when music is playng and I press it the music pauses, but when I press it again the music does not resume! In gnome is pauses and resumes...

Toonses82 07-30-2008 10:52 AM

I'm not entirely sure how to solve it, but I will say I've had problems mapping keys in Juk. If you're using Juk, you might try another player.

mpg187 08-04-2008 10:01 PM

I use Rhythm box


All times are GMT -5. The time now is 09:49 AM.