LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   user not authorised to run x server (http://www.linuxquestions.org/questions/ubuntu-63/user-not-authorised-to-run-x-server-346431/)

alagenchev 07-25-2005 01:09 AM

user not authorised to run x server
 
Hello, I am trying Ubuntu on a dual boot Slack and Ubuntu machine. I had already installed ubuntu once before on this machine, but had to reinstall because I changed some of the hardware. I just installed it second time and now I am not able to startx as a normal user. The terminal tells me that the user does not have permissions to run xserver. root runs fine. I checked the startx permissions and they seem fine. what else do I need to check. Apparently this is a permissions problem, but I just don't know what else I need to change and give user permissions. Can anyone help?

edit: BTW this is the default user that I setup during install. I dont see why default user would be able to run x on one instgall and then not be able to on a second

codec 07-25-2005 03:32 AM

I don't know how to really solve that problem

When I sudo to other user, the xserver doesn't allow me to run gui programs. I usually change back to root and do that:

xhost local:username

However, I have to do that everytime and it's annoying, I would like to know if there are any good way to give xauthority permantly

danns 07-25-2005 08:49 AM

Re: user not authorised to run x server
 
Quote:

Originally posted by alagenchev
The terminal tells me that the user does not have permissions to run xserver. root runs fine. I checked the startx permissions and they seem fine. what else do I need to check. Apparently this is a permissions problem, but I just don't know what else I need to change and give user permissions. Can anyone help?
Just out of curiousity, here.

It seems you have disabled gdm and get right to a shell prompt instead of X when you start.

Are you able to log in as the user if you use gdm?

Logged in on the console try:

sudo /etc/init.d/gdm start

Will gdm start? Are you able to log in via gdm?

Have you tried looking at the /var/log/XFree????.log (forget the full name) for any other information?

alagenchev 07-25-2005 11:06 AM

no i have not disabled gdm, I used the failsafe terminal to get some more information for the error I am getting. That's how I was able to determine that it is a permissions problem. I am at work right now, but I will check the log as soon as I get home. Is startx binary or a script? Any other suggestions pls?

danns 07-25-2005 12:47 PM

Quote:

Originally posted by alagenchev
no i have not disabled gdm, I used the failsafe terminal to get some more information for the error I am getting. That's how I was able to determine that it is a permissions problem. I am at work right now, but I will check the log as soon as I get home. Is startx binary or a script? Any other suggestions pls?
Are you trying to run startx from a console while you have X already running via gdm? This may be the problem.

I only have Slackware machines over here right now so I cannot test this on Ubuntu, but if I have X up and then run startx from a console, I get the error that X is already running and if it is not I need to delete the /tmp/.X0.lock file.

If you are trying to run multiple X sessions then you must provide a different display. ( i.e.; X -display :1).

alagenchev 07-25-2005 09:30 PM

danns, I delete that file, I don't think that is the problem. I was aware of that. I tried running it through gdm, it did not work. I ran failsafe terminal and deleted that file, and then did startx. I get the user not authorized..... error at that point. I don't know what I else I can do now. I changed the startx permissions to 777, but still no result

danns 07-26-2005 02:19 PM

Quote:

Originally posted by alagenchev
danns, I delete that file, I don't think that is the problem. I was aware of that. I tried running it through gdm, it did not work. I ran failsafe terminal and deleted that file, and then did startx. I get the user not authorized..... error at that point. I don't know what I else I can do now. I changed the startx permissions to 777, but still no result

Ok, I just tested this and got the same results you did. You cannot run startx as normal user when X is already running via the failsafe terminal you are in.

You still have X running even if you are using Failsafe terminal. You need to stop X before you can run startx as a normal user. This means you need to stop gdm:


sudo /etc/init.d/gdm stop

This will drop you out of X to the console with a log in prompt. Log in with your account and then try running startx.

Take note that if you are expecting something like slackware here where you log in to the console and then type startx to start X (you not running a graphial login in slackware) Ubuntu is not set up like this at all. Slackware runs gdm (or is it kdm or xdm) in run levels 4 and 5 I beileve. Run level 3 is the default which is console login.

Ubuntu has gdm set for run levels 2 through 5 with 2 being the default. If you want to boot in what is slackware's run level 3 you need to remove the gdm entery in /etc/rc2.d/S13gdm. Take note that this file is a link to /etc/init.d/gdm so do not delete the file in /etc/init.d.


alagenchev 07-26-2005 03:33 PM

thank you danns, yes I was expecting something similar to slack.

I am at work right now and have not tested all that yet. But I am still wondering why would X give me a black screen when I log in using gdm. That was the main reason why I tried running in failsafe mode. I will try what you are suggesting and hopefuly this way I could get some error messages that will help sort things out. Thank you for sticking with me.

danns 07-26-2005 03:35 PM

Hey, no problem. Hope you get that figured out quickly!


All times are GMT -5. The time now is 06:55 PM.