LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-25-2008, 05:29 PM   #1
retrovertigo
Member
 
Registered: Jul 2007
Distribution: Arch Linux
Posts: 36

Rep: Reputation: 15
[SOLVED] usb drive: resized partition using gparted, now it won't automount


I had been using my USB stick for some time, and Ubuntu has always automatically mounted the drive and even opened up a Nautilus window for it.

Then I decided to try to make a bootable "distro-on-a-stick", so I used GParted to resize the single partition that was already on the USB drive and add others in the newly-freed space. After miserably failing at getting a bootable OS on the stick, I went back to GParted and removed the extra partitions that I had created, and expanded the original partition to span the entire stick.

Now when I insert the stick, it does not automount. Nautilus still contains a reference to the USB stick in its "Places" pane on the left, and when I click that it will mount the partition on the USB stick. However, I think the automount is still hosed, and that the reference to the USB stick in Nautilus is likely just something that Nautilus has cached. The device name is still the same as before, so it's not out of the question that Nautilus just remembers the USB stick by its previous device name.

I've done some searching, and found that automounting in Gnome is mediated by gnome-volume-manager. I've checked and this is running, but it's still not automounting. Where do I go from here to troubleshoot this?

Last edited by retrovertigo; 08-27-2008 at 08:58 AM. Reason: added "[SOLVED]" to the thread title
 
Old 08-25-2008, 05:32 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,297

Rep: Reputation: 205Reputation: 205Reputation: 205
Quote:
Originally Posted by retrovertigo View Post
...Nautilus still contains a reference to the USB stick in its "Places" pane on the left, and when I click that it will mount the partition on the USB stick.
When the stick is mounted, try right clicking it and going to properties. You may have the option to set automount there.
 
Old 08-25-2008, 05:41 PM   #3
retrovertigo
Member
 
Registered: Jul 2007
Distribution: Arch Linux
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by {BBI}Nexus{BBI} View Post
When the stick is mounted, try right clicking it and going to properties. You may have the option to set automount there.
Right-clicking the "Places" entry only lets me unmount, open, or open in new window. I navigated to the mount point for the USB stick and right clicked in the Nautilus window and selected "Properties", but found no option to automatically mount it.
 
Old 08-27-2008, 08:55 AM   #4
retrovertigo
Member
 
Registered: Jul 2007
Distribution: Arch Linux
Posts: 36

Original Poster
Rep: Reputation: 15
I don't know why this didn't turn up in my google searches, but I went to GParted's homepage and found the following in their FAQ:


Quote:
8 : Why has Gnome automounting of devices stopped working after gparted terminated abnormally?
GParted version 0.3.6 (and many earlier versions) created a file to prevent problems that occur if a device is automounted while gparted is working on the device. This file is removed when GParted exits normally. However, if GParted crashed it could leave this file on the computer.

Newer GParted versions (0.3.7 and greater) do not use this file, and instead rely on hal-lock to acquire device locks.

To fix the problem you can do one of the following:

1. Remove the file /usr/share/hal/fdi/policy/gparted-disable-automount.fdi
or,
2. Start and then exit gparted. This will also remove the file.

I did remember GParted exiting abnormally when I tried starting it for the first time. According to apt, the currently installed version of GParted was indeed <=0.3.6 (it's 0.3.5). I checked and there was no such file in /usr/share/hal/fdi/policy. However, I ran gksudo gparted and then closed GParted, and automount works again.

So, in short, RTFFAQ.


If one of the mods sees this, can you change the title of the thread to include [solved] at the beginning, to help people in the future who are googling for a solution to this problem?

Last edited by retrovertigo; 08-27-2008 at 08:56 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Drive Does Not Automount (GNOME) carlosinfl Debian 12 02-12-2009 09:21 PM
USB drive won't automount linuxhippy Slackware 25 11-24-2007 10:52 AM
USB Flash Drive will not automount drlinux VectorLinux 6 04-19-2007 04:47 PM
automount of usb drive konramesh Linux - Hardware 1 12-02-2006 10:16 PM
Slightly OT : Restoring Drive Image to Resized Partition dlocalized Linux - Newbie 10 11-28-2003 02:36 PM


All times are GMT -5. The time now is 08:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration