LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 10-09-2005, 01:55 AM   #1
pazzport
Member
 
Registered: Dec 2004
Posts: 47

Rep: Reputation: 16
USB drive mount double mount issue


I'm running Ubuntu 5.1 (Breezy) with KDE and trying to mount a 200 GB USB external drive. The drive seems to mount twice, once as /dev/sdb which doesn't work and then as /dev/sdb1 which does work. Two icons appears on my KDE desktop. I'm kinda new and would appreciate the help. Thanks.

My fstab is:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0

My mtab is:

/dev/hda1 / ext3 rw,errors=remount-ro,commit=0 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0
tmpfs /lib/modules/2.6.12-9-386/volatile tmpfs rw 0 0
tmpfs /dev tmpfs rw,size=10M,mode=0755 0 0
/dev/sdb1 /media/sdb1 ntfs rw,noexec,nosuid,nodev,uid=1000,gid=1000,umask=077,iocharset=utf8 0 0
 
Old 10-09-2005, 03:15 AM   #2
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
/dev/sdb and /dev/sdb1 are devices, not mount points, although they can themselves be mounted.

/dev/sdb is the second detected SCSI drive, /dev/sdb1 is the first partition on the second detected SCSI drive (/dev/sdb2 would be the second partition, and so on).

The reason you can't mount /dev/sdb is that it is not a partition - it is your entire drive, partition table and all.

You probably have some sort of auto-mounter enabled, which would explain why you can see files when you click on /dev/sdb1 without having to type:

Code:
mount /dev/sdb1 /some/mount/point
in a terminal. According to your mtab, the mount point chosen by your auto-mounter is /media/sdb1, which would be a directory and not a device.
 
Old 10-10-2005, 04:26 PM   #3
pazzport
Member
 
Registered: Dec 2004
Posts: 47

Original Poster
Rep: Reputation: 16
OK - well then the question becomes, How do I get my automounter to quit trying to mount the device? Any ideas?
 
Old 10-10-2005, 09:28 PM   #4
zhangmaike
Member
 
Registered: Oct 2004
Distribution: Slackware
Posts: 376

Rep: Reputation: 31
The appearance of icons is probably just the devices being detected, not the devices being mounted... I would guess that they are not mounted until you try to view them (which would be when the auto-mounter kicks in)

If you wish to disable your auto-mounter, that would be somewhere in the Ubuntu documentation, though I do not know off-hand, as I do not use Ubuntu.

As it is, it doesn't seem to be doing any harm, but if the icons are truly annoying you, check the documentation for how to disable the auto-mounter... it may not even be the auto-mounter that causes the icons to display.

Last edited by zhangmaike; 10-10-2005 at 09:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount usb drive, umount and mount another drive arubin Linux - Hardware 9 01-17-2007 04:46 AM
Can't mount usb drive esanchez Linux - Hardware 9 10-10-2004 11:39 PM
USB drive - cannot mount Wynd Linux - Hardware 2 05-01-2004 07:58 PM
USB drive won't mount. Borg Swarm DamnSmallLinux 1 02-07-2004 10:25 AM
mount usb module then mount usb hard drive guanyu Linux - Hardware 1 10-08-2003 12:50 PM


All times are GMT -5. The time now is 06:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration