Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 06-11-2007, 08:41 PM   #1
Registered: Aug 2005
Location: New Zealand
Distribution: Kubuntu 6.06
Posts: 32

Rep: Reputation: 15
Upgrading KDE, now have broken packages

Tried to do an apt-get install kde earlier, on way to upgrading from 6.10 to Feisty 7.04, but Juk couldn't install because it needed a version of libgstreamer different to what I have, but it won't let me update it. Apt-get -f install gives me this:

dpkg: regarding .../libgstreamer0.10-0_0.10.12-0ubuntu2_amd64.deb containing libgstreamer0.10-0:
libgstreamer0.10-0 breaks libgstreamer-plugins-base0.10-0 (<< 0.10.11cvs20070110-0ubuntu5)
libgstreamer-plugins-base0.10-0 (version 0.10.10-1ubuntu1) is installed.
dpkg: error processing /var/cache/apt/archives/libgstreamer0.10-0_0.10.12-0ubuntu2_amd64.deb (--unpack):
installing libgstreamer0.10-0 would break libgstreamer-plugins-base0.10-0, and
deconfiguration is not permitted (--auto-deconfigure might help)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

How do I fix this? I can't uninstall juk without removing kde-multimedia and if I try to do that it wants to remove kde.
Old 06-11-2007, 08:50 PM   #2
Registered: Aug 2005
Location: New Zealand
Distribution: Kubuntu 6.06
Posts: 32

Original Poster
Rep: Reputation: 15
Um scratch that, for some reason installing it in synaptic seemed to fix everything... why couldn't apt-get do that?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading KDE packages docGonzo2000 Slackware 2 08-10-2007 03:33 AM
Broken packages hraposo Debian 2 08-13-2006 02:55 PM
Broken packages mcnearcj Ubuntu 3 08-01-2006 02:56 PM
Oops! Broken X and KDE after upgrading chriseebee Linux - General 0 06-10-2004 12:36 PM
Broken Packages Kujila Linux - Software 2 02-01-2004 06:07 PM

All times are GMT -5. The time now is 07:31 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration