UbuntuThis forum is for the discussion of Ubuntu Linux.
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
win32sux, Hold on, I will try your suggestion.
But, the link that you provided, takes me to a page, where I see a package to download the "IN DEVELOPMENT" Firefox Version 1.0.4-2.
Still, I will download it.
Last edited by duffmckagan; 06-09-2005 at 12:28 PM.
amit@ubuntu:~ $ sudo apt-get install mozilla-firefox
Reading Package Lists... Done
Building Dependency Tree... Done
mozilla-firefox is already the newest version.
You might want to run Ďapt-get -f installí to correct these:
The following packages have unmet dependencies:
ymessenger: Depends: libgdk-pixbuf2 (>= 0.13.0) but it is not going to be installed
Depends: libssl0.9.6 but it is not going to be installed
E: Unmet dependencies. Try Ďapt-get -f installí with no packages (or specify a solution).
Yeah, before that I tried to install ymessenger, exactly in the same way as told by yahoo, but got a similar message.
win32sux, I have downloaded the package you have mentioned already.
Should I go with it?
I can try both the methods.
But will that UPGRADE my Current Version of Firefox?
With installing the .deb package that I have downloaded as per win32sux's instructions, this is the result.
amit@ubuntu:~ $ sudo dpkg -i mozilla-firefox_1.0.4-2_i386.deb
(Reading database ... 61576 files and directories currently installed.)
Preparing to replace mozilla-firefox 1.0.4-2 (using mozilla-firefox_1.0.4-2_i386.deb) ...
Unpacking replacement mozilla-firefox ...
dpkg: dependency problems prevent configuration of mozilla-firefox:
mozilla-firefox depends on libc6 (>= 2.3.2.ds1-21); however:
Version of libc6 on system is 2.3.2.ds1-13ubuntu2.
mozilla-firefox depends on libfontconfig1 (>= 2.3.0); however:
Version of libfontconfig1 on system is 2.2.2-2ubuntu3.
mozilla-firefox depends on libglib2.0-0 (>= 2.6.0); however:
Version of libglib2.0-0 on system is 2.4.7-0ubuntu2.
mozilla-firefox depends on libgtk2.0-0 (>= 2.6.0); however:
Version of libgtk2.0-0 on system is 2.4.10-1ubuntu1.
mozilla-firefox depends on libpango1.0-0 (>= 1.8.1); however:
Version of libpango1.0-0 on system is 1.6.0b-0ubuntu1.
mozilla-firefox depends on libpng12-0 (>= 1.2.8rel); however:
Version of libpng12-0 on system is 22.214.171.124-7.
dpkg: error processing mozilla-firefox (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
okay the dependancies for the package aren't met by your current system... you'd need to add a repository to your sources file in which the proper version dependencies reside and then use "apt-get install mozilla-firefox" to download and install firefox along with the needed dependencies onto your system... i assume you should just add the sarge repository, as sarge includes firefox 1.0.4 AFAIK, but i'll let a debian person give you a better answer, as i don't have much experience with debian...