LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 11-30-2012, 07:50 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Rep: Reputation: 53
Unable to start desktop, low graphic mode


Hi all,

Host Ubuntu 12.04 desktop 64bit
VM Ubuntu 12.04 server 64bit
Virtualizer Oracle VirtualBox

I followed;
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 12.10)
http://www.howtoforge.com/virtual-us...l-ubuntu-12.10

installing the LAMP server on the VM running remote installation on the host terminal vis ssh. It worked without problem. After having finished "1 Preliminary Note" I took a break with the PC switched off.

After the break I started the PC and the server on the VM. Unfortunately I forgot to run;
$ ssh user@192.168.0.101
on the host terminal to login on the server.

Then I followed "2 Install Postfix, Courier, Saslauthd, MySQL, phpMyAdmin" installing;
Code:
$ sudo apt-get install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl phpmyadmin apache2 libapache2-mod-php5 php5 php5-mysql libpam-smbpass
installing those packages on the host terminal and finished up to "4 Create The MySQL Database For Postfix/Courier".

Then I realised having made this mistake installing those packages on the host. I started removing the installed packages on host terminal by;

1)
$ apt-get remove postfix
(no problem)

2)
$ sudo apt-get phpmyadmin apache2 libapache2-mod-php5 php5 php5-mysql
(also no problem)

3)
IIRC on running;
$ sudo apt-get openssl

I was NOT allowed to remove it, suggesting to run "autoremove"

On running;
$ sudo apt-get autoremove openssl
Suddenly I saw it starting removing GNOME packages.

I could not stop the action even with the terminal closed.

I switched to F3 (Text Mode) and rebooted PC. But I could not started the host, warning low graphic.

I think I could start rescue mode dropping to shell. Please help how to rescue this PC. There are about 20 VMs running on this box.

TIA

B.R.
satimis
 
Old 12-01-2012, 12:16 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,508

Rep: Reputation: 571Reputation: 571Reputation: 571Reputation: 571Reputation: 571Reputation: 571
Get the log, and find out what is/was uninstalled from the host. If disk space isn't a problem, it's not a disaster to have unwanted packages lying about. It is a disaster not to have wanted packages.

One quick bodge might be a global update - however you do that in ubuntu. That might catch missing dependencies for you. Then see what you have, and fix the host machine first.
 
Old 12-01-2012, 05:51 PM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,428

Original Poster
Rep: Reputation: 53
Quote:
Originally Posted by business_kid View Post
Get the log, and find out what is/was uninstalled from the host. If disk space isn't a problem, it's not a disaster to have unwanted packages lying about. It is a disaster not to have wanted packages.

One quick bodge might be a global update - however you do that in ubuntu. That might catch missing dependencies for you. Then see what you have, and fix the host machine first.
Hi,

Thanks for your advice.

I got it fixed with following steps.

1) booted the PC
2) dropped to Init-1
3) Ran;
$ sudo apt-get install --reinstall ubuntu-desktop
$ sudo reboot

Ubuntu desktop comes back.

Second time I encountered "low graphic mode" on running;
$ sudo apt-get remove libsasl2-2

It started deleting graphic packages. Promptly I rebooted PC. It booted to "low graphic mode" again. I have to re-install the desktop again.

It is quite strange not all following mistakenly installed packages can be removed
Code:
postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl phpmyadmin apache2 libapache2-mod-php5 php5 php5-mysql libpam-smbpass
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My CentOS Machine Does'nt Start in Graphic Mode.. pramodbisht Linux - Server 6 04-23-2012 08:37 AM
unable to switch frm console mode to desktop mode kapil Linux - Newbie 18 09-15-2011 12:55 AM
Linux not Start in graphic mode muhiuddin Linux - Newbie 3 11-07-2008 12:39 AM
Redhat Linux doesnot start in Graphic mode after booting doshi_montu Linux - Newbie 1 04-11-2004 12:54 AM


All times are GMT -5. The time now is 12:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration