LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 02-28-2007, 11:42 PM   #1
samjaynes
LQ Newbie
 
Registered: Feb 2007
Location: Utah
Distribution: Edgy Eft
Posts: 21

Rep: Reputation: 15
Unable to resolve 915GM resolution issue


I need your help and advice. I have googled, and read as much as I could before posting to this forum. As noted, I have the Dell Lattitude D610 (Ubuntu Edgy Eft) with the 915GM Video Card. I am limited to just 1024x768 resolution. Here are the steps I have done so far:

Installed 915resolution
sudo apt-get install 915resolution
sudo dpkg-reconfigure xserver-xorg
restarted xserver, but wouldn't come back from ctl-alt-f7, but ctl-alt-f1 went to a session.

Also, I have edited 915resolution MODE 30 to 1280 1024 32 (not being too picky at this point)
Changed the default to use mode 30 xres to 1280 yres to 1024 and bit to 32

Here is a some text from /etc/x11/xorg.conf:
Quote:
Section "Device"
Identifier "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics
Controller"
Driver "i810"
BusID "PCI:0:2:0"
Option "XAANoOffscreenPixmaps"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 915GM/GMS/910GML Express Graphics
Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

At this point, I am only allowed to select 1024X768 or 800X600 in System/Preferences/System Resolution... what am I missing?

Is their a repository that I am missing, driver, xorg stuff??? Any assistance would be helpful, I have seen quite a few threads both in Ubuntu forums, and other linux forums.
 
Old 03-01-2007, 03:39 AM   #2
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
The modes may be limited by your monitor configuration. Have you tried selecting the proper monitor as opposed to generic? If your monitor isn't in the selection list, you should at least pick a generic monitor that can handle 1280x1024. That mode should be supported by the 915G video by default.

Also, since this is a laptop, it is highly possible that you are limited to 1024x768 by the LCD.
 
Old 03-01-2007, 03:50 AM   #3
dlesaffre
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
I think you should at least have the "1280x1024" mode in your screens Modes lines.
And I am by no means an expert in X configuration, but you want 32 bit depth, but you don't have a 32-bit Display subsection. Maybe you should even adjust your DefaultDepth to 32. Or try everything with depth 24.
 
Old 03-01-2007, 03:52 AM   #4
gkiagia
Member
 
Registered: Oct 2003
Location: Greece
Distribution: Debian sid
Posts: 248

Rep: Reputation: 30
See /var/log/Xorg.0.log to see what's wrong and/or find the error messages in there and post them here.
 
Old 03-01-2007, 03:54 AM   #5
dlesaffre
LQ Newbie
 
Registered: Apr 2005
Posts: 16

Rep: Reputation: 0
Although targeted at Gentoo, a short HOWTO can be found at http://gentoo-wiki.org/HOWTO_Intel_O...ive_Resolution
 
Old 03-01-2007, 06:09 AM   #6
Rodcl
Member
 
Registered: Apr 2002
Location: Manchester, England
Distribution: Slackware 9.1
Posts: 113

Rep: Reputation: 15
@samjaynes

Most of the work has been done, now you just need to add one line of code and this issue will be sorted:

first edit the file bootmisc.sh:

Code:
$ sudo vi /etc/init.d/bootmisc.sh
Add the line 915resolution 3c 1280 800 after the line : [ -f /etc/default/rcS ] && . /etc/default/rcS (at approximatively line 10)
...
Code:
[ -f /etc/default/rcS ] && . /etc/default/rcS
915resolution 3c 1280 800
...

Evidently change the 1280 800 part to your desired resolution and where "3c" change it to your specified resolution. You can this find out by running in terminal the 915resolution hack and it should give you all available options:
Code:
sudo 915resolution -l

Just like everything else when it comes to tinkering back up everything worth backing up before attempting this. After the changes have been made, reboot.

This is part of a very useful guide from linux laptops: http://users.skynet.be/thomasvst/linux-on-laptop/

It was meant for a Vaio laptop but posses the very same chipset!

good luck

Last edited by Rodcl; 03-01-2007 at 06:19 AM.
 
Old 03-01-2007, 08:44 AM   #7
wabbalee
Member
 
Registered: Oct 2006
Location: brisbane - australia
Distribution: mepis, ubuntu, zenwalk
Posts: 334

Rep: Reputation: 38
have you added a line in your either gdm or kdm file located: /etc/init.d/kdm ? as a first line you must put something like 915resolution 38 1280 800 24.
otherwise the hack will not load. check this thread http://www.linuxquestions.org/questi...d.php?t=496953 and this one http://www.linuxquestions.org/questi...39#post2503939 for more info, i have had the same battle with my Acer TM2480. everything is fine now.
 
Old 03-01-2007, 05:10 PM   #8
samjaynes
LQ Newbie
 
Registered: Feb 2007
Location: Utah
Distribution: Edgy Eft
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by GrueMaster
The modes may be limited by your monitor configuration. Have you tried selecting the proper monitor as opposed to generic? If your monitor isn't in the selection list, you should at least pick a generic monitor that can handle 1280x1024. That mode should be supported by the 915G video by default.

Also, since this is a laptop, it is highly possible that you are limited to 1024x768 by the LCD.

Thank you for your response. I am unsure if the native resolution is 1024X768 (previously had XP), It very well could be on a 12.1" screen. However, I was hoping to force it to at least 1280X1024.

I know for a fact that an external 19" Dell LCD was able to produce 1280X1024 just fine when under the XP OS.

Thank you for your comments, as well as everyone else who has posted. I will make those modifications once I get back to the office.
 
Old 03-01-2007, 05:34 PM   #9
GrueMaster
Member
 
Registered: Aug 2005
Location: Oregon
Distribution: Kubuntu.
Posts: 848

Rep: Reputation: 30
External monitor should, but I'm not sure how you would get there without some serious tweaks to the xorg.conf file. I know my nvidia supports different resolutions on different monitors, but it is a desktop system. I haven't been able to do the same on my 945GM based laptop.
 
Old 03-01-2007, 08:36 PM   #10
samjaynes
LQ Newbie
 
Registered: Feb 2007
Location: Utah
Distribution: Edgy Eft
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by gkiagia
See /var/log/Xorg.0.log to see what's wrong and/or find the error messages in there and post them here.
Although it is confusing, I see:
Quote:
(II) I810: Driver for Intel Integrated Graphics Chipsets: i810, i810-dc100,
i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G, E7221 (i915),
915GM, 945G, 945GM, 965G, 965G, 965Q, 946GZ
(II) Primary Device is: PCI 00:02:0
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1) found
(--) Chipset 915GM found

Then this line every so many lines:
(WW) I810(0): Bad V_BIOS checksum

And then close to the bottom:
(WW) AIGLX: 3D driver claims to not support visual 0x23
(WW) AIGLX: 3D driver claims to not support visual 0x24
(WW) AIGLX: 3D driver claims to not support visual 0x25
(WW) AIGLX: 3D driver claims to not support visual 0x26
(WW) AIGLX: 3D driver claims to not support visual 0x27
(WW) AIGLX: 3D driver claims to not support visual 0x28
(WW) AIGLX: 3D driver claims to not support visual 0x29
(WW) AIGLX: 3D driver claims to not support visual 0x2a
(WW) AIGLX: 3D driver claims to not support visual 0x2b
(WW) AIGLX: 3D driver claims to not support visual 0x2c
(WW) AIGLX: 3D driver claims to not support visual 0x2d
(WW) AIGLX: 3D driver claims to not support visual 0x2e
(WW) AIGLX: 3D driver claims to not support visual 0x2f
(WW) AIGLX: 3D driver claims to not support visual 0x30
(WW) AIGLX: 3D driver claims to not support visual 0x31
(WW) AIGLX: 3D driver claims to not support visual 0x32
I wanted to respond to your post before I tried anything else.
 
Old 03-01-2007, 08:43 PM   #11
samjaynes
LQ Newbie
 
Registered: Feb 2007
Location: Utah
Distribution: Edgy Eft
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Rodcl

Add the line 915resolution 3c 1280 800 after the line : [ -f /etc/default/rcS ] && . /etc/default/rcS (at approximatively line 10)
...
Code:
[ -f /etc/default/rcS ] && . /etc/default/rcS
915resolution 3c 1280 800
...
I open this file, and could not see any code referring to the /etc directory. Everything began with /var... and no default directory either.
 
Old 03-06-2007, 04:40 PM   #12
johanw
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Rep: Reputation: 0
I hope I have the solution for you. If your LCD monitor is 17" or larger 1280x1024 should be supported at 60Hz.

I use Ubuntu edgy and have a 945GM card using the i810 driver.
915resolution need to be installed but you do not have to make any modifications its config file unless you want to use a wide screen resolution.

"sudo 915resolution -l" will give you the supported resolutions. If the one you want is in this list you do not need to alter any 915resolution files.

Here's what I did to get 1280x1024 enabled in Xorg.

What you will need to do is to create a modeline for the resolution you want to place in xorg.conf. To get a modeline you type this into a terminal "gtf 1280 1024 60 -x".

Edit /etc/X11/xorg.conf. At the end of the Section "Monitor" add Option "DDC" "false" and on a new line add the modeline that you got in the previous step, minus the -HSync and +Vsync. Like this:

Quote:
Section "Monitor"
Identifier "BenQ T705"
Option "DPMS"
HorizSync 30-65
VertRefresh 50-75
Option "DDC" "false"
Modeline "1280x1024" 108.0 1280 1328 1440 1688 1024 1025 1028 1066
EndSection
Note that gtf will give you a modeline that is called "1280x1024_60.00". This you will need to rename to "1280x1024" because it is not a valid name for xorg.

In the Section "Screen" set the DefaultDepth to 24 and you MIGHT need to add this line underneath the DefaultDepth: Option "MonitorLayout" "CRT" (I say "might" because I am not using a laptop but a DVI to VGA adapter to connect my LCD screen)

If "1280x1024" is not visible in the SubSection "Display" for 24 bit depth, add it before "1024x768"

Quote:
Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile Integrated Graphics Controller"
Monitor "BenQ T705"
DefaultDepth 24
Option "MonitorLayout" "CRT"
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection

SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
the device section should look similar to this:

Quote:
Section "Device"
Identifier "Intel Corporation Mobile Integrated Graphics Controller"
Driver "i810"
Option "XAANoOffscreenPixmaps"
BusID "PCI:0:2:0"
EndSection
I hope this have been helpful to you.
 
Old 03-07-2007, 01:49 PM   #13
samjaynes
LQ Newbie
 
Registered: Feb 2007
Location: Utah
Distribution: Edgy Eft
Posts: 21

Original Poster
Rep: Reputation: 15
Thank you for your response. I made the modifications to the xorg.conf file, and x-server failed to start. The error I saw was:

No Matching Device Section for Instance
Failed to start... 0:2:1

No Video BIOS Modes for chosen depth

Here is a section of the xorg.conf file I created:

Code:
Section "Device"
	Identifier	"Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
	Driver		"i810"
	BusID		"PCI:0:2:0"
        Option          "XAANoOffscreenPixmaps"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	Option		"DDC" "false"
	Modeline "1280x1024"  108.88  1280 1360 1496 1712  1024 1025 1028 1060
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280X1024" "1024x768"
	EndSubSection
EndSection
Any ideas what would cause x-server to fail with these configs? P.S. I tried running x-server reconfig by after accepting the defaults, and choosing resolutions, it failed also.

Here is the output of 915resolution -l
Code:
Chipset: 915GM
BIOS: TYPE 1
Mode Table Offset: $C0000 + $269
Mode Table Entries: 36

Mode 30 : 1280x1024, 32 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1440, 8 bits/pixel
Mode 41 : 1280x1024, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1920x1440, 16 bits/pixel
Mode 50 : 1280x1024, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1440, 32 bits/pixel
Mode 60 : 400x772, 8 bits/pixel
Mode 61 : 400x772, 16 bits/pixel
Mode 62 : 400x772, 32 bits/pixel
Mode 63 : 512x771, 8 bits/pixel
Mode 64 : 512x771, 16 bits/pixel
Mode 65 : 512x771, 32 bits/pixel
Mode 66 : 400x772, 8 bits/pixel
Mode 67 : 400x772, 16 bits/pixel
Mode 68 : 400x772, 32 bits/pixel
 
Old 03-07-2007, 04:47 PM   #14
johanw
LQ Newbie
 
Registered: Oct 2004
Posts: 8

Rep: Reputation: 0
Hello again,

First of all I see a typo in your xorg.conf. Modeline is called "1280x1024" but the corresponding mode in the screen section for 24 bit say "1280X1024" (note the capital X).
I recommend you to correct the typo and try again. If that does not help:

That error is a bit strange. Might be that BusID "PCI:0:2:0" in xorg.conf is wrong.

Let's see if you have more than one detected card. I would like to see the output of "sudo lspci | grep -i graph"

...and also I will need to see the full xorg.conf, not just parts of it. Do you have several cards/screens defined in there?
 
Old 03-07-2007, 05:56 PM   #15
samjaynes
LQ Newbie
 
Registered: Feb 2007
Location: Utah
Distribution: Edgy Eft
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by johanw
Hello again,

First of all I see a typo in your xorg.conf. Modeline is called "1280x1024" but the corresponding mode in the screen section for 24 bit say "1280X1024" (note the capital X).
I recommend you to correct the typo and try again. If that does not help:

That error is a bit strange. Might be that BusID "PCI:0:2:0" in xorg.conf is wrong.

Let's see if you have more than one detected card. I would like to see the output of "sudo lspci | grep -i graph"

...and also I will need to see the full xorg.conf, not just parts of it. Do you have several cards/screens defined in there?
Thanks for the quick response, and your willingness to work through this mess. I changed the X to a lower case, and it still failed (BTW, how do you get to a terminal screen from the blinking cursor [I have been rebooting in recovery to execute the CP command])

My entire xorg.conf file is:
Code:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/X11/fonts/misc"
	FontPath	"/usr/share/X11/fonts/cyrillic"
	FontPath	"/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/X11/fonts/Type1"
	FontPath	"/usr/share/X11/fonts/100dpi"
	FontPath	"/usr/share/X11/fonts/75dpi"
	FontPath	"/usr/share/fonts/X11/misc"
	# path to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load	"i2c"
	Load	"bitmap"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"type1"
	Load	"vbe"
        Load    "dbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
	Option		"XkbOptions"	"lv3:ralt_switch"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ExplorerPS/2"
	Option		"ZAxisMapping"		"4 5"
	Option		"Emulate3Buttons"	"true"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to 
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
	Identifier	"Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
	Driver		"i810"
	BusID		"PCI:0:2:0"
        Option          "XAANoOffscreenPixmaps"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	Option		"DDC" "false"
	Modeline "1280x1024"  108.88  1280 1360 1496 1712  1024 1025 1028 1060
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1024x768"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice     "stylus" "SendCoreEvents"
	InputDevice     "cursor" "SendCoreEvents"
	InputDevice     "eraser" "SendCoreEvents"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Section "Extensions"
        Option "Composite" "Enable"
EndSection
BUT, I think you may have something with the PCI. Here is the output of the lspci command:

Code:
sudo lspci | grep -1 graph
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
BTW, In the xorg.conf file, when x-server fails, I see some errors regarding the fonts (but not mission critical at this point)

I saw this on the Dell site:

Video

NOTE: Your Dell™ Latitude™ D610 computer has both integrated and discrete video options.

Video type:
integrated on system board, 128-bit hardware accelerated

Data bus
integrated video

Video controller
Intel Extreme Graphics

Video memory
Integrated video up to 128 MB of shared system memory.

NOTE: Up to 128 MB shared if total computer memory is 512 MB or greater; up to 64 MB shared if total computer memory is less than 512 MB

*** I assume I could add a RAM section to the Device area..

Last edited by samjaynes; 03-07-2007 at 10:11 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Resolution messed up Fedora Core 6 Intel 915GM linuxnewby34 Linux - Laptop and Netbook 10 12-26-2006 12:47 PM
Resolution problem fedora core 6 intel 915gm!!! linuxnewby34 Linux - Hardware 1 12-19-2006 01:49 AM
Suse 9.3 Dell D610 Intel 915GM Cannot change resolution vancew22 Linux - Laptop and Netbook 7 10-06-2005 08:36 AM
Unable to resolve hostname adirock2 Linux - Networking 14 07-06-2005 03:08 AM


All times are GMT -5. The time now is 05:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration