LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2008, 08:36 AM   #1
mainhoonteja
LQ Newbie
 
Registered: Jul 2008
Posts: 4

Rep: Reputation: 0
Question Unable to access drives


Hi I am an amature in Linux , I was using Windows untill i discovered about Ubuntu ...

My Windows is not working... and while i am trying to access any of my drives it doesn't allow me to access the drives... The Error message that i get is "UNABLE TO MOUNT THE VOLUME". And one of the solution is to Login to window are shutdown properly. and that is something i cant do... and them it asks me to forcefully mount the drive my typing a command line,,,, I tried doing that but there i get these silly messages

I tried a few command line such as

mount -t/ntfs-3g/dev/sda8/media/movies o-force

"Only root can do this" or "Permission denied"

Please help me

Thanks in advance

Last edited by mainhoonteja; 07-20-2008 at 08:39 AM.
 
Old 07-20-2008, 09:28 AM   #2
neilneil2000
LQ Newbie
 
Registered: Jun 2008
Distribution: Ubuntu Hardy Heron 8.04
Posts: 25

Rep: Reputation: 15
add the word "sudo" in front of your commands. This enables you to run commands with elevated privilages.

So effectively you will be "root"
 
Old 07-20-2008, 09:44 AM   #3
Sjonnie48
Member
 
Registered: Jun 2005
Location: Earth
Distribution: Ubuntu10.04
Posts: 308

Rep: Reputation: 43
You can also retain a root shell by using sudo -i. This saves you from having to type sudo anytime you want to do something that demands root rights.
 
Old 07-20-2008, 10:20 AM   #4
mainhoonteja
LQ Newbie
 
Registered: Jul 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by neilneil2000 View Post
add the word "sudo" in front of your commands. This enables you to run commands with elevated privilages.

So effectively you will be "root"
Thanks..for your prompt response.. i tried adding sudo in front of the commands and this is what it gives me


Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
One can change the type of mount containing the directory dir:
mount --make-shared dir
mount --make-slave dir
mount --make-private dir
mount --make-unbindable dir
One can change the type of all the mounts in a mount subtree
containing the directory dir:
mount --make-rshared dir
mount --make-rslave dir
mount --make-rprivate dir
mount --make-runbindable dir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

Last edited by mainhoonteja; 07-20-2008 at 10:42 AM.
 
Old 07-20-2008, 08:22 PM   #5
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Quote:
Originally Posted by mainhoonteja View Post
Hi I am an amature in Linux , I was using Windows untill i discovered about Ubuntu ...

My Windows is not working... and while i am trying to access any of my drives it doesn't allow me to access the drives...
Can you give us some more details? Did you install Ubuntu alongside Windows so you could dual boot both Windows and Ubuntu? If so is there an option to boot Windows in the grub menu when the computer boots up? Can you boot Windows at all?
Or when you installed Ubuntu did you select "autopartition" or "use entire disk" or whatever it says.

Post the output of "sudo fdisk -l". This will list your partitions on the drives.
Also post the output of "cat /etc/fstab". This will list you partitions, mount points, and file system types so we can know how to tell you how to mount your Windows partitions.

Last edited by tommcd; 07-20-2008 at 08:23 PM.
 
Old 07-24-2008, 12:53 PM   #6
mainhoonteja
LQ Newbie
 
Registered: Jul 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by tommcd View Post
Can you give us some more details? Did you install Ubuntu alongside Windows so you could dual boot both Windows and Ubuntu? If so is there an option to boot Windows in the grub menu when the computer boots up? Can you boot Windows at all?
Or when you installed Ubuntu did you select "autopartition" or "use entire disk" or whatever it says.

Post the output of "sudo fdisk -l". This will list your partitions on the drives.
Also post the output of "cat /etc/fstab". This will list you partitions, mount points, and file system types so we can know how to tell you how to mount your Windows partitions.

Hi Yes i did Install Ubuntu along side windows, and it does give me the option to boot windows in the grub menu, but then i am unable to use windows as my PC automatically restarts

and here are the details you requested

1 "sudo fdisk -l


Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xe3d1e3d1

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2550 20482843+ 7 HPFS/NTFS
/dev/sda2 2551 9729 57665317+ f W95 Ext'd (LBA)
/dev/sda5 2551 5100 20482843+ 7 HPFS/NTFS
/dev/sda6 5101 7650 20482843+ 7 HPFS/NTFS
/dev/sda7 9605 9729 1003999+ 82 Linux swap / Solaris
/dev/sda8 7651 9604 15695473+ 83 Linux

Partition table entries are not in disk order

Disk /dev/sdb: 81.9 GB, 81964302336 bytes
255 heads, 63 sectors/track, 9964 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xbdd4b0b6

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 9964 80035798+ 7 HPFS/NTFS

2 "cat /etc/fstab"

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda8
UUID=5aba64d1-b9ad-4a9a-b5b7-069717599c83 / ext2 relatime,errors=remount-ro 1 1
# /dev/sda7
UUID=ed6f03ef-dfd3-4cb3-8832-8fc946a164ac none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
 
Old 07-26-2008, 11:13 PM   #7
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
Your windows partitions are still there as indicated by all the HPFS/NTFS partitions in the output of fdisk. For some reason they are not listed in your fstab. If they were they would be mounted when Ubuntu boots up. You can fix this so you can mount your Windows partitions and access the data. You have some reading to do. See these pages:
For mounting Windows partitions:
https://help.ubuntu.com/community/Mo...dowsPartitions
For how to add partitions to fstab:
https://help.ubuntu.com/community/Fstab
And for using nrfs3g to get write access to Windows partitions:
https://help.ubuntu.com/community/Mo...irdPartyNTFS3G
Backup your fstab before you edit it like this
Code:
sudo cp /etc/fstab /etc/fstab.bak
That way you can easily resore fstab if you mess it up.
This is complicated by the fact that you have several Windows partitions on 2 hard drives. Try to mount one, like whichever one is used for data storage, then work on the others.
 
Old 07-27-2008, 08:52 AM   #8
tommcd
Senior Member
 
Registered: Jun 2006
Location: Philadelphia PA USA
Distribution: Lubuntu, Slackware
Posts: 2,230

Rep: Reputation: 287Reputation: 287Reputation: 287
For the quick and dirty way to mount your Windows partitions from the command line see this:
http://www.cyberciti.biz/faq/mountin...-ubuntu-linux/
Replace /dev/sdb1 with the NTFS partition you want to mount from the listing of your "sudo fdisk -l". This works for me, as I do not have my Windows partition in fstab either. The umask=022 will give read and executable permissions for everybody. To only give executable permissions to the owner and group (root, and root) use umask=027. This is a bit safer if you are worried about the security of having Windows executable files able to be executed by anyone.
Here is another good page for fstab from the Ubuntu wiki:
http://ubuntuforums.org/showthread.php?t=283131
 
  


Reply

Tags
help, pls


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to mount SATA drives on boot Rincewind2 Linux - Hardware 5 12-05-2007 11:56 AM
Unable to access Windows Drives!! crash_override_me Linux - General 14 03-24-2007 04:39 AM
unable to see ide drives under fedora 4 filfish Linux - Hardware 2 11-01-2005 05:06 PM
Unable to mount Cd-drives when not in root jginger Suse/Novell 4 11-15-2004 10:08 AM
Slackware 9.0 - unable to see fat-c/d drives evano Slackware 9 04-22-2003 11:07 AM


All times are GMT -5. The time now is 05:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration