LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 10-18-2011, 02:39 AM   #1
richard_wu0313
LQ Newbie
 
Registered: May 2011
Posts: 10

Rep: Reputation: 0
Ubuntu11.10 Network autoconfiguration failed


Hi There,
i used PXE to install ubuntu11.10 amd64, but i met error "Network autoconfiguration failed, your network is probably not using the DHCP protocol". and i checked /var/log/syslog, got possible error message. "dhclient no dhcpoffers received". However, the same way, same machine, same configure, i tried ubuntu 11.04, it's ok. so i doubted maybe some issue in "initrd.gz" and "linux" under folder install/netboot...

Any suggestion would be appreciated! thanks!
 
Old 10-18-2011, 02:44 AM   #2
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Well, it's got to be some subtle difference in the software suite from release to release ... Given the type of error, I'd guess that you're using a wireless network device?

Perhaps there is a different firmware for your device in the kernel on your 11.10?

Is the device ethernet or wireless?

What is the output of lsmod? (On both releases, if possible ... no biggie, though.)
 
Old 10-18-2011, 02:52 AM   #3
richard_wu0313
LQ Newbie
 
Registered: May 2011
Posts: 10

Original Poster
Rep: Reputation: 0
thanks for response! it's Ethernet.

output from ubuntu11.10: the same as ubuntu11.04
usb_storage, vga16fb, vgastate, usbhid, hid, e1000em tg3


// Perhaps there is a different firmware for your device in the kernel on your 11.10?
May i know what you mean for this sentence?


Richard
 
Old 10-18-2011, 03:01 AM   #4
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 609

Rep: Reputation: 218Reputation: 218Reputation: 218
Quote:
Originally Posted by richard_wu0313 View Post
// Perhaps there is a different firmware for your device in the kernel on your 11.10?
May i know what you mean for this sentence?
Yes. Some devices, like many wireless network devices, require a bit of code that they load into their chips in some way. It's called firmware, and the kernel has to be able to provide this to the device, usually while initializing it. This is in addition to any device driver functionality, which the kernel itself is fully responsible for.

I was thinking that, if you were using a wireless device, that the different kernels on the two different releases may have had different versions of the firmware for the device. This has happened to me (in FreeBSD, but still ...) so I figured I'd ask.

So, are you certain that the interface is coming up? The last bit of lsmod output there is odd ... It's an Intel card, then?

What is the output of ifconfig?
 
Old 10-18-2011, 03:16 AM   #5
richard_wu0313
LQ Newbie
 
Registered: May 2011
Posts: 10

Original Poster
Rep: Reputation: 0
Actually i was not sure whether eth0/1 was up. command "ifconfig" was not available in boot kernel then. My scenario was using PXE to boot up and then install ubuntu11.10 from pxe server, and client machine tried to download installation file to client machine and install, but met the network error. So there was limited tool in compressed kernel.
however, i checked file /etc/udev/rules.d/70-persistent-net.rules
tg3 is broadcom NIC, whose name is eth0
e1000e us intel NIC, whose name is eth1
and i plugged network connection to eth1 which support PXE.

Is there other command i can check whether ethx is up?
 
Old 10-18-2011, 03:24 AM   #6
hen770
Member
 
Registered: Oct 2010
Distribution: Arch
Posts: 136

Rep: Reputation: 7
Try to use the: ip link set ethX up .
I would disable the broadcom card in the bios the try to insatall.
 
Old 10-18-2011, 03:36 AM   #7
richard_wu0313
LQ Newbie
 
Registered: May 2011
Posts: 10

Original Poster
Rep: Reputation: 0
i used "ip link" to three link, one is "lo" state UNKNOWN, second is "eth0" state DOWN, third is "eth1" state DOWN.
After disabled onboard NIC, the auto configuration passed. Thanks a ton, you really help me out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Ubuntu11.04 andrewc54 Linux - Newbie 3 03-31-2011 03:43 AM
kernel ip autoconfiguration taan05 Linux - General 4 06-29-2009 07:39 AM
ipv6 autoconfiguration montrhano Linux - Networking 0 04-12-2007 04:35 AM
network autoconfiguration failed sevenfactorial Linux - Networking 5 06-28-2006 02:27 PM
Apache Autoconfiguration abhis_mail2002 Fedora 1 01-16-2006 03:44 AM


All times are GMT -5. The time now is 05:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration