Did you know LQ has a Linux Hardware Compatibility List?
Go Back > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Ubuntu This forum is for the discussion of Ubuntu Linux.


  Search this Thread
Old 06-21-2009, 02:39 AM   #1
LQ Newbie
Registered: Apr 2009
Location: virudhunagar,TN,India
Posts: 11

Rep: Reputation: 0
Red face Ubuntu-hardy-broken dependency

hi all,i have ubuntu-8.04LTS(hardy-herone) in my laptop.While i doing updating using manual installation from,I was needed to install libgd2-xpm and libgd-gd2-perl.So,my package manager instructed me to remove libgd2-noxpm package.I have entered into terminal
$aptitude remove libgd2-noxpm -f --purge
then it replied
packages to be removed
packages are unmet dependencies are
libgraphviz4 depends libgd2-noxpm is not installable
libgd2-xpm is not installable
packages are BROKEN
But after accept to remove that broken packages,it eventually shows "libmagick10,rssglx,ubuntu-desktop are broken" after consecutive remove commands to these packages.But none of these packages removed.Eventually i remember i read once not to remove ubuntu-desktop at any cost.I observed that package manager doesnt pass any broken dependency symbol in my desktop.I dont understand the situation.Can anybody pls explain how to remove libgd2-noxpm sothat i can install libgd2-xpm and explain this erotic situation technically
Thanks and regards
S.Suresh kumar


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 8.04 + wine 0.9.53 - resolving broken libldap2 dependency ErV Ubuntu 2 01-18-2009 11:52 AM
LXer: Installing Xen On An Ubuntu 8.04 (Hardy Heron) Server From The Ubuntu Repositor LXer Syndicated Linux News 0 05-08-2008 02:10 PM
GUI in Kubuntu Hardy broken after upgrade Spearhead40 Ubuntu 5 05-02-2008 04:20 PM
Hardy package upgrade libc6-686 broken Spearhead40 Ubuntu 2 04-05-2008 10:17 AM
Change in dependency of libxine1 and broken new package Ubuntu 5 11-29-2007 05:32 AM

All times are GMT -5. The time now is 04:42 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration