LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 09-17-2006, 11:29 AM   #1
Hotaru
LQ Newbie
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 6

Rep: Reputation: 0
Exclamation Ubuntu doesn't recognize my USB drive


As a note, I read the other threads and thus far none of their problems seem to be identical to mine. So I will elaborate.

I was using Ubuntu 5 and when I would plug in my external hard drive (USB 2.0) everything worked fine. It mounted automatically and I could use it as one would expect. I recently upgraded to 6.06 but I am having trouble that I cannot describe. Let me explain some symptoms.

FDISK:
Code:
jessica@jessica-laptop:/media$ fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   ?           1       19457   156288321    7  HPFS/NTFS
The top part is right, it's a 160GB drive, etc. The second part though seems to be giving me a pretty odd form of an error. I haven't ever seen this before and haven't found any threads with this problem.

Also, I used GParted to see what it thought about the situation.
It also recognizes a /dev/sda1 partition on the 160GB drive, but has an "!" next to sda1 and it doesn't give me any further information about the specific partition. In information, it basically just says that it can't read from it and "Did you install the correct plugin for this file system?"

So right now it seems that it recognizes the harddrive but not the partition. I haven't done anything to modify it, and it still works fine in windows XP, so I don't think this is a problem with the drive. I tried modifying my fstab and mounting it, but then I get this:

Code:
jessica@jessica-laptop:/etc$ sudo mount -a
mount: special device /dev/sda1 does not exist
 
Old 09-18-2006, 11:09 AM   #2
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
To me it looks like your drive uses the NTFS filesystem. You most likely don't have any filesystem drivers for NTFS installed. IIRC, you'll need to install "ntfsprogs" to fix this.
 
Old 09-18-2006, 12:35 PM   #3
imagineaxion
Member
 
Registered: Sep 2004
Location: Epsom, Surrey
Distribution: Ubuntu & Mac OS X
Posts: 141

Rep: Reputation: 16
It does seem like it is NTFS files system, i would suggest backing up the contents on a windows system and reformatting the drive to fat32 and copy the stuff back on.

This will be more hastle free and will work on a wider range of machines e.g. when you go to another work computer or friends computer that is using linux without the correct drivers.

You can of course install the NTFS drivers as mentioned to make your machine usable by a wider range of devices too, incase someone else brings over a usb drive with NTFS filesystem.
 
Old 09-18-2006, 01:27 PM   #4
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
DO NOT FORMAT FOR FAT32!!!

You have a 160GB drive. Fat32 cannot support a partition larger than 132 some odd GB.

My dad had a 160GB internal hard drive under Windows 98, and he couldn't use all of it because of that problem.

Keep it NTFS. Just install the NTFS drivers and you should be fine.

If you want to try something that MIGHT work (emphasis on the might part):

Install KwickDisk (my spelling may be incorrect on that). It mounts stuff that I find really hard to mount since I'm not that good at editing /etc/fstab by hand. It might work, it might not. I'm sorry I don't know of a Gnome equivalent, but there isn't a Kubuntu forum and so there are both Gnome and KDE users in this forum so I have to try and do my best to support both.

DO NOT FORMAT AS FAT32!!! Unless you want to have part of your drive unusable or have multiple partitions, both of which would be bad (IMHO).
 
Old 09-18-2006, 03:31 PM   #5
Hotaru
LQ Newbie
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 6

Original Poster
Rep: Reputation: 0
I really don't think the NTFS filesystem is the problem. Before posting, I had an internal drive with an NTFS partition and it works fine. Just in case, I installed some drivers for NTFS and they really made no difference. The guide offered by Ubuntu on ntfs-3g didn't make much difference and the ntfsprogs' ntfsmount gave the error:

Code:
jessica@jessica-laptop:~$ ntfsmount /dev/sda1 /media/sda1 -o fmask=0111,dmask=0
The device /dev/sda1 doesn't exist
Mount failed.
So I'm pretty confident even as a FAT32 I would be having this trouble. I just have no clue why. Should I go back to Ubuntu 5? I really don't know why the new version would do this, though.

Later I will look into KwickDisk or some equivalent. In fact I'm going to see what other mounting or diagnostic tools I can find that might at least offer some explanation. Thanks for the help so far.
 
Old 09-18-2006, 07:03 PM   #6
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
Tell me what this says:

Code:
cat /etc/fstab
I suspect your USB disk is not in FSTAB, or if it is, I suspect it's configured as VFAT (for USB Flash Memory keys like mine - little 128MB things).

If that is so, then I think I know how to fix your problem.
 
Old 09-18-2006, 10:39 PM   #7
Hotaru
LQ Newbie
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 6

Original Poster
Rep: Reputation: 0
I tried with it both in FSTAB and not in it. I took it out because one guide I read said that FSTAB is used for static hard drives, and mine is external and not always going to be plugged in. So in my case I would want to use a nautilus macro to mount it (for ntfs-3g support). In my case the mount fails that way, too. Let me add it in, try it, and cat it for you.

Code:
jessica@jessica-laptop:/etc$ sudo mount -a
mount: special device /dev/sda1 does not exist
jessica@jessica-laptop:/etc$ cat fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda5       /               ext2    defaults,errors=remount-ro 0       1
/dev/hda1       /media/hda1     vfat    defaults,utf8,umask=007,gid=46 0       1/dev/hda2       /media/hda2     ntfs    defaults,nls=utf8,umask=007,gid=46 0    1
/dev/hda3       /media/hda3     ntfs    defaults,nls=utf8,umask=007,gid=46 0    1
/dev/hdc        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/sda1       /media/sda1     ntfs    defaults,nls=utf8   0       0
jessica@jessica-laptop:/etc$
Also, take note that my first post I did a sudo mount -a... It wouldn't complain about sda1 unless it was in fstab. Let me know if there is something wrong with the way I entered it.

[Edit:] Just as a note, the last line for the /dev/sda1 was added by me during my attempt to fix the problem. So I manually entered that in. /dev/sda1 does NOT exist, but /dev/sda does. The error during mount that says sda1 does not exist is correct, but other applications seem to realize that I do have the 160GB drive connected (as shown above).

Code:
jessica@jessica-laptop:/dev$ ls sda*
sda

Last edited by Hotaru; 09-18-2006 at 11:09 PM.
 
Old 09-18-2006, 10:50 PM   #8
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
On my laptop, this is my line for my USB key:

Code:
/dev/sda1/     /mnt/sda1     vfat     noauto,async,user,exec 1000 1000
I found this:

http://gentoo-wiki.com/HOWTO_USB_Mass_Storage_Device

It's not exactly Ubuntu-specific, however, it does have some select commands that might help us narrow down what's going wrong.

Are you sure you're using sudo mount /dev/sda1, not just sudo mount /dev/sda?

On your fdisk -l you used /dev/sda, not /dev/sda1. That's why I ask.
 
Old 09-18-2006, 11:19 PM   #9
Hotaru
LQ Newbie
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by lordSaurontheGreat

Are you sure you're using sudo mount /dev/sda1, not just sudo mount /dev/sda?

On your fdisk -l you used /dev/sda, not /dev/sda1. That's why I ask.
Yeah definitely... I was using sudo mount -a... Which yeilds same result as sudo mount /dev/sda1

Anyway, as long as /dev/sda1 does not exist, it can't be mounted, which I realize now is my problem. In order to mount the drive at all it must exist in /dev/. At that point I have a macro for nautilus to mount the drive using ntfs-3g... but I can't get to that point.

FSTAB is really going to do the same thing as the macro, except for static drives. But really, either way... It's not working. I also checked up on my Ubuntu preferences and all of the options are set to automatically mount and read from the drive (which worked in the old version of Ubuntu).

I am at least learning a lot from this experience... Much more than if I gave up and reinstalled 5 (which I might still do). I'm going to keep studying this document you linked me to, but it seems drastically different than Ubuntu.
 
Old 09-19-2006, 10:55 AM   #10
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
Gentoo is a dramatically different experience from Ubuntu. Gentoo is closer to build-your-own distro than most other distros. For that I enjoy it greatly.

Just another idea...

I know that mount loves to complain at me if /mnt/sda1 does not exist. I'd check to see if that exists, since I've gotten several errors complaining that the mount point does not exist - all of which are fixed by a simple
Code:
lsauron@the-dark-tower $ sudo mkdir /mnt/sda1
I know this isn't helping all that much, but I'm learning as I go as well. I really hope you find a solution!
 
Old 09-19-2006, 02:51 PM   #11
Hotaru
LQ Newbie
 
Registered: Sep 2006
Distribution: Ubuntu 6.06
Posts: 6

Original Poster
Rep: Reputation: 0
mount checks for the mount directory to exist before it even checks if the device exists, so no... Or else it would give me that error.

And just FYI, I'm certain it does exist, anyway.

But anyway, I'd say if I don't figure this out by the end of the week or so I'll just to a clean install of the previous Ubuntu version. I'm really not that sad about it, really... I at least know for sure that'd fix my problem.
 
Old 09-19-2006, 10:01 PM   #12
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
Wait. Let me take my special tool to work...

http://www.google.com/linux

I hadn't actually thought to use it until just now. Yes, I am a absent-minded programmer and I'm proud of it you little end-user ; )

http://www.google.com/linux?hl=en&lr...tu&btnG=Search

Lots of good info there. I unfortunately don't have the time to sift through it all, but there has to be *something* there...
 
Old 09-20-2006, 01:57 PM   #13
lordSaurontheGreat
Member
 
Registered: Sep 2006
Distribution: Gentoo, SuSE 10
Posts: 94

Rep: Reputation: 15
This is something:

http://www.linuxquestions.org/questi...USB+Hard+Drive
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu/XP - Not able to recognize hard drive after installation sethis Linux - Hardware 3 08-28-2006 09:19 AM
ubuntu partitioning tool does not see external usb hard drive when installing ubuntu fakie_flip Linux - Software 2 07-30-2006 01:44 AM
Installer does not recognize USB external Hard Drive pktFishHooks Fedora - Installation 1 05-03-2005 10:52 AM
Fedora Core 3 installer does not recognize USB drive during installation Freedom Seeker Linux - General 1 04-21-2005 02:19 AM
How do you get Suse linux 9.0 to recognize a USB ZIP Drive Awwwesome Linux - Hardware 2 11-15-2004 04:28 PM


All times are GMT -5. The time now is 06:42 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration