LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-02-2013, 02:44 PM   #1
10eputzen
LQ Newbie
 
Registered: Aug 2013
Posts: 3

Rep: Reputation: Disabled
Question Ubuntu Clock keeps changing.


I'm having lots of trouble trying to figure out what is wrong with my Ubuntu clock.
I installed 13.04 on my server using VMWare (maybe it has something to do with that.)
After rebooting the system, the clock is always 2h ahead. After updating the ntp service, the clock sets itself back to the proper time, but after rebooting the system it is off again.
The timezone is set to CEST, but even the CEST is 2h off after a reboot. It feels like the system is applying the daylight saving time twice after the reboot.
Any ideas?
 
Old 08-02-2013, 02:52 PM   #2
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
What time does your BIOS think it is?

edit
meh, just noticed, is this the VMWare guest that has time issues?

Last edited by Firerat; 08-02-2013 at 02:53 PM.
 
Old 08-02-2013, 02:57 PM   #3
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
http://www.vmware.com/files/pdf/tech...alMachines.pdf
might shed some light
 
Old 08-02-2013, 03:03 PM   #4
10eputzen
LQ Newbie
 
Registered: Aug 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Yeah, it is the guest (using ESXI). Thanks for the pdf.

Last edited by 10eputzen; 08-02-2013 at 03:06 PM.
 
Old 08-02-2013, 03:11 PM   #5
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
Quote:
Originally Posted by 10eputzen View Post
Yeah, it is the guest (using ESXI). Thanks for the pdf.
Hope it helps, I only skimmed through it.. *lots* of words, but I did see it detail how to config a few settings
 
Old 08-03-2013, 02:11 PM   #6
10eputzen
LQ Newbie
 
Registered: Aug 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Hmm, I read through the pdf, but everything I tried there only helped until the next reboot
 
Old 08-03-2013, 02:24 PM   #7
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,411

Rep: Reputation: 794Reputation: 794Reputation: 794Reputation: 794Reputation: 794Reputation: 794Reputation: 794
This is a guess because I don't use VMWare (only VirtualBox) but do you have the guest set to think that "system time is UTC"? It occurs that the host OS might be passing on non-UTC time so you might want to change that?
Apologies if I'm barking up the wrong tree but I'd rather post and be wrong than hold back if it works.
 
Old 08-03-2013, 02:53 PM   #8
Firerat
Senior Member
 
Registered: Oct 2008
Distribution: Debian Jessie / sid
Posts: 1,471

Rep: Reputation: 444Reputation: 444Reputation: 444Reputation: 444Reputation: 444
I also don't use VmWare, it seems it deals with time differently

taken from page 22 of previously linked pdf

Quote:
Because guest operating systems generally get their time from the virtual CMOS TOD clock when they are powered on, you must set this device to your fictitious time if you want the time to persist across guest operating system restarts.

If you want to start a guest operating system with the same time on every startup, use the rtc.startTime option described in “Virtual CMOS RTC” on page 10.

If, instead, you want the guest operating system to have a constant offset from real time as maintained by the host, you can use the rtc.diffFromUTC option, or simply set the CMOS TOD clock from the virtual machine’s BIOS setup screen or from within the guest operating system.

In Microsoft Windows, setting the system time automatically updates the CMOS clock.

In Linux, you can use the /sbin/hwclock program to set the CMOS clock. Alternatively, because most Linux distributions are configured to copy the system time into the CMOS clock during system shutdown, you can simply set the system time and shut down the guest operating system before restarting it again.
all seems a bit confusing , but It looks like The VMWare guest has it's own BIOS settings.. It could be that it pulled local time from the host during initial setup, and due to some quirk it is now out of step


so a variation on post #2
What time does your VmWare Guest's BIOS think it is?

Last edited by Firerat; 08-03-2013 at 02:56 PM. Reason: cut'n'paste formating fail
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] System Clock Speed Changing bramankp Linux - Hardware 7 07-27-2011 07:38 AM
clock changing time greek45 Linux - Software 2 11-27-2009 07:47 AM
Changing time on clock on cent os 5 ? centosfan Linux - Distributions 1 11-02-2008 04:27 PM
the amazing, incredible, changing clock! BrianNJ Linux - Software 7 07-03-2006 10:17 PM
Changing the clock in CDE? as400 Solaris / OpenSolaris 109 04-24-2006 12:48 AM


All times are GMT -5. The time now is 03:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration