LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 10-12-2005, 08:42 PM   #1
rjcmi
LQ Newbie
 
Registered: Feb 2004
Location: Michigan
Distribution: Ubuntu
Posts: 21

Rep: Reputation: 15
Ubuntu Breezy No Sound on Audigy Sound Card


I just did an install of Ubuntu Breezy and am unable to get the sound to work on the computer.

System is the following
Amd 2000 XP
Soyo Dragon Plus MOBO
Soundblaster Audigy

Results of lspci command for the sound card are:
lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
0000:00:0c.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
0000:00:0c.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 03)
0000:00:0c.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port

I checked the master volume and it is at 100 percent.

I'm new to troubleshooting Linux problems so any help is appriciated. I am not sure which log files to check. The Alsa Mixer does start on boot.

I've had a Debian system and Ubuntu Horary and had no problems getting sound to work.

I also attempted to play a music cd, the drive mounts the cd normally and it gets the track informaion and appears to be playing it but I have no sound.

Any help is appriciated.
 
Old 10-13-2005, 01:24 AM   #2
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Seems to be an issue with the volume. Alsamixer is just a volume-control app and will not start on boot.

Apart from the Master Volume, there must be something called PCM, try increasing that volume
 
Old 10-13-2005, 02:28 AM   #3
Dommy
Member
 
Registered: Jul 2004
Location: Canberra
Distribution: Mint 7
Posts: 204

Rep: Reputation: 30
You might also look to see if your speakers are muted, I've had this trouble before and had to manually unmute the speakers also check the settings mentioned by akudewan in the previous post
 
Old 10-13-2005, 08:26 AM   #4
rjcmi
LQ Newbie
 
Registered: Feb 2004
Location: Michigan
Distribution: Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for the help. I tried changing the pcm volume in the alsamixer and checked to ensure the speakers were on and not muted manually. All appeared to be working correctly and the volume was set high.

Still scratching my head on this one.
 
Old 10-13-2005, 12:54 PM   #5
doublejoon
Member
 
Registered: Oct 2003
Location: King George, VA
Distribution: RHEL/CentOS/Scientific/Fedora, LinuxMint
Posts: 366

Rep: Reputation: 44
make sure headphone slider is not muted as well. This happened to me on my CentOS workstation. I had Master turned up
PCM turned up
Headphones (muted)

Unmuted Headphones......Walla!
 
Old 10-14-2005, 12:57 AM   #6
akudewan
Member
 
Registered: Apr 2004
Location: India
Distribution: Ubuntu
Posts: 364

Rep: Reputation: 30
Btw, which software are you using to play sound?
 
Old 10-14-2005, 11:25 AM   #7
kuriken
LQ Newbie
 
Registered: Aug 2005
Location: Finland
Distribution: Ubuntu 5.04
Posts: 1

Rep: Reputation: 0
I had the same sound card, same problem. I just solved it. It was kinda easy job this time for me, but that doesn't mean I didn't use a lot of time fighting against it.

Try to mute spdif output from alsamixer. This way I got my sound work. It looks like you have the same prob. Or if you have speakers that use spdif, unmute spdif channel.

Hope this helped And sorry for my bad english.
 
Old 10-14-2005, 02:37 PM   #8
rjcmi
LQ Newbie
 
Registered: Feb 2004
Location: Michigan
Distribution: Ubuntu
Posts: 21

Original Poster
Rep: Reputation: 15
Kuriken thanks for the post, you nailed it. Once I made that chage everything is working fine.

Thanks to all who took the time to help me.
 
Old 10-15-2005, 02:53 AM   #9
SgC.9711
Member
 
Registered: Oct 2005
Posts: 35

Rep: Reputation: 15
Quote:
Originally posted by kuriken
I had the same sound card, same problem. I just solved it. It was kinda easy job this time for me, but that doesn't mean I didn't use a lot of time fighting against it.

Try to mute spdif output from alsamixer. This way I got my sound work. It looks like you have the same prob. Or if you have speakers that use spdif, unmute spdif channel.

Hope this helped And sorry for my bad english.
Sorry, can you please explain what is "mute spdif output from alsamixer" I can run "aslamixer" from Terminal. But unable to find "spdif".

I am running Ubuntu Breezy Badger on Acer 1061 laptop. The rest of device detection was very good, including keyboard mapping of all the function and short keys. Hope your suggested solution will work on my laptop. Thanks.
 
Old 08-01-2006, 10:25 PM   #10
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
You helped me, too, Kuriken!

Quote:
Originally Posted by kuriken
I had the same sound card, same problem. I just solved it. It was kinda easy job this time for me, but that doesn't mean I didn't use a lot of time fighting against it.

Try to mute spdif output from alsamixer. This way I got my sound work. It looks like you have the same prob. Or if you have speakers that use spdif, unmute spdif channel.

Hope this helped And sorry for my bad english.
I was wondering if I'd ever get my Audigy card to work. Everywhere I looked I found the most complicated instructions involving stuff I didn't understand.

Then by luck (and Google) I found your post and figured out how to mute the spdif--and that didn't work. BUT I heard a faint click in both channels in my headphones, so I knew something was happening through the sound card.

I found settings in VLC (the player I use most often) and changed the output device to the sound card from the onboard chip, and I now have sound!

I can't thank you enough.

And your English is nothing to apologize for.
 
Old 08-09-2007, 03:37 PM   #11
bestbeach
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
Question totem works and vlc does not

I have no idea, but I have sound in totem and no sound in VLC.
How to fix it? I've tried to reinstall them also.

Last edited by bestbeach; 08-09-2007 at 03:43 PM.
 
Old 10-07-2007, 02:41 AM   #12
odoa2
LQ Newbie
 
Registered: Oct 2003
Location: Alaska
Distribution: Slack 9.1
Posts: 2

Rep: Reputation: 0
Quote:
Originally Posted by bestbeach View Post
I have no idea, but I have sound in totem and no sound in VLC.
How to fix it? I've tried to reinstall them also.
Under VLC, open pref>audio>alsa refresh list, select usb, then save.
 
Old 10-29-2007, 02:16 AM   #13
BoPRoX
LQ Newbie
 
Registered: Oct 2007
Posts: 1

Rep: Reputation: 0
If anyone would end up on this thread through a search and still has problems, in Ubuntu 7.10 I managed to get sound by muting Audigy Analog/Digital Output Jack in alsamixer.
 
Old 11-19-2007, 09:30 AM   #14
muncher
LQ Newbie
 
Registered: Apr 2007
Posts: 4

Rep: Reputation: 0
Hey guys, not sure if I have anything helpful to contribute, I have an audigy 2 ZS and i have installed 7.10 a couple of times in the last week, seems if i play a music video in vlc player(and have audio) then an mp3 in xmms it works if i do it the other way around i have to reconfigure the alsa plugin inside xmms (that even soubs wierd to me. I also have wierd stuff going on with alsa, if i run alsamixer in a console it says the audiocard is Intel ICH5, If i run gnome sound properties it says the audigy is the sound card the system is using, not sure whats going on there. Read a post in another forum that says to run (alsactl store) as root user to save your sound settings. Wierd stuff, got sound finally though.
Everytime i reboot the alsaplugin in xmms has selected a nerw device, even after i run alsactl store.

Cheers

muncher

Last edited by muncher; 11-23-2007 at 12:32 AM.
 
Old 03-10-2009, 11:19 PM   #15
Saltwaterfishiin
LQ Newbie
 
Registered: Mar 2009
Posts: 4

Rep: Reputation: 0
Audigy problems

Hi all,

I am new to linux and have Ubuntu on my computer. As many of you, I have no sound from my Creative Labs sound blaster (SB 0090). I've read the posts and can't seem to find how to mute the spdif output in Alsamixer. I've tried typing "alsamixer" into terminal and only get the Master sound. I've tried opening alsamixer (double clicking the speaker icon) and don't see anything that says spdif. Please send me instructions to saltwaterfishin@aol.com or post here. I'll try to find my way back to this forum.

Thanks a bunch,

Jay
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound coming from my sound blaster audigy 2 ZS platinum sound card msab Linux - Hardware 9 12-05-2010 05:10 AM
No Sound from Audigy card on 10.2 dbc001 Mandriva 6 09-28-2005 08:42 PM
Audigy sound card trackrat Mandriva 16 07-25-2004 12:38 AM
Can't get sound from Mandrake 9.1 with SoundBlaster Audigy 2 Sound Card... shortyzms Linux - Newbie 3 12-08-2003 05:36 PM
Sound Card Issues - Audigy johnny_575 Linux - Newbie 10 10-26-2003 04:07 PM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration