LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Ubuntu Breezy No Sound on Audigy Sound Card (http://www.linuxquestions.org/questions/ubuntu-63/ubuntu-breezy-no-sound-on-audigy-sound-card-372455/)

rjcmi 10-12-2005 08:42 PM

Ubuntu Breezy No Sound on Audigy Sound Card
 
I just did an install of Ubuntu Breezy and am unable to get the sound to work on the computer.

System is the following
Amd 2000 XP
Soyo Dragon Plus MOBO
Soundblaster Audigy

Results of lspci command for the sound card are:
lspci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
0000:00:0c.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
0000:00:0c.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 03)
0000:00:0c.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port

I checked the master volume and it is at 100 percent.

I'm new to troubleshooting Linux problems so any help is appriciated. I am not sure which log files to check. The Alsa Mixer does start on boot.

I've had a Debian system and Ubuntu Horary and had no problems getting sound to work.

I also attempted to play a music cd, the drive mounts the cd normally and it gets the track informaion and appears to be playing it but I have no sound.

Any help is appriciated.

akudewan 10-13-2005 01:24 AM

Seems to be an issue with the volume. Alsamixer is just a volume-control app and will not start on boot.

Apart from the Master Volume, there must be something called PCM, try increasing that volume

Dommy 10-13-2005 02:28 AM

You might also look to see if your speakers are muted, I've had this trouble before and had to manually unmute the speakers also check the settings mentioned by akudewan in the previous post

rjcmi 10-13-2005 08:26 AM

Thanks for the help. I tried changing the pcm volume in the alsamixer and checked to ensure the speakers were on and not muted manually. All appeared to be working correctly and the volume was set high.

Still scratching my head on this one.

doublejoon 10-13-2005 12:54 PM

make sure headphone slider is not muted as well. This happened to me on my CentOS workstation. I had Master turned up
PCM turned up
Headphones (muted)

Unmuted Headphones......Walla!

akudewan 10-14-2005 12:57 AM

Btw, which software are you using to play sound?

kuriken 10-14-2005 11:25 AM

I had the same sound card, same problem. I just solved it. It was kinda easy job this time for me, but that doesn't mean I didn't use a lot of time fighting against it.

Try to mute spdif output from alsamixer. This way I got my sound work. It looks like you have the same prob. Or if you have speakers that use spdif, unmute spdif channel.

Hope this helped :) And sorry for my bad english.

rjcmi 10-14-2005 02:37 PM

Kuriken thanks for the post, you nailed it. Once I made that chage everything is working fine.

Thanks to all who took the time to help me.

SgC.9711 10-15-2005 02:53 AM

Quote:

Originally posted by kuriken
I had the same sound card, same problem. I just solved it. It was kinda easy job this time for me, but that doesn't mean I didn't use a lot of time fighting against it.

Try to mute spdif output from alsamixer. This way I got my sound work. It looks like you have the same prob. Or if you have speakers that use spdif, unmute spdif channel.

Hope this helped :) And sorry for my bad english.

Sorry, can you please explain what is "mute spdif output from alsamixer" I can run "aslamixer" from Terminal. But unable to find "spdif".

I am running Ubuntu Breezy Badger on Acer 1061 laptop. The rest of device detection was very good, including keyboard mapping of all the function and short keys. Hope your suggested solution will work on my laptop. Thanks.

jonr 08-01-2006 10:25 PM

You helped me, too, Kuriken!
 
Quote:

Originally Posted by kuriken
I had the same sound card, same problem. I just solved it. It was kinda easy job this time for me, but that doesn't mean I didn't use a lot of time fighting against it.

Try to mute spdif output from alsamixer. This way I got my sound work. It looks like you have the same prob. Or if you have speakers that use spdif, unmute spdif channel.

Hope this helped :) And sorry for my bad english.

I was wondering if I'd ever get my Audigy card to work. Everywhere I looked I found the most complicated instructions involving stuff I didn't understand.

Then by luck (and Google) I found your post and figured out how to mute the spdif--and that didn't work. BUT I heard a faint click in both channels in my headphones, so I knew something was happening through the sound card.

I found settings in VLC (the player I use most often) and changed the output device to the sound card from the onboard chip, and I now have sound!

I can't thank you enough.

And your English is nothing to apologize for. :)

bestbeach 08-09-2007 03:37 PM

totem works and vlc does not
 
I have no idea, but I have sound in totem and no sound in VLC.
How to fix it? I've tried to reinstall them also.

odoa2 10-07-2007 02:41 AM

Quote:

Originally Posted by bestbeach (Post 2853772)
I have no idea, but I have sound in totem and no sound in VLC.
How to fix it? I've tried to reinstall them also.

Under VLC, open pref>audio>alsa refresh list, select usb, then save.

BoPRoX 10-29-2007 02:16 AM

If anyone would end up on this thread through a search and still has problems, in Ubuntu 7.10 I managed to get sound by muting Audigy Analog/Digital Output Jack in alsamixer. :)

muncher 11-19-2007 09:30 AM

Hey guys, not sure if I have anything helpful to contribute, I have an audigy 2 ZS and i have installed 7.10 a couple of times in the last week, seems if i play a music video in vlc player(and have audio) then an mp3 in xmms it works if i do it the other way around i have to reconfigure the alsa plugin inside xmms (that even soubs wierd to me. I also have wierd stuff going on with alsa, if i run alsamixer in a console it says the audiocard is Intel ICH5, If i run gnome sound properties it says the audigy is the sound card the system is using, not sure whats going on there. Read a post in another forum that says to run (alsactl store) as root user to save your sound settings. Wierd stuff, got sound finally though.
Everytime i reboot the alsaplugin in xmms has selected a nerw device, even after i run alsactl store.

Cheers

muncher

Saltwaterfishiin 03-10-2009 11:19 PM

Audigy problems
 
Hi all,

I am new to linux and have Ubuntu on my computer. As many of you, I have no sound from my Creative Labs sound blaster (SB 0090). I've read the posts and can't seem to find how to mute the spdif output in Alsamixer. I've tried typing "alsamixer" into terminal and only get the Master sound. I've tried opening alsamixer (double clicking the speaker icon) and don't see anything that says spdif. Please send me instructions to saltwaterfishin@aol.com or post here. I'll try to find my way back to this forum.

Thanks a bunch,

Jay


All times are GMT -5. The time now is 08:27 AM.