LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   ubuntu 7.10: "Visual Effects" -> no window decorations!? (http://www.linuxquestions.org/questions/ubuntu-63/ubuntu-7-10-visual-effects-no-window-decorations-593076/)

Thoddy 10-19-2007 02:16 PM

ubuntu 7.10: "Visual Effects" -> no window decorations!?
 
Hi,

today I upgraded to ubuntu 7.10 - nice system. But I have one issue, though: when I try to use 3d desktop settings (System->Preferences-Appearance -> Visual Setting), no matter whether I use normal or extra - I have no more window decorations!? The only working mode is none - which means no 3f desktop settings...

I tried to find some things in other forums, but the only thing I found is "look whether emerald is installed". It is!


Any idea, anyone?
Thanks!

mdg 10-19-2007 02:50 PM

Are you using the propriety 3D drivers? I think Ubuntu calls it Restricted drivers.

Thoddy 10-19-2007 03:21 PM

Quote:

Originally Posted by mdg (Post 2929952)
Are you using the propriety 3D drivers? I think Ubuntu calls it Restricted drivers.

Yes, the restricted nvidia drivers that come with ubuntu!

syg00 10-19-2007 06:03 PM

Install “compiz-configuration-settings-manager” via synaptic

SilentSam 10-19-2007 06:41 PM

That happened to me in Feisty with Beryl. You had to make sure that Beryl (or in your case Compiz-Fusion) is calling up the correct window manager for decorations.

For KDE:
Kwin or Emerald

Gnome:
Metacity or Emerald

Emerald decorations are more compatible for Beryl/Compiz

Thoddy 10-20-2007 05:31 AM

Quote:

Originally Posted by SilentSam (Post 2930156)
That happened to me in Feisty with Beryl. You had to make sure that Beryl (or in your case Compiz-Fusion) is calling up the correct window manager for decorations.

For KDE:
Kwin or Emerald

Gnome:
Metacity or Emerald

Emerald decorations are more compatible for Beryl/Compiz


OK - how do I do that??
I have "compizconfig-session-manager" installed and now I also have the "Emerald Theme Manager" in my Preferences menu. I can select themes there. And I finally have another option in the "Visual Effects" menu, the "custom", in whihc there is a preferences button - I can set loads of options there, but I didn't find any option "select window manager" or anything like that... ?

jay73 10-20-2007 06:12 AM

This sure looks very messy. I didn't have a clue where to start looking when Compiz crashed (don't install Celestia!). A million options but just not the one you are looking for.

Thoddy 10-20-2007 06:23 AM

Quote:

Originally Posted by jay73 (Post 2930511)
This sure looks very messy. I didn't have a clue where to start looking when Compiz crashed (don't install Celestia!). A million options but just not the one you are looking for.

Celestia isn't installed!

Anyway - it's a "real-time space simulation", how could that affect the window manager? :)

stealth_banana 10-20-2007 06:30 AM

quick command line, try

compiz --replace && emerald --replace

In kubuntu the method is really bad, I ended up writing a script in ruby to do it all.

jay73 10-20-2007 07:01 AM

No, let me be clear, I wasn't suggesting that you have Celestia installed. And I didn't say that your computer was "messy" - I only meant that Compiz on Ubuntu 7.10 is very confusing and poorly documented. What I also meant was: be very careful if some day you want to install Celestia. It crashed my desktop not once, not twice but three times. First the desktop icons disappear and if you then log out - BAM! Black screen if you log back in : S By the way, Celestia is know to clash with Compiz - I just didn't expect it could become that bad. But well, that's on a side note. Has nothing to do with your question, in fact. Hmm, I'm making myself very useful here : S

Thoddy 10-20-2007 08:06 AM

Quote:

Originally Posted by stealth_banana (Post 2930524)
quick command line, try

compiz --replace && emerald --replace


Nope!

Same problem: all effects work, but no window decorations... :(

Thoddy 10-20-2007 08:31 AM

OK, I found the / or at least a possible solution:

https://bugs.launchpad.net/ubuntu/+bug/154596

I installed aserver-xgl - now it works! Strange it is installed by default!? Bu anyway...

jakewine 10-23-2007 11:38 PM

Quote:

Originally Posted by Thoddy (Post 2930597)
OK, I found the / or at least a possible solution:



I installed aserver-xgl - now it works! Strange it is installed by default!? Bu anyway...

BE CAREFULL!!!!!! I just installed xserver-xlg attempting to fix this problem and it wrecked my video. No desktop icons, no top/bottom bars, nothing but a blank screen with a mouse pointer.
After removing the xserver-xgl, things still didn't work correctly, but i was able to get a basic screen going. I removed nvidia-glx and reinstalled it and then things started working normally again.

Finally, back to square one... enable visual effects and the window decorations disappear. I found a solution on another forum and thought I'd share. This worked for me.

make a backup
Quote:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
then edit
Quote:

sudo gedit /etc/X11/xorg.conf
Then add the following two lines to the "device" section:

Quote:

Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
log out and log back in and everything should be good.

Thoddy 10-24-2007 02:34 PM

Awesome! It works!!

...and it's way faster than the XGL desktop without any animations! ;) In fact, there is almost no difference in response time.


Thank you jakewine!! :)

Thoddy 10-24-2007 02:40 PM

Nope! It does not work! :(

At least: it works only until I use the "Application Switcher". Then the window decorations are suddenly gone!?

jakewine, could you test that, please??


All times are GMT -5. The time now is 12:32 PM.