LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Ubuntu 7.10 64bit - how to set java path to/redirect java to libjvm.so ? (http://www.linuxquestions.org/questions/ubuntu-63/ubuntu-7-10-64bit-how-to-set-java-path-to-redirect-java-to-libjvm-so-630445/)

Thane 03-25-2008 07:08 AM

Ubuntu 7.10 64bit - how to set java path to/redirect java to libjvm.so ?
 
Recently have not been able to get .jar files running. Repeatedly getting error msg, which indicates the problem is at the accessing of libjvm.so . After much searching have found a couple of references to setting a path to libjvm.so in the /etc/ld.so.conf file. I've checked and there's no reference to the libjvm in that file. But these people are running RedHat, running servers, etc. I don't know if I should be trying this on my machine and I really have no idea how to attempt it either. Somewhere I've gotten Java7 IcedTea jre on the machine (it shows up in Synaptic). The iced tea seems to be the problem, but the gutsy complains after I remove the IcedTea - seems locked into wanting it present. I used to use sunjava6. Is there a way to make it work by setting a path to the conf file or somehow else as these people have alluded? Thanks.

Thane 03-25-2008 06:52 PM

Found it. Couldn't get out of the repeated error command Child Process Failed every time I tried to run a .jar with IcedTea java uninstalled. Finally found the following command on a couple of discussions, which has redirected my SunJava6 to be the default java program. sudo update-java-alternatives –-set java-6-sun My .jar files are now loading fine.


All times are GMT -5. The time now is 12:15 AM.