LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Ubuntu 12.04 no GRUB interface at startup (http://www.linuxquestions.org/questions/ubuntu-63/ubuntu-12-04-no-grub-interface-at-startup-4175412879/)

KYJazzyJeff 06-22-2012 02:25 PM

Ubuntu 12.04 no GRUB interface at startup
 
Actually, I think it really is trying to display, but it seems that at the time when that's supposed to happen, my monitor gives me an 'Out of Range' error message and my computer boots into Ubuntu after a few seconds. Had this same problem with Fedora 17 some time ago, openSUSE's GRUB interface displays fine though.

towheedm 06-22-2012 09:43 PM

In the simplest case, GRUB will hide the menu if GRUB_HIDDEN_TIMEOUT is set in /etc/default/grub. To show the menu you must comment out this line and update GRUB's boot configuration file.

From a terminal, open the file with gedit as root:
Code:

gksudo gedit /etc/default/grub
Comment out the line:
Code:

#GRUB_HIDDEN_TIMEOUT=5
You may also set the timeout before the default menu entry is booted automatically, by uncommenting this line and changing the timeout value:
Code:

GRUB_TIMEOUT=30
Save the changes and update GRUB's configuration file:
Code:

sudo update-grub
As far as the 'Out of Range' error goes. This may br caused by GRUB trying to set the video mode to one that's unsupported by you card/monitor. You can simply check this by changing this line to:
Code:

GRUB_GFXMODE=1024x768
This set's the video mode to 1024x768 which as far as I know is supported by all VESA cards and monitors.

Save the changes and update GRUB's configuration file as shown above.

Reboot. At this point you should see GRUB's boot menu.

To check the modes that GRUB support for your card, do this.
  1. When the menu is shown press 'c' to go to GRUB's command-line. The GRUB prompt will be shown (grub> ).
  2. Enter this command:
    Code:

    set pager=on
  3. Check the modes supported with the vbeinfo command:
    Code:

    vbeinfo
Take a note of the displayed video modes. Note however, that your monitor may not support all of these modes. Select a mode supported by your monitor and set the GRUB_GFXMODE variable to this. Update GRUB's configuration file and your GRUB menu should be shown at the selected video mode.

Hope this helps.

KYJazzyJeff 06-23-2012 11:31 AM

Weird, the timeout AND graphics mode lines were commented and the timeout value somehow got set to zero. No matter, just uncommented the graphics mode line, left the graphics mode at it's original setting (640x480), uncommented the timeout line, set it to five, and that did the trick.

towheedm 06-23-2012 11:48 AM

If GRUB_GFXMODE is commented out, Ubuntu set's it to auto when generating the configuration file. In auto, GRUB selects the first working mode. Depending on the video card, this mode may not work. I have an nVidia FX5200 card, and when set to auto, GRUB selected the 640x400 mode, which resulted in a blank display.

BTW: Auto is also a valid setting for GRUB_GFXMODE. See:
Code:

info -f grub -n 'Simple configuration'
for additional settings.

arafatnazir 04-08-2013 08:54 PM

GRUB menu finally fixed!!!
 
Quote:

Originally Posted by KYJazzyJeff (Post 4710100)
Weird, the timeout AND graphics mode lines were commented and the timeout value somehow got set to zero. No matter, just uncommented the graphics mode line, left the graphics mode at it's original setting (640x480), uncommented the timeout line, set it to five, and that did the trick.

Thank you KYJazzyJeff....I was having the problem where it would show "out of range" instead of displaying the GRUB menu.After fighting with this problem for over a week..i finally fixed it with your help....i would have never realised the solution was so simple.. Great job bro

widget 04-09-2013 12:46 PM

You should mark this thread Solved. You will find it under Thread Tools at the top of the page here. Only the OP can do that.

People that use the forum search tools for this problem will appreciate it, particularly since this is a common problem.

EDIT
You should be able to see the grub menu when you boot when set to hide by hitting the Shift key when the screen menu should be visible. This is supposed to bring it up in case you need to boot recovery mode or an older kernel.

I prefer to see the menu all the time.

robt23 04-09-2013 01:08 PM

Thanks for this easy to understand explanation of the `out of range ` problem.

This stopped me from using all Ubuntu releases after 8.04 because of the change from GRUB to GRUB 2. Finally, I see light where before there was darkness.

Brilliant tutorial and Thank you so much.


All times are GMT -5. The time now is 11:20 PM.