LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 05-26-2012, 03:44 PM   #1
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Rep: Reputation: 7
Ubuntu 11.10 - problems with hibernation, resume from it


Hi.

I've got really anoying problem with hibernation - it doesen't work and i don't know why, because it worked before. Now only works suspend to disk, but not suspend/hibernation to a disk.

I will provide some infos:

Code:
AMD x4 955
Asus M4A77
nVidia GTX260 with 180.13 drivers.
Here are some outputs from terminal:

/etc/fstab:

Code:
firekage@deusex:~$ cat /etc/fstab | grep swap
UUID=114c98b3-c532-42af-a84c-cbd07e97e836    none    swap    sw    0  0
now what i have in /etc/initramfs-tools/conf.d/resume:


Code:
firekage@deusex:~$ cat /etc/initramfs-tools/conf.d/resume 
RESUME=UUID=114c98b3-c532-42af-a84c-cbd07e97e836
i have installed hibernate pack (installed trough terminal), so this is output from /etc/uswsusp.conf:


Code:
firekage@deusex:~$ cat /etc/uswsusp.conf
# /etc/uswsusp.conf( -- Configuration file for s2disk/s2both
resume device =/dev/disk/by-uuid/114c98b3-c532-42af-a84c-cbd07e97e836
splash = y
compress = y
early writeout = y
image size = 1942887383
RSA key file = /etc/uswsusp.key
shutdown method = platform


these are my partirions with UUID's:

Code:
/dev/zram0: UUID="ec1ba85a-3ab1-4500-b6cd-c99f053a7259" TYPE="swap" 
/dev/sda1: UUID="114c98b3-c532-42af-a84c-cbd07e97e836" TYPE="swap" 
/dev/sda2: UUID="0a2ebb07-8b93-4938-9bee-7eca19168eee" TYPE="ext4" 
/dev/sda5: LABEL="RAZIEL" UUID="3ADE0DB5DE0D6A89" TYPE="ntfs" 
/dev/sdb1: UUID="149ac71c-7444-48aa-bc0c-9fb07bccf74c" TYPE="ext4" 
/dev/sdb2: LABEL="TERESA" UUID="4CE4692BE469190A" TYPE="ntfs" 
/dev/sdc1: LABEL="OBORO" UUID="20FEB393FEB36028" TYPE="ntfs" 
/dev/sdc2: LABEL="TANABE" UUID="88BCE378BCE35F66" TYPE="ntfs" 
/dev/sdd2: LABEL="SAKI" UUID="26E0FD2DE0FD03B9" TYPE="ntfs" 
/dev/sdd5: LABEL="REKI" UUID="F408618A08614CA4" TYPE="ntfs" 
/dev/sde1: LABEL="SAYA" UUID="B88440648440276A" TYPE="ntfs" 
/dev/sde2: LABEL="MOTOKO" UUID="F0005CEB005CB9F4" TYPE="ntfs" 
/dev/sdf1: UUID="f2d547ed-164e-4d90-bb32-ad3c57046d4f" TYPE="ext4" 
/dev/sdf2: LABEL="CLARE" UUID="DA7C0A647C0A3BAF" TYPE="ntfs" 
/dev/mapper/truecrypt1: UUID="3E0006BE00067CE1" TYPE="ntfs" 
/dev/mapper/truecrypt2: UUID="A2E0E88CE0E867CD" TYPE="ntfs" 
/dev/mapper/truecrypt3: UUID="C6D061EDD061E3E1" TYPE="ntfs" 
/dev/mapper/truecrypt4: UUID="28D82F4DD82F1918" TYPE="ntfs" 
/dev/mapper/truecrypt5: UUID="640400580400301A" TYPE="ntfs"
I think that everything is ok (exept that there is zram, (i didn't install it - it came by itself?), and it is in one other swap partition.


Can you help me? Suspend/hibernation to disk doesen't work. When i switch, computer goes silently into "sleep" mode (i see that s2d is writing file) but after resuming computer either freezes on purple wallpaper with bouncing orange balls (boot screen of ubuntu) or if either works fine...it's in fact reebooted not resumed because my apps doesen't run in background.
 
Old 05-26-2012, 07:13 PM   #2
kareempharmacist
Member
 
Registered: Jan 2012
Location: Cairo Egypt
Distribution: CrunchBang,Linux Mint,Slackopuppy
Posts: 266

Rep: Reputation: 18
http://askubuntu.com/questions/66879...-fix-hibernate
 
Old 05-27-2012, 05:38 AM   #3
firekage
Member
 
Registered: May 2011
Location: Poland
Distribution: Slackware, Ubuntu, Arch
Posts: 272

Original Poster
Rep: Reputation: 7
Quote:
Originally Posted by kareempharmacist View Post
Desen't work. I already have installed uswsusp. When i choose suspend to disk i see that uswsusp is writing file on the disk but after resuming it boots not from suspend but as a normal boot from start, not as a resume.

Last edited by firekage; 05-27-2012 at 05:40 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network Can't be reloaded after resume from hibernation snowweb Linux - Networking 2 09-16-2012 10:53 PM
Ubuntu boots up from hibernation is not faster TigerLinux Ubuntu 3 02-15-2011 10:32 PM
File to wakeup the system for hibernation like resume.sh ?? sanketdangi Ubuntu 3 01-16-2010 12:25 PM
[SOLVED] Suspend/Hibernation resume problems with ATI graphics card. defensorfedei Linux - Laptop and Netbook 5 10-13-2009 04:14 AM
Is hibernation broken in Ubuntu? gohmifune Ubuntu 1 06-13-2007 04:39 AM


All times are GMT -5. The time now is 02:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration