LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Ubuntu 10.10 - ATI Drivers. (http://www.linuxquestions.org/questions/ubuntu-63/ubuntu-10-10-ati-drivers-841547/)

someone Awesome 10-31-2010 12:25 PM

Ubuntu 10.10 - ATI Drivers.
 
Introduction:

After quite some time I have used windows i have returned to Linux, I used to love Linux but than I had to use windows for gaming purposes.

Now, I have decided to try Linux again in dual boot with windows 7 ultimate.

Installation was pretty smooth, I successfully installed Ubuntu 10.10 (64 bit amd).

My PC:

Amd phenom 2 X2 550 3.0 GHZ
Gigabyte GA-MA770-UD3
Samsung 500GB hard disk
AMD ATI Raedon hd 4870

I have A few problems.

1:
I have a dual screen setup, one 17'' screen in the left and a main 22'' screen in the middle. It works perfectly in windows but for some bizarre reason I can't manage to configure my 22'' inch screen as a main screen in ubuntu. Furthermore, when I set them together the smaller screen (which it sets as main) as some weird location issues. (may have something to do with 2 and 3).

2:
My 17'' inch screen (mentioned above), is a native 1280X1024. But ubuntu doesn't give me that as an option. I have 1360X768 (which is over the native) and 1152X864.

3:
This is probably the cause for the 2 first problems. I have installed ATI CATALYST control panel in order to fix those problems, and it says :
"
There was a problem initializing Catalyst Control Center Linux edition. It could be caused by the following.
No ATI graphics driver is installed, or the ATI driver is not functioning properly.
Please install the ATI driver appropriate for you ATI hardware, or configure using aticonfig.
"

I will probably come out with more problems as ill play with it.

TobiSGD 10-31-2010 12:28 PM

Did you install the ATI-driver with the Driver Manager of Ubuntu?

someone Awesome 10-31-2010 02:00 PM

ok I installed it, it now works as it should.


But it's realy slow just dragging about windows and such.

It souldn't be this slow...

TobiSGD 11-01-2010 07:58 AM

I found out the the 2D acceleration of the ATI driver is not very well, but it seems to me that this is not true for all cards. I don't have this issue, so I can't help you with this, sorry.

someone Awesome 11-01-2010 12:34 PM

There is a diffrence between just "not well" to stalling while dragging a window around.


Anyone knows the cause of this?


*** hd 4870 is a quite a strong card... it's not hardware related ***

someone Awesome 11-04-2010 12:10 AM

I guess no one knows ?

:(

crts 11-04-2010 08:07 AM

Hi,

it has been a long time since I used the proprietary driver for my ATI card (it's no longer supported). However, I do recall that I had to change some settings in the xorg.conf file to get some decent performance. Unfortunately I do not remember what exactly I changed. Maybe you could post your xorg.conf here. I assume, xorg.conf is still needed for the ATI drivers to work.

someone Awesome 11-05-2010 01:28 AM

Code:

Section "ServerLayout"
        Identifier    "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier  "aticonfig-Monitor[0]-0"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
EndSection

Section "Monitor"
        Identifier  "0-DFP2"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
        Option            "PreferredMode" "1920x1080"
        Option            "TargetRefresh" "60"
        Option            "Position" "0 0"
        Option            "Rotate" "normal"
        Option            "Disable" "false"
EndSection

Section "Monitor"
        Identifier  "0-CRT2"
        Option            "VendorName" "ATI Proprietary Driver"
        Option            "ModelName" "Generic Autodetecting Monitor"
        Option            "DPMS" "true"
        Option            "TargetRefresh" "60"
        Option            "Position" "0 56"
        Option            "Rotate" "normal"
        Option            "Disable" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        Option            "Monitor-DFP2" "0-DFP2"
        Option            "Monitor-CRT2" "0-CRT2"
        BusID      "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device    "aticonfig-Device[0]-0"
        DefaultDepth    24
        SubSection "Display"
                Viewport  0 0
                Depth    24
        EndSubSection
EndSection



Here it is, I have no idea what I need to change but... I guess you guys can help me with that.

crts 11-05-2010 05:55 AM

Quote:

Originally Posted by someone Awesome (Post 4149863)
Code:

Section "ServerLayout"
    Identifier    "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier  "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Monitor"
    Identifier  "0-DFP2"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
    Option        "PreferredMode" "1920x1080"
    Option        "TargetRefresh" "60"
    Option        "Position" "0 0"
    Option        "Rotate" "normal"
    Option        "Disable" "false"
EndSection

Section "Monitor"
    Identifier  "0-CRT2"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
    Option        "TargetRefresh" "60"
    Option        "Position" "0 56"
    Option        "Rotate" "normal"
    Option        "Disable" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    Option        "Monitor-DFP2" "0-DFP2"
    Option        "Monitor-CRT2" "0-CRT2"
    BusID      "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device    "aticonfig-Device[0]-0"
    DefaultDepth    24
    SubSection "Display"
        Viewport  0 0
        Depth    24
    EndSubSection
EndSection

Here it is, I have no idea what I need to change but... I guess you guys can help me with that.

Hello again,

I googled a bit and found this:
http://www.linuxinsight.com/your-ati...erver-1.3.html

I do recall that the option
Option "MigrationHeuristic" "greedy"

was the decisive option that got my card working back years ago. I am not sure if this will also help you, but it is worth a try. If not, try google with the following search terms:
linux ati driver slow

You might also want to include your card model. Keep us posted if this solves your issue.

stress_junkie 11-05-2010 08:03 AM

This might help.

http://www.phoronix.com/scan.php?pag...nhd_4870&num=1

phoronix is a great resource for information concerning hardware on Linux.

someone Awesome 11-05-2010 10:15 AM

didn't i mention?
Power color Ati raedon Hd 4870 512MB


Oh, and after trying some games (Open arena, Asylum) i found out they don't work. no error, but they wont start.

ill try your option and update

someone Awesome 11-05-2010 11:25 AM

It didn't work, I also tried to reinstall drivers, but no luck.

I didn't quite find a solution online :(

someone Awesome 11-08-2010 05:26 AM

Anyone?

:(
:(
:(

someone Awesome 11-10-2010 04:45 AM

I guess there is no solution?

RedEyez 11-10-2010 09:22 AM

which ATI driver did you install from the ubuntu software manager? the ATI Binary X.org driver? because ubuntu has several different "ATI" drivers to choose from... and also if you go to System > Administration > Additional drivers does it say that the ati proprietary driver is in use?


All times are GMT -5. The time now is 08:25 AM.