LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 06-03-2006, 09:50 AM   #1
vital_101
Member
 
Registered: Jul 2005
Location: Mount Pleasant, Michigan
Distribution: Ubuntu Jaunty 9.04
Posts: 82

Rep: Reputation: Disabled
Trouble mounting floppy drive in Ubuntu 5.10


I recently needed to make use of my floppy drive (I know, weird). To access it, I went to places-->computer-->floppy drive. Upon double clicking that icon I get the error message:

Mount Error: give UDI is not a mountable volume.

Any ideas how I can get this fixed?
Thanks ahead of time.

/vital_101
 
Old 09-10-2006, 11:15 AM   #2
wezzie
LQ Newbie
 
Registered: Mar 2006
Posts: 15

Rep: Reputation: 0
Hi
I'm having exact same problem on identical distro.I would welcome the most simple instructions available as I'm probably the simplist newbie you've yet had to deal with! Thank you
Paul
 
Old 09-10-2006, 11:44 AM   #3
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
Can you post the condense of the file "/etc/fstab"
 
Old 09-10-2006, 03:48 PM   #4
crash_override_me
Member
 
Registered: Aug 2005
Location: India, New Delhi
Distribution: Debian Etch, Ubuntu
Posts: 342

Rep: Reputation: 30
may be there is no entry in ur /etc/fstab for mounting the floppy..
 
Old 09-10-2006, 08:34 PM   #5
Burrhead
LQ Newbie
 
Registered: Jan 2004
Posts: 5

Rep: Reputation: 0
Mounting Floppy Drive

Put a disk in the drive and try again.
 
Old 09-11-2006, 11:10 AM   #6
wezzie
LQ Newbie
 
Registered: Mar 2006
Posts: 15

Rep: Reputation: 0
I managed to find /etc/fstab. there is an entry for my floppy that goes something like this:- /dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

Is this getting me anywhere?
 
Old 09-11-2006, 05:35 PM   #7
wezzie
LQ Newbie
 
Registered: Mar 2006
Posts: 15

Rep: Reputation: 0
Further to this,I tried a remedy I stumbled across in the LQ Wiki:-
mount /mnt/floppy and got cant find/mnt/floppy in/etc/fstab or /etc/mtab.
Now I'm really confused!
Paul
 
Old 09-11-2006, 06:18 PM   #8
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
you would have to change the command to "mount /media/floppy0"
you may also want to remove the "auto" from /etc/fstab as you have "noauto" there, which conflicts it.
 
Old 09-12-2006, 06:39 AM   #9
wezzie
LQ Newbie
 
Registered: Mar 2006
Posts: 15

Rep: Reputation: 0
Many thanks to you 'binary y2k2'.The "mount /media/floppy0" command was a complete success!I have extracted the files I needed to get my ADSL modem working with UBUNTU and am therefore one step closer to being able to kick the 'anti christ'(Microsoft) into touch!
Just one more question re. this issue if you don't mind. How do I remove the 'auto' from 'fstab'? The file I took the info from was 'read only'.
 
Old 09-12-2006, 07:03 AM   #10
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
you need to edit the file as root:
in Gnome, press Alt-F2 and enter
Code:
gksu gedit /etc/fstab
in KDE, press Alt-F2 and enter
Code:
kdesu kate /etc/fstab
in a terminal
Code:
sudo nano /etc/fstab
 
Old 09-13-2006, 10:26 AM   #11
wezzie
LQ Newbie
 
Registered: Mar 2006
Posts: 15

Rep: Reputation: 0
Thanks again Y2K2. Concise, easy to understand answers. The only sort I can work with. You've saved me many hours and much frustration. I owe you one!
Paul
 
Old 09-13-2006, 02:55 PM   #12
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
No problem Paul, you're welcome.

It's nice you took the time to say thanks, not many posters do that.
 
Old 09-15-2006, 12:21 PM   #13
treader
LQ Newbie
 
Registered: Mar 2006
Location: Cincinnati, OH
Distribution: Ubuntu Breezy Badger
Posts: 7

Rep: Reputation: 0
floppy not recognized

I am adding this here because it seems to be the same sort of problem.
2.6.15-26-386, used to be Kubuntu-6.0.6 but i goobered that up by fooling with synaptic wearing the wrong pair of glasses. 2.93 Celeron in an Intel D101ggc mobo.

THE PROBLEM: I put a floppy drive in the box, and turned on the computer. The copy of tomsrtbt on the floppy booted and ran. But above Linux doesn't recognize the floppy drive. My thought is that adding a line to /etc/fstab might solve this, but

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

with the last line above added,
#*****How does one add those cute code boxes to a post?*****
mike@kubuntu-treader:~$ mount /dev/fd0
mount: I could not determine the filesystem type, and none was specified

with a floppy in the drive

mike@kubuntu-treader:~$ mount /dev/fd0
mount: mount point /media/floppy0 does not exist

If there are some texts that I could study to help with this I would appreciate hearing about them.
Anything short of re-sysgening.
Think ignorant newbee.

Studying hard to become a script_kiddy,
Mike Moulton

Last edited by treader; 09-15-2006 at 12:22 PM.
 
Old 09-16-2006, 12:14 PM   #14
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
Quote:
Originally Posted by treader
I am adding this here because it seems to be the same sort of problem.
2.6.15-26-386, used to be Kubuntu-6.0.6 but i goobered that up by fooling with synaptic wearing the wrong pair of glasses. 2.93 Celeron in an Intel D101ggc mobo.

THE PROBLEM: I put a floppy drive in the box, and turned on the computer. The copy of tomsrtbt on the floppy booted and ran. But above Linux doesn't recognize the floppy drive. My thought is that adding a line to /etc/fstab might solve this, but

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda5 none swap sw 0 0
/dev/hdd /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

with the last line above added,
That would work if the device fd0 was associated with your device
Quote:
Originally Posted by treader
#*****How does one add those cute code boxes to a post?*****
By putting "[ code ]" and "[ /code ]" (without spaces) around the text.
Quote:
Originally Posted by treader
mike@kubuntu-treader:~$ mount /dev/fd0
mount: I could not determine the filesystem type, and none was specified

with a floppy in the drive

mike@kubuntu-treader:~$ mount /dev/fd0
mount: mount point /media/floppy0 does not exist
you need to make sure the mount point (/media/floppy0) exists, if not then create it.
Quote:
Originally Posted by treader
If there are some texts that I could study to help with this I would appreciate hearing about them.
"man fstab" and "man mount" may help, fstab is pretty simple but mount is more complicated.

Look at the output of the command "lspci" post the output to see if your drive is recognised by linux.

Last edited by binary_y2k2; 09-16-2006 at 12:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting floppy drive foliva Suse/Novell 2 09-21-2005 03:24 PM
mounting floppy drive??? SillyLinuxNewb Linux - Laptop and Netbook 1 12-29-2004 05:59 AM
Need help mounting floppy drive everythingand2 Slackware 16 10-11-2003 07:06 PM
Mounting Floppy Drive weelyjim Linux - Newbie 2 08-29-2003 03:27 PM
mounting my floppy drive jolly_good2000 Linux - General 2 11-19-2002 10:55 AM


All times are GMT -5. The time now is 09:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration