LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 11-07-2007, 05:44 AM   #1
pk_kala
Member
 
Registered: Feb 2006
Posts: 34

Rep: Reputation: 15
The following packages are BROKEN:


I try to install xmms.
# aptitude install xmms
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
xmms
The following NEW packages will be automatically installed:
libglib1.2 libgtk1.2 libgtk1.2-common
The following NEW packages will be installed:
libglib1.2 libgtk1.2 libgtk1.2-common
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 3270kB of archives. After unpacking 9507kB will be used.
The following packages have unmet dependencies:
xmms: Depends: libmikmod2 (>= 3.1.10) which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
xmms [Not Installed]

Score is -9881

Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done

Help me please


BR
 
Old 11-07-2007, 07:43 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
Forget xmms. It's a dead project and several distros have already removed it from their repositories (and others are considering it). Install audacious and its related plugin packages instead. It's everything xmms was, but completely rewritten with a modern gtk2 interface. And it's under active development. You won't be sorry.
 
Old 11-07-2007, 09:55 AM   #3
php
Member
 
Registered: Jun 2001
Location: USA
Distribution: Slackware
Posts: 825

Rep: Reputation: 30
it's decrepited
 
Old 11-07-2007, 10:46 PM   #4
pk_kala
Member
 
Registered: Feb 2006
Posts: 34

Original Poster
Rep: Reputation: 15
Hi All,
I try to install vlc and other package.
I have same problem.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
vlc vlc-nox
The following NEW packages will be automatically installed:
liba52-0.7.4 libdvbpsi4 libdvdnav4 libdvdread3 libebml0 libiso9660-4 libmatroska0 libmpeg2-4 libtar libvcdinfo0 libvlc0 libwxbase2.6-0 libwxgtk2.6-0
libxosd2 videolan-doc
The following NEW packages will be installed:
liba52-0.7.4 libdvbpsi4 libdvdnav4 libdvdread3 libebml0 libiso9660-4 libmatroska0 libmpeg2-4 libtar libvcdinfo0 libvlc0 libwxbase2.6-0 libwxgtk2.6-0
libxosd2 videolan-doc
0 packages upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
Need to get 21.2MB of archives. After unpacking 45.2MB will be used.
The following packages have unmet dependencies:
vlc-nox: Depends: libavcodec1d (>= 0.cvs20070307) which is a virtual package.
Depends: libavformat1d (>= 0.cvs20070307) which is a virtual package.
Depends: libavutil1d (>= 0.cvs20070307) which is a virtual package.
Depends: libdc1394-13 which is a virtual package.
Depends: libgsm1 (>= 1.0.10) which is a virtual package.
Depends: libid3tag0 (>= 0.15.1b) which is a virtual package.
Depends: libmad0 (>= 0.15.1b) which is a virtual package.
Depends: libmodplug0c2 (>= 1:0.7-4.1) which is a virtual package.
Depends: libmpcdec3 which is a virtual package.
Depends: libpostproc1d (>= 0.cvs20070307) which is a virtual package.
vlc: Depends: ttf-dejavu which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
vlc [Not Installed]
vlc-nox [Not Installed]

Score is -9872

Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done


Thank you.
 
Old 11-08-2007, 12:23 AM   #5
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950Reputation: 1950
What you're experiencing is a dependency conflict. The programs already on your computer need different versions of the libraries than the ones the new program needs. So you have to choose which program you want, you can't have both.

Usually this is only a temporary problem. Sometimes some packages are updated to use newer library versions before other programs, or even before the libraries themselves are available. Most of the time your best bet is simply to wait a few days or weeks until everything gets updated.

You can also play around and find out just where the dependency problem lies. Try running install and/or remove on each of the various listed dependencies. Their outputs should tell you exactly which packages need these libraries, and which ones are causing the hold-up. You have to do some detective work though.

If you really need the program right away, you could try getting the source code and compiling it yourself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Packages hraposo Ubuntu 1 08-23-2007 01:23 PM
Broken packages mcnearcj Ubuntu 3 08-01-2006 02:56 PM
Broken Packages hongman Linux - Software 2 04-13-2005 06:48 AM
what's with all those broken packages darkleaf Debian 8 09-29-2004 02:40 PM
Broken Packages Kujila Linux - Software 2 02-01-2004 06:07 PM


All times are GMT -5. The time now is 07:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration