LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   The following packages are BROKEN: (http://www.linuxquestions.org/questions/ubuntu-63/the-following-packages-are-broken-597734/)

pk_kala 11-07-2007 04:44 AM

The following packages are BROKEN:
 
I try to install xmms.
# aptitude install xmms
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
xmms
The following NEW packages will be automatically installed:
libglib1.2 libgtk1.2 libgtk1.2-common
The following NEW packages will be installed:
libglib1.2 libgtk1.2 libgtk1.2-common
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 3270kB of archives. After unpacking 9507kB will be used.
The following packages have unmet dependencies:
xmms: Depends: libmikmod2 (>= 3.1.10) which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
xmms [Not Installed]

Score is -9881

Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done

Help me please


BR

David the H. 11-07-2007 06:43 AM

Forget xmms. It's a dead project and several distros have already removed it from their repositories (and others are considering it). Install audacious and its related plugin packages instead. It's everything xmms was, but completely rewritten with a modern gtk2 interface. And it's under active development. You won't be sorry.

php 11-07-2007 08:55 AM

it's decrepited

pk_kala 11-07-2007 09:46 PM

Hi All,
I try to install vlc and other package.
I have same problem.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
The following packages are BROKEN:
vlc vlc-nox
The following NEW packages will be automatically installed:
liba52-0.7.4 libdvbpsi4 libdvdnav4 libdvdread3 libebml0 libiso9660-4 libmatroska0 libmpeg2-4 libtar libvcdinfo0 libvlc0 libwxbase2.6-0 libwxgtk2.6-0
libxosd2 videolan-doc
The following NEW packages will be installed:
liba52-0.7.4 libdvbpsi4 libdvdnav4 libdvdread3 libebml0 libiso9660-4 libmatroska0 libmpeg2-4 libtar libvcdinfo0 libvlc0 libwxbase2.6-0 libwxgtk2.6-0
libxosd2 videolan-doc
0 packages upgraded, 17 newly installed, 0 to remove and 0 not upgraded.
Need to get 21.2MB of archives. After unpacking 45.2MB will be used.
The following packages have unmet dependencies:
vlc-nox: Depends: libavcodec1d (>= 0.cvs20070307) which is a virtual package.
Depends: libavformat1d (>= 0.cvs20070307) which is a virtual package.
Depends: libavutil1d (>= 0.cvs20070307) which is a virtual package.
Depends: libdc1394-13 which is a virtual package.
Depends: libgsm1 (>= 1.0.10) which is a virtual package.
Depends: libid3tag0 (>= 0.15.1b) which is a virtual package.
Depends: libmad0 (>= 0.15.1b) which is a virtual package.
Depends: libmodplug0c2 (>= 1:0.7-4.1) which is a virtual package.
Depends: libmpcdec3 which is a virtual package.
Depends: libpostproc1d (>= 0.cvs20070307) which is a virtual package.
vlc: Depends: ttf-dejavu which is a virtual package.
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
vlc [Not Installed]
vlc-nox [Not Installed]

Score is -9872

Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?] Y
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done


Thank you.

David the H. 11-07-2007 11:23 PM

What you're experiencing is a dependency conflict. The programs already on your computer need different versions of the libraries than the ones the new program needs. So you have to choose which program you want, you can't have both.

Usually this is only a temporary problem. Sometimes some packages are updated to use newer library versions before other programs, or even before the libraries themselves are available. Most of the time your best bet is simply to wait a few days or weeks until everything gets updated.

You can also play around and find out just where the dependency problem lies. Try running install and/or remove on each of the various listed dependencies. Their outputs should tell you exactly which packages need these libraries, and which ones are causing the hold-up. You have to do some detective work though.

If you really need the program right away, you could try getting the source code and compiling it yourself.


All times are GMT -5. The time now is 08:18 AM.