LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 10-12-2006, 06:28 AM   #1
rojak
LQ Newbie
 
Registered: May 2006
Location: Singapore
Distribution: Ubuntu 9.10
Posts: 16

Rep: Reputation: 0
tftp server problems on Ubuntu 6.06


I am about to give up and become an insurance agent...

Tried everything to get a tftp server running on Ubuntu 6.06
tftpd, atftpd and tftpd-hpa
Start from inet.d as well as stand-alone
Ran clients thru localhost, LAN, cross-cable
Read all posts related to tftp...

The best I can get is timeout

Anyone can give me a hint what is left to try?

TiA
 
Old 10-12-2006, 09:22 AM   #2
IBall
Senior Member
 
Registered: Nov 2003
Location: Perth, Western Australia
Distribution: Ubuntu, Debian, Various using VMWare
Posts: 2,088

Rep: Reputation: 61
Is there any reason why you want a TFTP server?

Unless there is, I suggest using SSH, which is secure and also provides SFTP and SCP. There is plenty of info available on setting up SSH, basically you need to install the openSSH server using apt-get and you are good to go. I have some info Here

--Ian
 
Old 10-12-2006, 07:07 PM   #3
rojak
LQ Newbie
 
Registered: May 2006
Location: Singapore
Distribution: Ubuntu 9.10
Posts: 16

Original Poster
Rep: Reputation: 0
Yes there is.
My TFTP client is a Uboot bootloader on an embedded platform.
The only way to get kernel / filesytem downloaded is by TFTP request from Uboot shell.
In the past got it working in a Redhat 9 environment.

Nevertheless, I can take a look into Uboot support for SSH.
 
Old 10-12-2006, 07:38 PM   #4
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Re: TFTP

After you start the TFTP daemon check your netstat table for port 69.

Code:
# netstat -ul
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
udp        0      0 *:tftp                  *:*
t for UDP and l for listening


In most case's the TFTP daemon has a configured root directory of /tftpboot.
 
Old 10-16-2006, 09:15 PM   #5
xinxin
LQ Newbie
 
Registered: Sep 2006
Posts: 5

Rep: Reputation: 0
If your configure path is "/etc/inetd.conf", then check if you add "-s" parameter in that list. In my case, without "-s", I can not access /tftpboot directory for downloading and uploading. I also set my directory to /tftpboot and set the it to 777 permission.

Quote:
#:BOOT: Tftp service is provided primarily for booting. Most sites
# run this only on machines acting as "boot servers."
tftp dgram udp wait nobody /usr/sbin/tcpd /usr/sbin/in.tftpd -s /tftpboot
Hope it can help you,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TFTP Server mattp Linux - Software 8 01-18-2010 05:28 PM
TFTP server yhus Linux - Networking 5 06-18-2006 02:44 PM
tftp on Ubuntu 5.10 blejeune Ubuntu 1 02-12-2006 05:08 PM
tftp on Ubuntu 5.10 blejeune Debian 1 02-11-2006 11:41 PM


All times are GMT -5. The time now is 09:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration