LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Ubuntu (http://www.linuxquestions.org/questions/ubuntu-63/)
-   -   Switching Keyboard Layout in Console Only (http://www.linuxquestions.org/questions/ubuntu-63/switching-keyboard-layout-in-console-only-787624/)

Saint-Ours 02-07-2010 01:52 PM

Switching Keyboard Layout in Console Only
 
Hello,

First, I have searched a lot on this issue, but trying what I found only returned error messages... I will try to be detailed.

Issue:
I am logging into an Ubuntu 8.04 machine using ssh, so I use a console. The keyboard layout is US-standard, obvioulsy. However, I would like to use french-canadian keyboard layout. And I don't know at all how to switch it in console. Give me Gnome or KDE, and we're done. But this is console only.

Clues:
I guess it has to do with the loadkeys command. Ok. I retrieved from the web a file cf.map.gz. Maybe ubuntu requires a different kind of file? Using "locate cf.map" I get nothing, except the file I have downloaded. Any package I should demand to be installed? (if yes, what do I do once they are in?)

I tried using both the .gz and uncompressed files.

Code:

loadkeys cf.map.gz
Couldnt get a file descriptor referring to the console

Code:

loadkeys -u cf.map.gz
Couldnt get a file descriptor referring to the console
Loading cf.map.gz
loadkeys: cf.map.gz:8: cannot open include file qwerty-layout

What's going on?

Another path:
URL: https://help.ubuntu.com/community/LocaleConf

They tell us about some program, console-data, using root privileges. Intriguing, but I am only a user, and do not have any root privileges. The system admin. has never used another keyboard layout, and knows even less than I on this matter.

Please do not tell me "man loadkeys", because it says nothing (to me).

I tried similar stuff on my openSUSE at home, on a newly created experimental account, and I am equally unable to change within the console the keyboard layout (similar error messages).

Thank you for your help.

Saint-Ours 02-07-2010 03:20 PM

Hummmm... Nevermind.

I just found out something to make things simpler:

The keyboard layout being used is not function of the system you are ssh-ed in, but of the actual hardware configuration of the machine/account you are physically working on. So my problem initially was created by using resetted settings from a previously faulty Gnome, which fooled me quite a bit.

Nonetheless, this loadkeys command remains not very functional for me (but it did work on my computer, using root). Is this a system-wide command? Anyway it is likely an old and deprecated way to change layout.

Bibelo 02-07-2011 08:57 AM

Quote:

Originally Posted by Saint-Ours (Post 3855973)
Hummmm... Nevermind.

I just found out something to make things simpler:

The keyboard layout being used is not function of the system you are ssh-ed in, but of the actual hardware configuration of the machine/account you are physically working on. So my problem initially was created by using resetted settings from a previously faulty Gnome, which fooled me quite a bit.

Nonetheless, this loadkeys command remains not very functional for me (but it did work on my computer, using root). Is this a system-wide command? Anyway it is likely an old and deprecated way to change layout.

Hello,

did you finally find a way to change keyboard in a SSH session ?

Thank you.


All times are GMT -5. The time now is 09:52 PM.