LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices



Reply
 
Search this Thread
Old 06-19-2007, 09:18 AM   #1
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Rep: Reputation: 32
subdomains


Hi all

Trying to work out how to run subdomains

I've followed this link
http://www.debuntu.org/2006/02/22/7-...using-apache-2

When I reload Apache2

I get the following message

Code:
root@rockinghamgateway:/etc/apache2/sites-enabled# /etc/init.d/apache2 reload
 * Reloading apache 2.0 configuration...                                                                                   [Tue Jun 19 21:14:45 2007] [warn] VirtualHost cooper.rockinghamgateway.com:0 overlaps with VirtualHost cooper.rockinghamgateway.com:0, the first has precedence, perhaps you need a NameVirtualHost directive
                                                                                                                    [ ok ]
I created the link ok, and did it in the directory it says too.

Code:
root@rockinghamgateway:/etc/apache2/sites-enabled# ln -s /etc/apache2/sites-available/cooper.rockinghamgateway.com.conf copper.rockinghamgateway.com.conf
I'm alittle lost here, have I miss some thing

TT
 
Old 06-19-2007, 09:45 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
you've not even said if it's working or not.. i assume it's not but you've said nothign about what youre problem is...
 
Old 06-19-2007, 09:49 AM   #3
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by acid_kewpie
you've not even said if it's working or not.. i assume it's not but you've said nothign about what youre problem is...
My problem is why wont it work

TT
 
Old 06-19-2007, 10:50 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
how are you testing it? what do your access logs say? what does your config say?
 
Old 06-19-2007, 07:24 PM   #5
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by acid_kewpie
how are you testing it? what do your access logs say? what does your config say?
I'm testing it via browser on another PC on my network.

My last log says this

Code:
192.168.1.7 - - [19/Jun/2007:21:49:15 +0800] "GET /sphider-logo.png HTTP/1.1" 304 - "http://cooper.rockinghamgateway.com/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.4) Gecko/20061201 Firefox/2.0.0.4 (Ubuntu-feisty)"
when i test it, its bringing up my main domain name page http://www.rockinghamgateway.com/ not the cooper page.

TT
 
Old 06-20-2007, 02:44 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
wow, you really don't want to give any trade secrets away do you??
 
Old 06-20-2007, 06:09 AM   #7
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
I haven't had any trade secrets to give away

I'm just trying to work out how to do the subdomains

Any one care to point me to a tutorial please, I cant seem to get it right.

TT

Last edited by tommytomato; 06-20-2007 at 07:01 AM.
 
Old 06-20-2007, 07:11 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
you've still not shown us your config... how can we possibly tell you what you've done wrong if you won't show us what you've done in the first place?
 
Old 06-20-2007, 07:16 AM   #9
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by acid_kewpie
you've still not shown us your config... how can we possibly tell you what you've done wrong if you won't show us what you've done in the first place?
what config file your taking about ? sorry but here are a few

TT
 
Old 06-20-2007, 08:30 AM   #10
tommytomato
Member
 
Registered: Nov 2003
Location: Narrogin Western Australia
Distribution: GUI Ubuntu 12.04 - Server 12.04.4 LTS
Posts: 935

Original Poster
Rep: Reputation: 32
I think i got it

Not sure if its the correct way, but i followed what this person said

http://ubuntuforums.org/showthread.p...ight=subdomain

is a2ensite the same as linking it

opps, can i have a live test please

does the subdomain http://linux.rockinghamgateway.com work, it does my end.

TT

Last edited by tommytomato; 06-20-2007 at 08:39 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help with subdomains (DNS) Bzz Linux - Networking 11 12-11-2006 01:18 PM
Subdomains tommytomato Linux - Newbie 5 02-04-2004 10:48 AM
Subdomains papaj Linux - General 7 04-26-2003 05:19 PM
Bind and subdomains jnsc Linux - Software 2 03-01-2003 09:43 AM
Subdomains setting up - help :) Acid_Burn Linux - General 4 12-15-2002 06:10 AM


All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration