LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2006, 03:15 PM   #1
crashsystems
Member
 
Registered: May 2006
Location: Tennessee et. al
Distribution: Debian Sid, Etch
Posts: 138

Rep: Reputation: 15
Strange screen resolution


I just recently switched from Mandriva 2006 to Ubuntu (by the way, how is that pronounced?), and I'm lovering it! Finally, a fast/simple distro where ACPI actually works. Anyways, my computer is an acer laptop with a wide screen at 1280 x 960, but the closest fitting res in System/Preferences/Screen Resolution menu is 1024 x 760. Does anyone know how I could change my res to 1280 x 960? Thanks for your help.

crashsystems

Last edited by crashsystems; 10-28-2006 at 02:06 PM.
 
Old 07-20-2006, 03:29 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
I believe it is pronounced "Oo-boon-too".

sudo dpkg-reconfigure xserver-xorg then be sure to select all the applicable resolutions for your machine.
 
Old 07-20-2006, 04:18 PM   #3
crashsystems
Member
 
Registered: May 2006
Location: Tennessee et. al
Distribution: Debian Sid, Etch
Posts: 138

Original Poster
Rep: Reputation: 15
ok, I did the xorg reconfigure thing twice, and it diden't work. I made sure to select the resolution I want, but instead of adding that to the list after I rebooted, the only extra entry is 960 x 600, which of course looks terrable on this screen. Any idea what I might be doing wrong?

crashsystems

P.S. Below is the contents of my xorg.conf file. Perhaps it will be usefull.

Section "Files"
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/wacom" # Change to
# /dev/input/event
# for USB
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "SiSM760GX"
Driver "sis"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Acer 15.4"
Option "DPMS"
HorizSync 30-60
VertRefresh 50-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "SiSM760GX"
Monitor "Acer 15.4"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x960" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Last edited by crashsystems; 07-20-2006 at 04:24 PM.
 
Old 07-20-2006, 04:32 PM   #4
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Weird, it looks like your display says its setup to do 1280x960. Try Ctrl+Alt+"+" to just increment your current display.
 
Old 07-20-2006, 04:37 PM   #5
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
1280x960 isn't a widescreen resolution. It's a normal 4:3 resolution (just like 1024x768, 800x600, 640x480, 1600x1200).

Could your laptop's resolution actually be 1280x720?
 
Old 07-20-2006, 04:43 PM   #6
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You could try generating your own modeline with the "gft" program.
Code:
gtf 1280 960 56 -x
This output a line with a modeline for "1280x960_56.00". Remove the ".00" and either insert the modeline in your [Monitor] section. This is what I had to do to get 1280x800 on my laptop when I used SuSE 9.3.

Also, read through your /var/log/xorg.0.log file. It's possible that there was a problem setting up a screen for the 1280x960 resolution. The two lines:
HorizSync 30-60
VertRefresh 50-75
can be a bit touchy if the values are off.
 
Old 07-20-2006, 05:01 PM   #7
crashsystems
Member
 
Registered: May 2006
Location: Tennessee et. al
Distribution: Debian Sid, Etch
Posts: 138

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jschiwal
You could try generating your own modeline with the "gft" program.
Code:
gtf 1280 960 56 -x
This output a line with a modeline for "1280x960_56.00". Remove the ".00" and either insert the modeline in your [Monitor] section. This is what I had to do to get 1280x800 on my laptop when I used SuSE 9.3.
I ran the gtf program in the terminal, and here is the responce.

Code:
crashsystems@crashsystems:~$ gtf 1280 960 56 -x

  # 1280x960 @ 56.00 Hz (GTF) hsync: 55.55 kHz; pclk: 94.22 MHz
  Modeline "1280x960_56.00"  94.22  1280 1352 1488 1696  960 961 964 992  -HSync +Vsync
If I'm understanding you correctly, I'm supposed to instert the modeline somewhere in the monitor section of my xorg.conf. However, I'm a bit fuzzy as to exactly where to put it (I know how picky config file syntax can be). Also, in responce to IsaacKuo, the book that came with the laptop listed it's max resolution as 1280 x 960. Perhaps its not widescreen, but that is what I thought of it as, sence it looks a little wider than you average 15" screen.

crashsystems

Last edited by crashsystems; 07-20-2006 at 05:02 PM.
 
Old 07-20-2006, 08:33 PM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
First of all, the "xorg.conf" file has its own man page.
Yes, there are two ways of doing it. One way is to have a Modes section and use "UseModes" in the Monitor section.
The other is to use the "ModeLine" identifier, which your generated modeline has. Then in the Screen section, change the "1280x960" to "1280x960_56" so that they match your modeline entry. For example:
Depth 24
Modes "1280x960" "1024x768" "800x600" "640x480"

I'm not certain but I think you should change your modeline to:
Modeline "1280x960_56" 94.22 1280 1352 1488 1696 960 961 964 992 -HSync +Vsync

So your Monitor section will look like:
Code:
Section "Monitor"
Identifier "Acer 15.4"
Option "DPMS"
HorizSync 30-60
VertRefresh 50-75
EndSection

Some distros will produce a modes section. That makes it possible to have one section shared between two Monitor sections. Please back up your old xorg.conf file before changing it.
You might consider copying your monitor section and changing the identifier on your old one. It is the MonitorID listed in the ServerLayout section that determines which one is used.

If you were the experimental type, you could use the second dual head output, add a usb keyboard and another mouse, and set things up so that two people can operate your computer independently.
Then both your kids can be doing their homework at the same time!

Last edited by jschiwal; 07-20-2006 at 08:45 PM.
 
Old 07-21-2006, 09:52 AM   #9
crashsystems
Member
 
Registered: May 2006
Location: Tennessee et. al
Distribution: Debian Sid, Etch
Posts: 138

Original Poster
Rep: Reputation: 15
I tried adding that modline you posted, but it didn't work (I probably didn't do it right). When I rebooted my laptop, xorg wouldn't start. It is a good thing that I know how to use the command line a bit, because I used it to remove the edited xorg.config and replace it with a backup file. So now I'm back up in the gui, and right back where I started.
 
Old 07-24-2006, 01:20 PM   #10
crashsystems
Member
 
Registered: May 2006
Location: Tennessee et. al
Distribution: Debian Sid, Etch
Posts: 138

Original Poster
Rep: Reputation: 15
Situation resolved!

Over the weekend I got the idea, to do the xorg config thing from the command line, as posted earlier by pljvaldez:
Code:
sudo dpkg-reconfigure xserver-xorg
However, when I did it this time, I only selected my desired resolution in the resolution mode selection part, and none of the others. When I rebooted my computer, my screen was configured exactly how I want it. Thanks to everyone who gave advice on how to solve this problem.

crashsystems
 
Old 08-11-2006, 11:29 AM   #11
seashell11
Member
 
Registered: Jul 2005
Distribution: Ubuntu Maverick
Posts: 81

Rep: Reputation: 15
Quote:
Originally Posted by jschiwal
If you were the experimental type, you could use the second dual head output, add a usb keyboard and another mouse, and set things up so that two people can operate your computer independently.
Then both your kids can be doing their homework at the same time!

Is this really possible? I would like to try it if it is.
 
Old 08-11-2006, 12:00 PM   #12
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
Quote:
Originally Posted by seashell11
Is this really possible? I would like to try it if it is.
Yup, it is. Check out this article.
 
Old 11-01-2006, 03:56 AM   #13
macgregor98
LQ Newbie
 
Registered: Oct 2006
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by crashsystems
Situation resolved!

Over the weekend I got the idea, to do the xorg config thing from the command line, as posted earlier by pljvaldez:
Code:
sudo dpkg-reconfigure xserver-xorg
However, when I did it this time, I only selected my desired resolution in the resolution mode selection part, and none of the others. When I rebooted my computer, my screen was configured exactly how I want it. Thanks to everyone who gave advice on how to solve this problem.

crashsystems
how'd u do that? I went all the way through the point where I choose what resolutions to add. im stuck as to how to enable the resolution i want.
 
Old 11-01-2006, 01:27 PM   #14
crashsystems
Member
 
Registered: May 2006
Location: Tennessee et. al
Distribution: Debian Sid, Etch
Posts: 138

Original Poster
Rep: Reputation: 15
I could be wrong, but I think the key to how I solved the problem was to make sure that only one resolution is selected when going through the setup. When you did the setup, did use select multiple resolutions, or just one?


crashsystems
 
Old 11-01-2006, 03:23 PM   #15
macgregor98
LQ Newbie
 
Registered: Oct 2006
Posts: 12

Rep: Reputation: 0
I cant even get rid of the default ones. gonna try again after work tonight
 
  


Reply

Tags
acer, display, resolution, resolved, ubuntu, xorgconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 11:52 AM
How do i fix screen resolution / monitor choice while screen is pretty much unreadabl tinkerdog Fedora 2 09-08-2006 03:53 AM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 01:33 AM
Unable to configure screen resolution for 15.2" LCD screen in Fedore Core 1 schu Linux - Newbie 3 01-02-2004 05:39 PM
screen freezes after making changes to the screen resolution with Xconfigurator sharathkv Linux - Newbie 1 08-01-2003 05:56 AM


All times are GMT -5. The time now is 05:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration