LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 08-13-2011, 12:20 PM   #1
WickDaddy
LQ Newbie
 
Registered: Aug 2011
Posts: 3

Rep: Reputation: Disabled
Sound seems to be confused with itself. Speakers work fine, headphones are buggy.


Just downloaded and installed the newest version of Ubuntu a couple of days ago, but for some reason the sound only works in a buggy way.

Sound works fine through my laptop speakers (G60VX).

Headphones: Beats by Dre (pro)(not sure if this could be the problem). They work fine in Vista.

The problem is that when I plug in my headphones all the way they play very quiet. In the Alsamixer the headphones are on "00", but there's no way to change this. It doesn't seem to be active. It will only let me mute or unmute in my other program which is the difference between the quiet sound and no sound. This again also has no way for me to turn the volume up or down.

If I plug in my headphones 75% of the way they work fine. As long as I have my speaker muted in gnome alsamixer or else I get sound through both headphones and speakers.

This is a really confusing bug as I don't get why my headphones work 75% plugged in and only give a quiet sound 100% plugged in. Is there somewhere that the speakers and headphones are confusing each other?
 
Old 08-13-2011, 12:41 PM   #2
Larry James
Member
 
Registered: Jun 2000
Location: Buffalo, New York
Distribution: Fedora, Ubuntu
Posts: 343

Rep: Reputation: 38
Quote:
Originally Posted by WickDaddy View Post
Just downloaded and installed the newest version of Ubuntu a couple of days ago, but for some reason the sound only works in a buggy way.

Sound works fine through my laptop speakers (G60VX).

Headphones: Beats by Dre (pro)(not sure if this could be the problem). They work fine in Vista.

The problem is that when I plug in my headphones all the way they play very quiet. In the Alsamixer the headphones are on "00", but there's no way to change this. It doesn't seem to be active. It will only let me mute or unmute in my other program which is the difference between the quiet sound and no sound. This again also has no way for me to turn the volume up or down.

If I plug in my headphones 75% of the way they work fine. As long as I have my speaker muted in gnome alsamixer or else I get sound through both headphones and speakers.

This is a really confusing bug as I don't get why my headphones work 75% plugged in and only give a quiet sound 100% plugged in. Is there somewhere that the speakers and headphones are confusing each other?
What do you get when you try to use the Pulseaudio controls? Pulseaudio is installed by default to Ubuntu. You would have to manually select the Alsamixer to install it. Maybe some of the components are conflecting with Pulseaudio.

Try clicking on the Speaker near the clock and check the sound preferences.

-- L. James

--
L. D. James
ljames@apollo3.com
www.apollo3.com/~ljames
 
Old 08-14-2011, 11:17 AM   #3
WickDaddy
LQ Newbie
 
Registered: Aug 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
Nothing I do seems to work. Should I uninstall pulse audio?
 
Old 08-14-2011, 11:56 AM   #4
Larry James
Member
 
Registered: Jun 2000
Location: Buffalo, New York
Distribution: Fedora, Ubuntu
Posts: 343

Rep: Reputation: 38
Quote:
Originally Posted by WickDaddy View Post
Nothing I do seems to work. Should I uninstall pulse audio?
The other way around. I've read lots of messages with sound issues. Some of them have been resolved by installing alsa and removing Pulseaudio and some the other way around. What I find common is that following the support of one over the other works.

I don't see where you did anything to try to configure Pulseaudio. I'd suggest investing the settings there to be the best start, since it's installed by default on your distro.

What do you get when you check the sound configuration by clicking the Speaker icon near the clock. You can also get there by clicking the power button -> System Settings -> Sound.

You might have more than one hardware sound device. Check the one you have selected by default and run the test option and see if it works there.

-- L. James

--
L. D. James
ljames@apollo3.com
www.apollo3.com/~ljames
 
Old 08-14-2011, 12:51 PM   #5
WickDaddy
LQ Newbie
 
Registered: Aug 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
I have default and hda intel. Neither of them seems to work.

I have an Asus motherboard if that makes a difference. I've been researching this and Asus motherboards might conflict with the sound. I checked the BIOS, but found nothing that would reflect this. I think most computers have Asus motherboards though, so might not be the problem.

Could it possibly be that since I'm plugging it in only so far I'm getting Analog only? My laptop might need a way to play digital? Am I right in saying this?

My sound settings in the speaker.
Hardware: internal audio 1-O/I Analog Stereo Duplex
Input: internal audio analog stereo
Output: internal audio analog stereo (analog headphones)
Applications: alsa plug-in (chrome)

I played around with pulseaudio in the start. I forgot to put that in there.

Last edited by WickDaddy; 08-14-2011 at 12:53 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speakers work, headphones don't tommyttt Linux - Newbie 3 01-20-2011 01:47 AM
No audio from internal speakers but headphones work matt1123 Linux - Hardware 5 10-17-2010 02:38 PM
Sound: how to switch from headphones to speakers? FreakboY Slackware 1 11-28-2007 12:59 AM
Sound from speakers not from headphones crimsontide Linux - Hardware 2 12-21-2006 08:55 AM
Can get sound from laptop speakers but not from headphones thetremorchrist Linux - Hardware 4 02-14-2004 03:43 AM


All times are GMT -5. The time now is 03:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration