LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 02-14-2006, 11:17 PM   #1
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Rep: Reputation: 30
Setting default applications in GNOME


I have looked around for this fucntion (KDE has this in the file association settings); where is it in GNOME and how do I set default settings for files: like, .wmv, .pdf, .rm, .asf, etc.

At the moment I right click and choose another application. I want to set this permenently.

Thanks,
SL
 
Old 02-15-2006, 05:02 AM   #2
Gezzer
Member
 
Registered: Jan 2006
Distribution: kubuntu
Posts: 36

Rep: Reputation: 15
r/click the file in question
properties then the tab "open with"
choose your preferred program ...
 
Old 02-15-2006, 10:37 PM   #3
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
Gezzer, is your method a system wide change? I think that only work on each individual file. He wants to change the default program system wide. If he's not talking system wide, then i'll ask.

How do you change it system wide?
 
Old 02-15-2006, 11:21 PM   #4
aysiu
Senior Member
 
Registered: May 2005
Distribution: Ubuntu with IceWM
Posts: 1,776

Rep: Reputation: 66
Quote:
Originally Posted by Penguin of Wonder
Gezzer, is your method a system wide change? I think that only work on each individual file. He wants to change the default program system wide. If he's not talking system wide, then i'll ask.

How do you change it system wide?
That method does change it system-wide. If you go to a .png file, right-click, select properties, and choose to open with GIMP as the default, all .png files will open with GIMP by default.
 
Old 02-16-2006, 09:43 AM   #5
Penguin of Wonder
Senior Member
 
Registered: Sep 2005
Location: West Virginia
Distribution: Gentoo
Posts: 1,249

Rep: Reputation: 45
It is, your right. Sorry!
 
Old 02-16-2006, 10:18 AM   #6
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
Here isa spin on the questions: say you do not have a file saved on your hard drive (say it is a .pls file); how do you then set a system wide default app for this; in KDe we have a setting called "file assciation", in this case even if you do not have a file to right click and set default app, it allows you "anticipate" any future file extensions to be loaded by the desired default app. I say this, because I have tried to force .pls files (Winamp shoutcast) to open with amaroK, but the heck thing si, it opens all the time with kaeffein (which I hate, because it can nevr find the sound driver to play, and hangs, consuming my resources, until I kill kaffien...sorry I digress).

So it would be great to set thinsg upfront so that the desired effect is anticipated.
Thanks,
 
Old 02-16-2006, 05:29 PM   #7
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Fedora, Mint, FreeBSD, Android
Posts: 346

Rep: Reputation: 31
You need to create/edit the appropriate .desktop file in this directory: /usr/share/mimelnk/application/

HTH
 
Old 02-17-2006, 07:40 AM   #8
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
could you explain further; not sure if Iget what you mean? I see I have this directory, so how and why do I do this? Many thanks,
SL
 
Old 02-22-2006, 01:58 PM   #9
bonsonno
LQ Newbie
 
Registered: Sep 2005
Location: Derby, UK
Distribution: Ubuntu
Posts: 5

Rep: Reputation: 0
Hi there smiley_lauf - I did a little playing around and it's fairly simple.

Open up a terminal and type the following:

sudo gedit /usr/share/mimelnk/audio/pls.desktop

Type in your password and it will open up a text editor.

Paste the following into it:

[Desktop Entry]
Encoding=UTF-8
Type=MimeType
MimeType=audio/mpeg
Icon=sound
Comment=pls Playlist


Then save and close. If you double click a pls file now it should by default open in rythmbox however if you want to change this, right click any pls file and select properties, go to the "Open With" tab and select whichever program you'd like to open it with.

I'm sorry if I state too many obvious things, I don't know how long you've been using linux.

Hope this helps.

Benjy
 
Old 02-25-2006, 02:12 PM   #10
smiley_lauf
Member
 
Registered: Jan 2006
Location: NY
Distribution: Fedora 15 x64
Posts: 344

Original Poster
Rep: Reputation: 30
thanks got it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting default applications in GNOME2 SUSE Linux 10 smiley_lauf Linux - Newbie 2 01-15-2006 08:33 PM
Setting default program in GNOME buskmann Linux - Software 5 05-16-2005 03:46 PM
File type associations with default applications in Gnome/FC3 mjbrej Fedora 3 12-25-2004 05:28 PM
setting default printer in Gnome? freddieB Linux - Software 0 02-25-2002 01:28 PM
Default Gnome setting for all new user accts. BlueBerry Linux - General 0 12-28-2001 01:32 PM


All times are GMT -5. The time now is 01:46 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration