LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 04-24-2005, 02:33 PM   #1
JordanH
Member
 
Registered: Oct 2003
Location: Toronto, Canada
Distribution: Ubuntu, FC3, RHEL 3-4 AS Retired: SuSE 9.1 Pro, RedHat 6-9, FC1-2
Posts: 360

Rep: Reputation: 30
Thumbs down "set bell-style none" doesn't silence my bell.


Hi All,

I have tried modifying /etc/inputrc to set my bell-style to none. It doesn't sound like it works. I have also made the change in /usr/share/base-files/inputrc just in case for some strange reason it picks up the config there. Eitherway, my system bell still beeps at me and it's driving me insane.

Any ideas how to fix this?

Currently
Ubuntu 5.04
Kernel 2.6.10-5-386
Running in VMWare 5 for now
 
Old 04-24-2005, 03:31 PM   #2
nukkel
Member
 
Registered: Mar 2003
Location: Belgium
Distribution: Hardened gentoo
Posts: 323

Rep: Reputation: 30
Try "setterm -blength 0" (in console) or "xset -b" (in X)

You can also put this in your ~/.bashrc or ~/.profile or whatever.

To totally silence the bell at boot time it may be appropriate to put "setterm -blength 0 >/dev/ttyX" in the startup scripts (a line for each terminal you wish to silence, with X the appropriate number).

The best file to put it in is a bit distro-specific I'm afraid...
 
Old 04-24-2005, 05:15 PM   #3
JordanH
Member
 
Registered: Oct 2003
Location: Toronto, Canada
Distribution: Ubuntu, FC3, RHEL 3-4 AS Retired: SuSE 9.1 Pro, RedHat 6-9, FC1-2
Posts: 360

Original Poster
Rep: Reputation: 30
That works.

As for silencing it through my virtual consoles, no sweat.

Is there a place to make this universal throughout the system for X users? I want to ensure that by default the bell is off and have my users only turn it on if they so desire.

p.s. I like your sig
Quote:
"UNIX was not designed to stop you from doing stupid things, because that would also stop you from doing clever things."
- Doug Gwyn
 
Old 04-24-2005, 05:27 PM   #4
nukkel
Member
 
Registered: Mar 2003
Location: Belgium
Distribution: Hardened gentoo
Posts: 323

Rep: Reputation: 30
Quote:
Originally posted by JordanH

Is there a place to make this universal throughout the system for X users? I want to ensure that by default the bell is off and have my users only turn it on if they so desire.
If you use a display manager (xdm, gdm, kdm, wdm, ...), somewhere in their setup directories (something like /etc/X11/xdm), there should be a script called "Xsession". This runs after a user logs into X (and ultimately runs his window manager). So this is a good place to put "xset -b" in. Users can then "xset +b" to turn the bell back on.

If your users go into X from console using "startx", then there is no system-wide place to do it; they'll have to put it in their ~/.xinitrc or ~/.xsession

Quote:
Originally posted by JordanH
p.s. I like your sig
Thx

Last edited by nukkel; 04-24-2005 at 05:29 PM.
 
Old 04-24-2005, 09:54 PM   #5
JordanH
Member
 
Registered: Oct 2003
Location: Toronto, Canada
Distribution: Ubuntu, FC3, RHEL 3-4 AS Retired: SuSE 9.1 Pro, RedHat 6-9, FC1-2
Posts: 360

Original Poster
Rep: Reputation: 30
Perfect. Thanks.
 
Old 07-10-2005, 05:39 AM   #6
stabu
Member
 
Registered: Mar 2004
Location: dublin IRL
Distribution: Slackv12.1, Slamd64v12.1,Xubuntu v8.10_64, FC8_64
Posts: 438
Blog Entries: 5

Rep: Reputation: 32
Ubuntu and inputrc

Yes, I also had this problem and though the setterm solution is fine, the worry remains about what Ubuntu actually does with /etc/inputrc.

Does it ignore it? I ran a search right now on ubuntuforums and the word inputrc got 4 results, none of which really dealt with this issue.

/etc/inputrc is pretty crucial to command line editing. Ubuntu has to be using something . Guesses?
 
Old 07-28-2005, 06:15 AM   #7
nukkel
Member
 
Registered: Mar 2003
Location: Belgium
Distribution: Hardened gentoo
Posts: 323

Rep: Reputation: 30
Sorry, I've no experience with Ubuntu...
 
Old 04-22-2014, 10:19 AM   #8
uenglert
LQ Newbie
 
Registered: Apr 2014
Posts: 1

Rep: Reputation: Disabled
Turn bell off in terminal session

Hi,

have a look for profile on gnome-terminal or for properties when
the terminal is open.
If you find a entry named terminal bell, remove the active flag.

That did help me, maybe it will help you too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error: "cannot set groups" by using "su -", pls help nelsonyuen Linux - General 14 07-31-2010 12:24 PM
"set bell-style none" won't stop my internal speaker from beeping Lokathor Debian 7 11-26-2005 01:52 PM
How to set the size of icons for "Starterbar" in "Gdekslets" Blue Jacket Linux - Software 4 11-23-2005 02:42 AM
aterm: display bell and audio bell hallamigo Linux - Software 4 05-02-2004 12:00 AM
"Fast User Switching" (XP Style) in Linux... cedillo Linux - Newbie 3 12-18-2002 12:42 AM


All times are GMT -5. The time now is 04:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration