-   Ubuntu (
-   -   set autoconfig proxy for update/apt in 7.04 (

deesto 07-13-2007 09:14 AM

set autoconfig proxy for update/apt in 7.04
Having trouble getting Synaptic or apt to update anything in 7.04 Desktop. I have an automatic proxy configuration URL that I need to enter for the proxy. I have exported this URL as the http_proxy variable in my .bash_profile (created new file) and in /etc/profile. I can also enter it in the proper field in Firefox, and that connects to the internet just fine. But I tried to enter it into the network settings for Synaptic and Update Manager, and it doesn't work.

This isn't an odd port, or a user/password combination; the URL is in the format:

None of the suggested fixes I've found (create a /etc/apt/apt.conf file, edit the /etc/apt/apt.conf.d/70debconf file, etc.) seem to work. How do I get the update software to recognize a URL like this?

hob 07-14-2007 01:08 PM

I don't think that APT supports PAC files, so you should export the actual address of the proxy, rather than specifying the URL for the PAC.

This question looks like your situation:

All times are GMT -5. The time now is 06:58 AM.